aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang-runtime15
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /lang/erlang-runtime15
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'lang/erlang-runtime15')
-rw-r--r--lang/erlang-runtime15/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index 3f0bd9680578..d297dc1f10a4 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -36,11 +36,11 @@ PLIST_SUB= ERLANG_LIB=${ERLANG_LIB}
MAKE_JOBS_UNSAFE=yes
-OPTIONS_DEFINE= GCC46 DOCS GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX DTRACE
+OPTIONS_DEFINE= GCC DOCS GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX DTRACE
OPTIONS_SINGLE= ODBC
OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
-GCC46_DESC= Use gcc 4.6
+GCC_DESC= Use current GCC
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
SCTP_DESC= Enable SCTP support
@@ -67,12 +67,12 @@ DISTFILES+= ${ERLANG_DOCS}:erlangorg
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
-.if ${ARCH} == "amd64" && ${PORT_OPTIONS:MDTRACE} && ! ${PORT_OPTIONS:MGCC46}
-IGNORE= DTRACE support on amd64 requires GCC46 option
+.if ${ARCH} == "amd64" && ${PORT_OPTIONS:MDTRACE} && ! ${PORT_OPTIONS:MGCC}
+IGNORE= DTRACE support on amd64 requires GCC option
.endif
-.if ${PORT_OPTIONS:MGCC46}
-USE_GCC?= 4.6+
+.if ${PORT_OPTIONS:MGCC}
+USE_GCC?= yes
.endif
.if ${PORT_OPTIONS:MDTRACE}