aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang14/files
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2002-11-03 02:40:49 +0800
committerolgeni <olgeni@FreeBSD.org>2002-11-03 02:40:49 +0800
commit481e2a1009ce1450183dde2ec64f3f0e0e142892 (patch)
treedc1c2ecfcf320fc7eae9de107b90fbe0508a368d /lang/erlang14/files
parentca916139fefb20abff4fcd259914971bdfe24c68 (diff)
downloadfreebsd-ports-gnome-481e2a1009ce1450183dde2ec64f3f0e0e142892.tar.gz
freebsd-ports-gnome-481e2a1009ce1450183dde2ec64f3f0e0e142892.tar.zst
freebsd-ports-gnome-481e2a1009ce1450183dde2ec64f3f0e0e142892.zip
Update to version R9B-0, use ${SHAREOWN}:${SHAREGRP} rather
than hardcoding root:wheel.
Diffstat (limited to 'lang/erlang14/files')
-rw-r--r--lang/erlang14/files/patch-ac27
-rw-r--r--lang/erlang14/files/patch-af19
-rw-r--r--lang/erlang14/files/patch-ag33
-rw-r--r--lang/erlang14/files/patch-ah84
-rw-r--r--lang/erlang14/files/patch-ai12
-rw-r--r--lang/erlang14/files/patch-aj4
-rw-r--r--lang/erlang14/files/patch-an26
-rw-r--r--lang/erlang14/files/patch-ap7
-rw-r--r--lang/erlang14/files/patch-erts_boot_src_Makefile11
-rw-r--r--lang/erlang14/files/patch-erts_configure11
-rw-r--r--lang/erlang14/files/patch-erts_configure.in11
-rw-r--r--lang/erlang14/files/patch-lib_erl__interface_src_configure.in10
12 files changed, 48 insertions, 207 deletions
diff --git a/lang/erlang14/files/patch-ac b/lang/erlang14/files/patch-ac
deleted file mode 100644
index b574011d6429..000000000000
--- a/lang/erlang14/files/patch-ac
+++ /dev/null
@@ -1,27 +0,0 @@
---- erts/etc/common/Makefile.in.orig Tue Nov 28 20:41:14 2000
-+++ erts/etc/common/Makefile.in Tue Nov 28 20:46:05 2000
-@@ -65,6 +65,7 @@
- INSTALL = @INSTALL@
- INSTALL_DIR = $(INSTALL) -d
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
-+INSTALL_SCRIPT = @INSTALL_SCRIPT@
- INSTALL_DATA = @INSTALL_DATA@
-
- ifeq ($(findstring solaris,$(TARGET)),solaris)
-@@ -238,13 +239,13 @@
- endif
- $(INSTALL_DIR) $(RELEASE_PATH)/erts-$(VSN)/bin
- ifneq ($(findstring vxworks,$(TARGET)), vxworks)
-- $(INSTALL_PROGRAM) erl.src $(RELEASE_PATH)/erts-$(VSN)/bin
-+ $(INSTALL_SCRIPT) erl.src $(RELEASE_PATH)/erts-$(VSN)/bin
- endif
- $(INSTALL_PROGRAM) $(INSTALL_PROGS) $(RELEASE_PATH)/erts-$(VSN)/bin
-- $(INSTALL_PROGRAM) $(INSTALL_TOP) $(RELEASE_PATH)
-+ $(INSTALL_SCRIPT) $(INSTALL_TOP) $(RELEASE_PATH)
- ifneq ($(INSTALL_MISC),)
- $(INSTALL_DIR) $(RELEASE_PATH)/misc
-- $(INSTALL_PROGRAM) $(INSTALL_MISC) $(RELEASE_PATH)/misc
-+ $(INSTALL_SCRIPT) $(INSTALL_MISC) $(RELEASE_PATH)/misc
- endif
- ifneq ($(INSTALL_SRC),)
- $(INSTALL_DIR) $(RELEASE_PATH)/erts-$(VSN)/src
diff --git a/lang/erlang14/files/patch-af b/lang/erlang14/files/patch-af
deleted file mode 100644
index 4e20d048f0aa..000000000000
--- a/lang/erlang14/files/patch-af
+++ /dev/null
@@ -1,19 +0,0 @@
---- lib/os_mon/c_src/Makefile.in.orig Tue Nov 23 16:14:47 1999
-+++ lib/os_mon/c_src/Makefile.in Sat Dec 2 22:35:09 2000
-@@ -53,6 +53,7 @@
- PROGRAMS = \
- memsup @os_mon_programs@
- C_FILES= $(PROGRAMS:%=%.c)
-+LKSTAT= @os_mon_kstat@
- endif
-
- TARGET_FILES= $(PROGRAMS:%=$(BINDIR)/%)
-@@ -97,7 +98,7 @@
- $(LD) $(LDFLAGS) -o $@ $<
-
- $(BINDIR)/cpu_sup: $(OBJDIR)/cpu_sup.o
-- $(LD) $(LDFLAGS) -o $@ $< -lkstat
-+ $(LD) $(LDFLAGS) -o $@ $< $(LKSTAT)
-
- $(OBJDIR)/%.o: %.c
- $(CC) -c -o $@ $(ALL_CFLAGS) $<
diff --git a/lang/erlang14/files/patch-ag b/lang/erlang14/files/patch-ag
deleted file mode 100644
index b32003f79b65..000000000000
--- a/lang/erlang14/files/patch-ag
+++ /dev/null
@@ -1,33 +0,0 @@
---- lib/os_mon/c_src/memsup.c.orig Mon Sep 20 23:05:24 1999
-+++ lib/os_mon/c_src/memsup.c Sat Dec 2 22:23:25 2000
-@@ -89,6 +89,12 @@
- #include <ioLib.h>
- #include <memLib.h>
- #endif
-+#ifdef __FreeBSD__
-+#include <sys/types.h>
-+#include <sys/sysctl.h>
-+#include <sys/vmmeter.h>
-+#include <vm/vm_param.h>
-+#endif
-
- /* commands */
- #include "memsup.h"
-@@ -172,6 +178,16 @@
- load_statistics();
- *tot = (latest.numBytesFree + latest.numBytesAlloc) >> shiftleft;
- *used = latest.numBytesAlloc >> shiftleft;
-+#elif defined(__FreeBSD__)
-+ int mib[2];
-+ size_t len;
-+ struct vmtotal memory;
-+ mib[0] = CTL_VM;
-+ mib[1] = VM_METER;
-+ len = sizeof memory;
-+ sysctl(mib, 2, &memory, &len, NULL, 0);
-+ *tot = memory.t_vm >> shiftleft;
-+ *used = memory.t_avm >> shiftleft;
- #elif defined(_SC_AVPHYS_PAGES) /* Does this exist on others than Solaris2? */
- unsigned long avPhys, phys, pgSz;
-
-# End
diff --git a/lang/erlang14/files/patch-ah b/lang/erlang14/files/patch-ah
deleted file mode 100644
index 7da039d6bdf1..000000000000
--- a/lang/erlang14/files/patch-ah
+++ /dev/null
@@ -1,84 +0,0 @@
---- lib/os_mon/c_src/cpu_sup.c.orig Sat Dec 2 22:12:38 2000
-+++ lib/os_mon/c_src/cpu_sup.c Sat Dec 2 22:47:11 2000
-@@ -26,7 +26,14 @@
- */
-
- #include<stdio.h>
-+#ifdef __FreeBSD__
-+#include <sys/types.h>
-+#include <sys/sysctl.h>
-+#include <sys/param.h>
-+#include <sys/user.h>
-+#else
- #include<kstat.h>
-+#endif
-
- #define FD_IN 0
- #define FD_OUT 1
-@@ -45,20 +52,23 @@
- static void send(unsigned int data);
- static void error(char* err_msg);
-
-+#ifndef __FreeBSD__
- static kstat_ctl_t *kc;
- static kstat_t *ks;
-+#endif
-
- int main(int argc, char** argv) {
-- kid_t kid;
- char cmd;
- int rc;
-+#ifndef __FreeBSD__
-+ kid_t kid;
-
- kc = kstat_open();
- if(!kc) error("Can't open header kstat");
-
- ks = kstat_lookup(kc,"unix",0,"system_misc");
- if(!ks) error("Can't open system_misc kstat");
--
-+#endif
-
- while(1) {
- rc = read(FD_IN, &cmd, sizeof(cmd));
-@@ -79,6 +89,32 @@
- }
-
- static unsigned int measure(char* name) {
-+#ifdef __FreeBSD__
-+ size_t len;
-+ int mib[3];
-+ if (!strcmp (name, "nproc")) {
-+ mib[0] = CTL_KERN;
-+ mib[1] = KERN_PROC;
-+ mib[2] = KERN_PROC_ALL;
-+ sysctl(mib, 3, NULL, &len, NULL, 0);
-+ return len/sizeof(struct kinfo_proc);
-+ } else {
-+ struct loadavg load;
-+ mib[0] = CTL_VM;
-+ mib[1] = VM_LOADAVG;
-+ len = sizeof load;
-+ sysctl(mib, 2, &load, &len, NULL, 0);
-+ if (!strcmp (name, "avenrun_1min")) {
-+ return load.ldavg[0] * 256 / load.fscale;
-+ } else if (!strcmp (name, "avenrun_5min")) {
-+ return load.ldavg[1] * 256 / load.fscale;
-+ } else if (!strcmp (name, "avenrun_15min")) {
-+ return load.ldavg[2] * 256 / load.fscale;
-+ } else {
-+ return -1;
-+ }
-+ }
-+#else
- kstat_named_t* entry;
-
- kstat_read(kc,ks,NULL);
-@@ -90,6 +126,7 @@
- return -1;
-
- return entry->value.ul;
-+#endif
- }
-
- static void send(unsigned int data) {
diff --git a/lang/erlang14/files/patch-ai b/lang/erlang14/files/patch-ai
deleted file mode 100644
index 6be7b984151f..000000000000
--- a/lang/erlang14/files/patch-ai
+++ /dev/null
@@ -1,12 +0,0 @@
---- lib/os_mon/c_src/ferrule.c.orig Sat Dec 2 22:13:49 2000
-+++ lib/os_mon/c_src/ferrule.c Sat Dec 2 22:14:03 2000
-@@ -17,7 +17,9 @@
- */
- #include <stdio.h>
- #include <string.h>
-+#ifndef __FreeBSD__
- #include <stropts.h>
-+#endif
- #include <poll.h>
- #include <unistd.h>
- #include <sys/types.h>
diff --git a/lang/erlang14/files/patch-aj b/lang/erlang14/files/patch-aj
index 2efd40c6460c..c737dadeb146 100644
--- a/lang/erlang14/files/patch-aj
+++ b/lang/erlang14/files/patch-aj
@@ -1,5 +1,5 @@
---- ./erts/etc/unix/Install.src.orig Wed Jan 17 17:18:57 2001
-+++ ./erts/etc/unix/Install.src Wed Jan 17 17:35:40 2001
+--- erts/etc/unix/Install.src.orig Tue Oct 15 13:40:55 2002
++++ erts/etc/unix/Install.src Sat Nov 2 15:43:51 2002
@@ -97,7 +97,8 @@
chmod 755 start_erl
fi
diff --git a/lang/erlang14/files/patch-an b/lang/erlang14/files/patch-an
deleted file mode 100644
index 1a0ed1951434..000000000000
--- a/lang/erlang14/files/patch-an
+++ /dev/null
@@ -1,26 +0,0 @@
---- erts/configure.in.orig Mon Oct 8 10:36:08 2001
-+++ erts/configure.in Sun Jan 20 16:06:23 2002
-@@ -436,7 +436,7 @@
- dnl ----------------------------------------------------------------------
-
- AC_CHECK_FUNCS([ieee_handler fpsetmask finite res_gethostbyname dlopen \
-- poll pread pwrite writev memmove strerror strncasecmp \
-+ poll pread pwrite writev memmove strerror strerror_r strncasecmp \
- gethrtime localtime_r gmtime_r mremap memcpy mallopt])
- AC_FUNC_SETVBUF_REVERSED
- AC_FUNC_VFORK
-@@ -886,10 +886,13 @@
- # Os mon stuff.
- #--------------------------------------------------------------------
- AC_SUBST(os_mon_programs)
--AC_CHECK_LIB(kstat, kstat_open, [os_mon_programs="$os_mon_programs cpu_sup"])
-+AC_SUBST(os_mon_kstat)
-+AC_CHECK_LIB(kstat, kstat_open, [os_mon_kstat="-lkstat", os_mon_programs="$os_mon_programs cpu_sup"])
- case $host_os in
- solaris2*)
- os_mon_programs="$os_mon_programs ferrule mod_syslog" ;;
-+ freebsd*)
-+ os_mon_programs="$os_mon_programs cpu_sup ferrule mod_syslog" ;;
- esac
-
-
diff --git a/lang/erlang14/files/patch-ap b/lang/erlang14/files/patch-ap
index bb3e0ba3c4ab..051d70948357 100644
--- a/lang/erlang14/files/patch-ap
+++ b/lang/erlang14/files/patch-ap
@@ -1,6 +1,6 @@
---- erts/config.h.in.orig Thu Mar 28 21:53:19 2002
-+++ erts/config.h.in Thu Mar 28 21:54:07 2002
-@@ -211,6 +211,9 @@
+--- erts/config.h.in.orig Wed Oct 16 10:41:05 2002
++++ erts/config.h.in Sat Nov 2 15:43:51 2002
+@@ -258,6 +258,9 @@
/* Define if you have the strerror function. */
#undef HAVE_STRERROR
@@ -9,4 +9,3 @@
+
/* Define if you have the strncasecmp function. */
#undef HAVE_STRNCASECMP
-
diff --git a/lang/erlang14/files/patch-erts_boot_src_Makefile b/lang/erlang14/files/patch-erts_boot_src_Makefile
new file mode 100644
index 000000000000..75729da81402
--- /dev/null
+++ b/lang/erlang14/files/patch-erts_boot_src_Makefile
@@ -0,0 +1,11 @@
+--- erts/boot/src/Makefile.orig Sat Nov 2 16:15:36 2002
++++ erts/boot/src/Makefile Sat Nov 2 16:16:17 2002
+@@ -103,7 +103,7 @@
+ $(INSTALL_DIR) $(RELSYSDIR)
+ $(INSTALL_DATA) erlang.ear $(RELSYSDIR)/erlang.ear
+ $(INSTALL_DIR) $(RELSYSDIR)/bin
+- $(INSTALL_PROGRAM) ecc elink escript ear esh $(RELSYSDIR)/bin
++ $(INSTALL_SCRIPT) ecc elink escript ear esh $(RELSYSDIR)/bin
+ endif
+
+ bootstrap: ${BEAM} ${FAKES} elink
diff --git a/lang/erlang14/files/patch-erts_configure b/lang/erlang14/files/patch-erts_configure
new file mode 100644
index 000000000000..7ecc4f41d310
--- /dev/null
+++ b/lang/erlang14/files/patch-erts_configure
@@ -0,0 +1,11 @@
+--- erts/configure.orig Wed Oct 16 10:41:01 2002
++++ erts/configure Sat Nov 2 15:43:52 2002
+@@ -3960,7 +3960,7 @@
+
+
+ for ac_func in ieee_handler fpsetmask finite isnan isinf res_gethostbyname dlopen \
+- poll pread pwrite writev memmove strerror strncasecmp \
++ poll pread pwrite writev memmove strerror strerror_r strncasecmp \
+ gethrtime localtime_r gmtime_r mremap memcpy mallopt
+ do
+ echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
diff --git a/lang/erlang14/files/patch-erts_configure.in b/lang/erlang14/files/patch-erts_configure.in
new file mode 100644
index 000000000000..a81d2ede3fe4
--- /dev/null
+++ b/lang/erlang14/files/patch-erts_configure.in
@@ -0,0 +1,11 @@
+--- erts/configure.in.orig Thu Oct 10 16:18:27 2002
++++ erts/configure.in Sat Nov 2 15:43:51 2002
+@@ -546,7 +546,7 @@
+ dnl ----------------------------------------------------------------------
+
+ AC_CHECK_FUNCS([ieee_handler fpsetmask finite isnan isinf res_gethostbyname dlopen \
+- poll pread pwrite writev memmove strerror strncasecmp \
++ poll pread pwrite writev memmove strerror strerror_r strncasecmp \
+ gethrtime localtime_r gmtime_r mremap memcpy mallopt])
+ AC_FUNC_SETVBUF_REVERSED
+ AC_FUNC_VFORK
diff --git a/lang/erlang14/files/patch-lib_erl__interface_src_configure.in b/lang/erlang14/files/patch-lib_erl__interface_src_configure.in
new file mode 100644
index 000000000000..feda49221378
--- /dev/null
+++ b/lang/erlang14/files/patch-lib_erl__interface_src_configure.in
@@ -0,0 +1,10 @@
+--- lib/erl_interface/src/configure.in.orig Fri Sep 22 16:09:38 2000
++++ lib/erl_interface/src/configure.in Sat Nov 2 15:43:51 2002
+@@ -28,7 +28,7 @@
+ AC_FUNC_MEMCMP
+ AC_TYPE_SIGNAL
+ AC_FUNC_VPRINTF
+-AC_CHECK_FUNCS(gethostname gettimeofday select socket strdup strerror strstr uname)
++AC_CHECK_FUNCS(gethostname gettimeofday select socket strdup strerror strerror_r strstr uname)
+
+ AC_OUTPUT(GNUmakefile)