aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang14/files
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2002-03-31 18:23:43 +0800
committerolgeni <olgeni@FreeBSD.org>2002-03-31 18:23:43 +0800
commit6a681f70d0e57d2004c56a39f026722b614d7911 (patch)
treea375671d4851151d1626b4a63c969f4fa634666d /lang/erlang14/files
parent1cdccb0998e736af7a2e912521598fb1220762aa (diff)
downloadfreebsd-ports-gnome-6a681f70d0e57d2004c56a39f026722b614d7911.tar.gz
freebsd-ports-gnome-6a681f70d0e57d2004c56a39f026722b614d7911.tar.zst
freebsd-ports-gnome-6a681f70d0e57d2004c56a39f026722b614d7911.zip
Update port to version 8.0 (R8B-0).
Remove my code to handle the documentation merge for patched releases, it was rather obscure and error-prone. I'll rewrite it in a simpler way next time I'll need to perform the merge. Also include a fix for erlang-mode under emacs21 (by Hal Snyder <hal@vailsys.com> on the erlang mailing list).
Diffstat (limited to 'lang/erlang14/files')
-rw-r--r--lang/erlang14/files/patch-ad21
-rw-r--r--lang/erlang14/files/patch-ae18
-rw-r--r--lang/erlang14/files/patch-al19
-rw-r--r--lang/erlang14/files/patch-am11
-rw-r--r--lang/erlang14/files/patch-an26
-rw-r--r--lang/erlang14/files/patch-ao10
-rw-r--r--lang/erlang14/files/patch-ap12
-rw-r--r--lang/erlang14/files/patch-aq11
-rw-r--r--lang/erlang14/files/post-patch-configure10
9 files changed, 80 insertions, 58 deletions
diff --git a/lang/erlang14/files/patch-ad b/lang/erlang14/files/patch-ad
deleted file mode 100644
index cb87f5b64db0..000000000000
--- a/lang/erlang14/files/patch-ad
+++ /dev/null
@@ -1,21 +0,0 @@
---- lib/os_mon/src/disksup.erl.orig Sat Dec 2 22:19:26 2000
-+++ lib/os_mon/src/disksup.erl Sat Dec 2 22:19:34 2000
-@@ -81,6 +81,9 @@
- check_disk_space(State) when State#state.os == {unix, solaris} ->
- Result = os:cmd("/usr/bin/df -lk"),
- check_disks_solaris(skip_to_eol(Result), State#state.threshold);
-+check_disk_space(State) when State#state.os == {unix, freebsd} ->
-+ Result = os:cmd("/bin/df -k -t ufs"),
-+ check_disks_solaris(skip_to_eol(Result), State#state.threshold);
- check_disk_space(State) when State#state.os == {unix, sunos4} ->
- Result = os:cmd("df"),
- check_disks_solaris(skip_to_eol(Result), State#state.threshold).
-@@ -162,6 +165,8 @@
- {4,_,_} -> {unix, sunos4};
- V -> exit({{unknown_os_version, V}, {disk_sup, get_os, []}})
- end;
-+ {unix, freebsd} ->
-+ {unix, freebsd};
- {win32,W} ->
- {win32,W};
- Type ->
diff --git a/lang/erlang14/files/patch-ae b/lang/erlang14/files/patch-ae
deleted file mode 100644
index f4d48694e46f..000000000000
--- a/lang/erlang14/files/patch-ae
+++ /dev/null
@@ -1,18 +0,0 @@
---- erts/autoconf/configure.in.orig Sat Dec 2 22:27:49 2000
-+++ erts/autoconf/configure.in Sat Dec 2 22:34:30 2000
-@@ -638,10 +638,13 @@
- # Os mon stuff.
- #--------------------------------------------------------------------
- AC_SUBST(os_mon_programs)
--AC_CHECK_LIB(kstat, kstat_open, [os_mon_programs="$os_mon_programs cpu_sup"])
-+AC_SUBST(os_mon_kstat)
-+AC_CHECK_LIB(kstat, kstat_open, [os_mon_kstat="-lkstat", os_mon_programs="$os_mon_programs cpu_sup"])
- case $host_os in
- solaris2*)
- os_mon_programs="$os_mon_programs ferrule mod_syslog" ;;
-+ freebsd*)
-+ os_mon_programs="$os_mon_programs cpu_sup ferrule mod_syslog" ;;
- esac
-
-
-# End
diff --git a/lang/erlang14/files/patch-al b/lang/erlang14/files/patch-al
deleted file mode 100644
index a29f371c3b52..000000000000
--- a/lang/erlang14/files/patch-al
+++ /dev/null
@@ -1,19 +0,0 @@
---- lib/erl_interface/src/erl_error.c.orig Thu Feb 7 21:29:56 2002
-+++ lib/erl_interface/src/erl_error.c Thu Feb 7 21:32:55 2002
-
-@@ -177,6 +177,7 @@
- }
- #endif /* !HAVE_STRERROR */
-
-+#ifdef 0
- #ifndef HAVE_STRERROR_R
- /*
- * A reentrant form of strerror. It's a GNU extension originally.
-@@ -218,6 +219,7 @@
- return buf;
- }
- #endif /* !HAVE_STRERROR_R */
-+#endif
-
-
- /* Print a message and return to caller.
diff --git a/lang/erlang14/files/patch-am b/lang/erlang14/files/patch-am
new file mode 100644
index 000000000000..268f1f53eeec
--- /dev/null
+++ b/lang/erlang14/files/patch-am
@@ -0,0 +1,11 @@
+--- lib/mnesia/examples/Makefile.orig Sun Dec 2 19:00:59 2001
++++ lib/mnesia/examples/Makefile Sun Dec 2 19:01:32 2001
+@@ -95,7 +95,7 @@
+ bench.config6 \
+ bench.config7 \
+ $(RELSYSDIR)/examples/bench)
+- (cd bench; $(INSTALL_PROGRAM) bench.sh $(RELSYSDIR)/examples/bench)
++ (cd bench; $(INSTALL_SCRIPT) bench.sh $(RELSYSDIR)/examples/bench)
+
+ release_docs_spec:
+
diff --git a/lang/erlang14/files/patch-an b/lang/erlang14/files/patch-an
new file mode 100644
index 000000000000..1a0ed1951434
--- /dev/null
+++ b/lang/erlang14/files/patch-an
@@ -0,0 +1,26 @@
+--- erts/configure.in.orig Mon Oct 8 10:36:08 2001
++++ erts/configure.in Sun Jan 20 16:06:23 2002
+@@ -436,7 +436,7 @@
+ dnl ----------------------------------------------------------------------
+
+ AC_CHECK_FUNCS([ieee_handler fpsetmask finite res_gethostbyname dlopen \
+- poll pread pwrite writev memmove strerror strncasecmp \
++ poll pread pwrite writev memmove strerror strerror_r strncasecmp \
+ gethrtime localtime_r gmtime_r mremap memcpy mallopt])
+ AC_FUNC_SETVBUF_REVERSED
+ AC_FUNC_VFORK
+@@ -886,10 +886,13 @@
+ # Os mon stuff.
+ #--------------------------------------------------------------------
+ AC_SUBST(os_mon_programs)
+-AC_CHECK_LIB(kstat, kstat_open, [os_mon_programs="$os_mon_programs cpu_sup"])
++AC_SUBST(os_mon_kstat)
++AC_CHECK_LIB(kstat, kstat_open, [os_mon_kstat="-lkstat", os_mon_programs="$os_mon_programs cpu_sup"])
+ case $host_os in
+ solaris2*)
+ os_mon_programs="$os_mon_programs ferrule mod_syslog" ;;
++ freebsd*)
++ os_mon_programs="$os_mon_programs cpu_sup ferrule mod_syslog" ;;
+ esac
+
+
diff --git a/lang/erlang14/files/patch-ao b/lang/erlang14/files/patch-ao
new file mode 100644
index 000000000000..d7632c35fe0d
--- /dev/null
+++ b/lang/erlang14/files/patch-ao
@@ -0,0 +1,10 @@
+--- make/otp.mk.in.orig Fri Dec 7 17:59:22 2001
++++ make/otp.mk.in Fri Dec 7 17:59:32 2001
+@@ -41,6 +41,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DIR = @INSTALL_DIR@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_DATA = @INSTALL_DATA@
+
+ CC = @CC@
diff --git a/lang/erlang14/files/patch-ap b/lang/erlang14/files/patch-ap
new file mode 100644
index 000000000000..bb3e0ba3c4ab
--- /dev/null
+++ b/lang/erlang14/files/patch-ap
@@ -0,0 +1,12 @@
+--- erts/config.h.in.orig Thu Mar 28 21:53:19 2002
++++ erts/config.h.in Thu Mar 28 21:54:07 2002
+@@ -211,6 +211,9 @@
+ /* Define if you have the strerror function. */
+ #undef HAVE_STRERROR
+
++/* Define if you have the strerror_r function. */
++#undef HAVE_STRERROR_R
++
+ /* Define if you have the strncasecmp function. */
+ #undef HAVE_STRNCASECMP
+
diff --git a/lang/erlang14/files/patch-aq b/lang/erlang14/files/patch-aq
new file mode 100644
index 000000000000..9c4fbac0aa59
--- /dev/null
+++ b/lang/erlang14/files/patch-aq
@@ -0,0 +1,11 @@
+--- lib/emacs/erlang.el.orig Sun Mar 31 11:42:59 2002
++++ lib/emacs/erlang.el Sun Mar 31 11:42:49 2002
+@@ -5242,7 +5242,7 @@
+ (let ((msg nil))
+ (while (save-excursion
+ (goto-char (process-mark inferior-erlang-process))
+- (beginning-of-line)
++ (forward-line 0)
+ (not (looking-at comint-prompt-regexp)))
+ (if msg
+ ()
diff --git a/lang/erlang14/files/post-patch-configure b/lang/erlang14/files/post-patch-configure
new file mode 100644
index 000000000000..355f4493a797
--- /dev/null
+++ b/lang/erlang14/files/post-patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Fri Dec 7 16:13:39 2001
++++ configure Fri Dec 7 16:19:33 2001
+@@ -1081,6 +1081,7 @@
+ *) # Relative path.
+ ac_sub_cache_file="$ac_dots$cache_file" ;;
+ esac
++ ac_given_INSTALL="$INSTALL"
+ case "$ac_given_INSTALL" in
+ [/$]*) INSTALL="$ac_given_INSTALL" ;;
+ *) INSTALL="$ac_dots$ac_given_INSTALL" ;;