aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang14
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-09 01:14:55 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-09 01:14:55 +0800
commit35c0846b4dd6eec7fbebfb123b1bacd876bb03c3 (patch)
treeea526c275edff8c5f04551045e46c19d93f3105b /lang/erlang14
parentc7d7b7ca4a70bbe7ad1bebd791b15e9d4eb52ff8 (diff)
downloadfreebsd-ports-gnome-35c0846b4dd6eec7fbebfb123b1bacd876bb03c3.tar.gz
freebsd-ports-gnome-35c0846b4dd6eec7fbebfb123b1bacd876bb03c3.tar.zst
freebsd-ports-gnome-35c0846b4dd6eec7fbebfb123b1bacd876bb03c3.zip
Move the USE_* variables before the inclusion of bsd.port.pre.mk to fix
building in the new bsd.perl.mk order.
Diffstat (limited to 'lang/erlang14')
-rw-r--r--lang/erlang14/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 8863af4f8b03..3efd3785456f 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -49,6 +49,13 @@ SCRIPT_ENV+= PATH=${PATH}:${JAVA_HOME}/bin
USE_TK_RUN= yes
.endif
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_RC_SUBR= epmd.sh
+GNU_CONFIGURE= yes
+ONLY_FOR_ARCHS= i386 amd64
+REINPLACE_ARGS= -i
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 502102
@@ -70,13 +77,6 @@ ERLANG_DOCS= otp_doc_html_R11B-5.tar.gz
.endif
ERLANG_PLIST= ${WRKDIR}/pkg-plist
-USE_GMAKE= yes
-USE_PERL5= yes
-USE_RC_SUBR= epmd.sh
-GNU_CONFIGURE= yes
-ONLY_FOR_ARCHS= i386 amd64
-REINPLACE_ARGS= -i
-
CONFIGURE_TARGET= # Empty
CONFIGURE_ARGS+= --enable-threads
NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"