aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang14
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2004-03-12 04:10:53 +0800
committerolgeni <olgeni@FreeBSD.org>2004-03-12 04:10:53 +0800
commite6a1da8ec69c5fdb43f98638e960f7cb7d8c5553 (patch)
tree41e582cd5881e70543e5fc28229ad336c6506c38 /lang/erlang14
parenta8cafdd62074ef1967a2c5c995dde8932faba11e (diff)
downloadfreebsd-ports-gnome-e6a1da8ec69c5fdb43f98638e960f7cb7d8c5553.tar.gz
freebsd-ports-gnome-e6a1da8ec69c5fdb43f98638e960f7cb7d8c5553.tar.zst
freebsd-ports-gnome-e6a1da8ec69c5fdb43f98638e960f7cb7d8c5553.zip
Unbreak filelib:fold_files/6, add missing clause.
Obtained from: Dominic Williams (on erlang-questions)
Diffstat (limited to 'lang/erlang14')
-rw-r--r--lang/erlang14/Makefile2
-rw-r--r--lang/erlang14/files/patch-lib_stdlib_src_filelib.erl17
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 52e7fcaffee6..9f9eb56087fd 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r9c0
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.erlang.org/pub/download/ \
diff --git a/lang/erlang14/files/patch-lib_stdlib_src_filelib.erl b/lang/erlang14/files/patch-lib_stdlib_src_filelib.erl
new file mode 100644
index 000000000000..2b26e8e6c039
--- /dev/null
+++ b/lang/erlang14/files/patch-lib_stdlib_src_filelib.erl
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- lib/stdlib/src/filelib.erl.orig Thu Mar 11 21:05:33 2004
++++ lib/stdlib/src/filelib.erl Thu Mar 11 21:06:40 2004
+@@ -84,7 +84,10 @@
+ false ->
+ fold_files(T, Dir, RegExp, Recursive, Fun, Acc0)
+ end
+- end.
++ end;
++
++fold_files([], _, _, _, _, Acc) ->
++ Acc.
+
+ last_modified(File) ->
+ case file:read_file_info(File) of