aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2002-07-15 16:56:26 +0800
committerolgeni <olgeni@FreeBSD.org>2002-07-15 16:56:26 +0800
commit0b7d6d8a7b34995e3fb6b905e54841abbb7770d5 (patch)
tree516b9419b90a24bc05213646be3d35a145cea117 /lang/erlang
parentbbc16c84fc4f8c87a042c7173791f4c64a0ca043 (diff)
downloadfreebsd-ports-gnome-0b7d6d8a7b34995e3fb6b905e54841abbb7770d5.tar.gz
freebsd-ports-gnome-0b7d6d8a7b34995e3fb6b905e54841abbb7770d5.tar.zst
freebsd-ports-gnome-0b7d6d8a7b34995e3fb6b905e54841abbb7770d5.zip
chown lib/erlang to root:wheel with proper permissions, do not use bogus
uids from the documentation tarball.
Diffstat (limited to 'lang/erlang')
-rw-r--r--lang/erlang/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index ad9f8877fbb4..58e085c867f0 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -102,6 +102,8 @@ post-install:
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_DOCS} \
-C ${PREFIX}/lib/erlang
.endif
+ @${CHOWN} -R root:wheel ${PREFIX}/lib/erlang
+ @${CHMOD} -R o+rX-w,g+rX-w ${PREFIX}/lib/erlang
@sslapp=`ls -d ${PREFIX}/lib/erlang/lib/ssl-* | tail -1`; \
cd $$sslapp/priv/obj && ${MAKE} && strip ../bin/ssl_esock
@cd ${PREFIX} ; find lib/erlang/* -type f -o -type l \