aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2008-11-02 03:09:27 +0800
committerolgeni <olgeni@FreeBSD.org>2008-11-02 03:09:27 +0800
commit7ad7652bfeff80f21ea07b0c71f41063c2945645 (patch)
tree07d15f7fdcf8d3efd84c70b003365bfa6c22486f /lang/erlang
parenta85874cee0606ca7771b209f8cc1ffaf80743bf8 (diff)
downloadfreebsd-ports-gnome-7ad7652bfeff80f21ea07b0c71f41063c2945645.tar.gz
freebsd-ports-gnome-7ad7652bfeff80f21ea07b0c71f41063c2945645.tar.zst
freebsd-ports-gnome-7ad7652bfeff80f21ea07b0c71f41063c2945645.zip
Unbreak SCTP support and bump PORTREVISION.
Diffstat (limited to 'lang/erlang')
-rw-r--r--lang/erlang/Makefile3
-rw-r--r--lang/erlang/files/patch-erts_configure22
2 files changed, 24 insertions, 1 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index faa8429dfe00..0530f36a3a82 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -7,6 +7,7 @@
PORTNAME= erlang
PORTVERSION= r12b4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/ \
@@ -82,7 +83,7 @@ ERLANG_DOCS= otp_doc_html_R12B-4.tar.gz
.endif
ERLANG_PLIST= ${WRKDIR}/pkg-plist
-CONFIGURE_ARGS+= --enable-threads --enable-dynamic-ssl-lib
+CONFIGURE_ARGS+= --enable-threads --enable-dynamic-ssl-lib --enable-sctp
NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
CFLAGS+= -I${LOCALBASE}/include
diff --git a/lang/erlang/files/patch-erts_configure b/lang/erlang/files/patch-erts_configure
new file mode 100644
index 000000000000..5c4b25a5b0c9
--- /dev/null
+++ b/lang/erlang/files/patch-erts_configure
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- erts/configure.orig
++++ erts/configure
+@@ -10620,7 +10620,7 @@
+
+
+
+-if test "x$enable_sctp" == "xyes" ; then
++if test "x$enable_sctp" = "xyes" ; then
+ echo "$as_me:$LINENO: checking for netinet/sctp.h" >&5
+ echo $ECHO_N "checking for netinet/sctp.h... $ECHO_C" >&6
+ if test "${ac_cv_header_netinet_sctp_h+set}" = set; then
+@@ -10679,7 +10679,6 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lsctp $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF