aboutsummaryrefslogtreecommitdiffstats
path: root/lang/execline
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2003-10-25 05:41:31 +0800
committersergei <sergei@FreeBSD.org>2003-10-25 05:41:31 +0800
commit0f3baa266707c97bd1a1a9000beb52f48d281f91 (patch)
tree35770c702d9ac28aaf8421aa3a48c6f2cd675d8d /lang/execline
parent1593059bce03d22c291745485a79c136316d327e (diff)
downloadfreebsd-ports-gnome-0f3baa266707c97bd1a1a9000beb52f48d281f91.tar.gz
freebsd-ports-gnome-0f3baa266707c97bd1a1a9000beb52f48d281f91.tar.zst
freebsd-ports-gnome-0f3baa266707c97bd1a1a9000beb52f48d281f91.zip
Add execline 1.05:
execline is a very light non-interactive scripting language, which is similar to /bin/sh. Simple shell scripts can be easily rewritten in the execline language, improving performance and memory usage. execline was designed for use in embedded systems, but works on most Unix flavors. execline features conditional loops, getopt-style option handling, filename globbing, and more. Meanwhile, its syntax is far more logical and predictable than the shell's syntax, and has no security issues. Author: Laurent G. Bercot <ska-skaware@skarnet.org> WWW: http://www.skarnet.org/software/execline/ Approved by: krion (implicit)
Diffstat (limited to 'lang/execline')
-rw-r--r--lang/execline/Makefile40
-rw-r--r--lang/execline/distinfo1
-rw-r--r--lang/execline/pkg-descr13
-rw-r--r--lang/execline/pkg-plist97
4 files changed, 151 insertions, 0 deletions
diff --git a/lang/execline/Makefile b/lang/execline/Makefile
new file mode 100644
index 000000000000..1030145b0fc0
--- /dev/null
+++ b/lang/execline/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: execline
+# Date created: 2003-06-25
+# Whom: Sergei Kolobov <sergei@kolobov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= execline
+PORTVERSION= 1.05
+CATEGORIES= lang shells
+MASTER_SITES= http://www.skarnet.org/software/${PORTNAME}/
+
+MAINTAINER= sergei@kolobov.com
+COMMENT= Lightweight non-interactive scripting language similar to sh(1)
+
+WRKSRC= ${WRKDIR}/admin/${DISTNAME}
+
+DOCS= package/CHANGES package/README package/THANKS package/TODO \
+ doc/*.html
+
+do-configure:
+ ${ECHO_CMD} "${LOCALBASE}/include/skalibs" > ${WRKSRC}/conf-compile/import
+ ${ECHO_CMD} "${LOCALBASE}/lib/skalibs" >> ${WRKSRC}/conf-compile/import
+
+do-build:
+ cd ${WRKSRC} && package/compile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/command/* ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/library/* ${PREFIX}/lib
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/etc/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/execline/distinfo b/lang/execline/distinfo
new file mode 100644
index 000000000000..1f5aecd6a2ce
--- /dev/null
+++ b/lang/execline/distinfo
@@ -0,0 +1 @@
+MD5 (execline-1.05.tar.gz) = 94a986850acc4e724c6342ecdfe58d36
diff --git a/lang/execline/pkg-descr b/lang/execline/pkg-descr
new file mode 100644
index 000000000000..1aff1e188fec
--- /dev/null
+++ b/lang/execline/pkg-descr
@@ -0,0 +1,13 @@
+execline is a very light non-interactive scripting language,
+which is similar to /bin/sh. Simple shell scripts can be
+easily rewritten in the execline language, improving performance
+and memory usage. execline was designed for use
+in embedded systems, but works on most Unix flavors.
+
+execline features conditional loops, getopt-style option handling,
+filename globbing, and more. Meanwhile, its syntax
+is far more logical and predictable than the shell's syntax,
+and has no security issues.
+
+Author: Laurent G. Bercot <ska-skaware@skarnet.org>
+WWW: http://www.skarnet.org/software/execline/
diff --git a/lang/execline/pkg-plist b/lang/execline/pkg-plist
new file mode 100644
index 000000000000..ae766fa804b0
--- /dev/null
+++ b/lang/execline/pkg-plist
@@ -0,0 +1,97 @@
+@comment $FreeBSD$
+bin/background
+bin/backtick
+bin/cd
+bin/define
+bin/dollarat
+bin/elgetopt
+bin/elgetpositionals
+bin/elglob
+bin/emptyenv
+bin/exec
+bin/execline
+bin/execlineb
+bin/exit
+bin/export
+bin/fdclose
+bin/fdmove
+bin/fdreserve
+bin/for
+bin/forbacktick
+bin/foreground
+bin/getpid
+bin/heredoc
+bin/if
+bin/ifthenelse
+bin/import
+bin/importas
+bin/loopwhile
+bin/multisubstitute
+bin/pipeline
+bin/piperw
+bin/redirfd
+bin/runblock
+bin/shift
+bin/umask
+bin/unexport
+bin/wait
+include/execline/execline.h
+include/execline/exls1.h
+lib/libexecline.a
+lib/libexls1.a
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/background.html
+%%PORTDOCS%%%%DOCSDIR%%/backtick.html
+%%PORTDOCS%%%%DOCSDIR%%/cd.html
+%%PORTDOCS%%%%DOCSDIR%%/define.html
+%%PORTDOCS%%%%DOCSDIR%%/dieshdiedie.html
+%%PORTDOCS%%%%DOCSDIR%%/dollarat.html
+%%PORTDOCS%%%%DOCSDIR%%/el_pushenv.html
+%%PORTDOCS%%%%DOCSDIR%%/el_semicolon.html
+%%PORTDOCS%%%%DOCSDIR%%/el_split.html
+%%PORTDOCS%%%%DOCSDIR%%/el_substitute.html
+%%PORTDOCS%%%%DOCSDIR%%/elgetopt.html
+%%PORTDOCS%%%%DOCSDIR%%/elgetpositionals.html
+%%PORTDOCS%%%%DOCSDIR%%/elglob.html
+%%PORTDOCS%%%%DOCSDIR%%/emptyenv.html
+%%PORTDOCS%%%%DOCSDIR%%/exec.html
+%%PORTDOCS%%%%DOCSDIR%%/execline-shell.html
+%%PORTDOCS%%%%DOCSDIR%%/execline-startup.html
+%%PORTDOCS%%%%DOCSDIR%%/execline.html
+%%PORTDOCS%%%%DOCSDIR%%/execlineb.html
+%%PORTDOCS%%%%DOCSDIR%%/exit.html
+%%PORTDOCS%%%%DOCSDIR%%/export.html
+%%PORTDOCS%%%%DOCSDIR%%/fdclose.html
+%%PORTDOCS%%%%DOCSDIR%%/fdmove.html
+%%PORTDOCS%%%%DOCSDIR%%/fdreserve.html
+%%PORTDOCS%%%%DOCSDIR%%/for.html
+%%PORTDOCS%%%%DOCSDIR%%/forbacktick.html
+%%PORTDOCS%%%%DOCSDIR%%/foreground.html
+%%PORTDOCS%%%%DOCSDIR%%/getpid.html
+%%PORTDOCS%%%%DOCSDIR%%/grammar.html
+%%PORTDOCS%%%%DOCSDIR%%/heredoc.html
+%%PORTDOCS%%%%DOCSDIR%%/if.html
+%%PORTDOCS%%%%DOCSDIR%%/ifthenelse.html
+%%PORTDOCS%%%%DOCSDIR%%/import.html
+%%PORTDOCS%%%%DOCSDIR%%/importas.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/libexecline.html
+%%PORTDOCS%%%%DOCSDIR%%/loopwhile.html
+%%PORTDOCS%%%%DOCSDIR%%/multisubstitute.html
+%%PORTDOCS%%%%DOCSDIR%%/pipeline.html
+%%PORTDOCS%%%%DOCSDIR%%/piperw.html
+%%PORTDOCS%%%%DOCSDIR%%/redirfd.html
+%%PORTDOCS%%%%DOCSDIR%%/runblock.html
+%%PORTDOCS%%%%DOCSDIR%%/shift.html
+%%PORTDOCS%%%%DOCSDIR%%/umask.html
+%%PORTDOCS%%%%DOCSDIR%%/unexport.html
+%%PORTDOCS%%%%DOCSDIR%%/upgrade.html
+%%PORTDOCS%%%%DOCSDIR%%/wait.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/execline-shell
+%%EXAMPLESDIR%%/execline-startup
+@dirrm %%EXAMPLESDIR%%