aboutsummaryrefslogtreecommitdiffstats
path: root/lang/execline
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-02-11 04:33:51 +0800
committerjbeich <jbeich@FreeBSD.org>2015-02-11 04:33:51 +0800
commit9b3311d3a6a83b34c9a4c6e4ca74dc82e5b54d43 (patch)
tree6e5d99c8333b8e8a22d2d85aa4da6d1880ab75d9 /lang/execline
parent65426f588cdd12ac1559bc62ded013a7d1741290 (diff)
downloadfreebsd-ports-gnome-9b3311d3a6a83b34c9a4c6e4ca74dc82e5b54d43.tar.gz
freebsd-ports-gnome-9b3311d3a6a83b34c9a4c6e4ca74dc82e5b54d43.tar.zst
freebsd-ports-gnome-9b3311d3a6a83b34c9a4c6e4ca74dc82e5b54d43.zip
- devel/skalibs: update to 2.2.1.0 [1]
- lang/execline: update to 2.0.2.0 [2] - Pass maintainership to the submitter [1][2] - Mark sysutils/runwhen as BROKEN PR: 197233 [1] PR: 197234 [2] Differential Revision: https://reviews.freebsd.org/D1818 Submitted by: Colin Booth <colin@heliocat.net> Approved by: portmgr (bapt) [1] Approved by: bapt (mentor)
Diffstat (limited to 'lang/execline')
-rw-r--r--lang/execline/Makefile56
-rw-r--r--lang/execline/distinfo4
-rw-r--r--lang/execline/pkg-descr2
-rw-r--r--lang/execline/pkg-plist45
4 files changed, 49 insertions, 58 deletions
diff --git a/lang/execline/Makefile b/lang/execline/Makefile
index e5f88f48371b..5e8a008483fe 100644
--- a/lang/execline/Makefile
+++ b/lang/execline/Makefile
@@ -2,46 +2,32 @@
# $FreeBSD$
PORTNAME= execline
-PORTVERSION= 1.08
+PORTVERSION= 2.0.2.0
CATEGORIES= lang shells
MASTER_SITES= http://www.skarnet.org/software/${PORTNAME}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= colin@heliocat.net
COMMENT= Lightweight non-interactive sh(1)-like scripting language
-BUILD_DEPENDS= ${LOCALBASE}/lib/skalibs/libstddjb.a:${PORTSDIR}/devel/skalibs
-
-WRKSRC= ${WRKDIR}/admin/${DISTNAME}
-
-DOCS= package/CHANGES package/README package/THANKS package/TODO \
- doc/*.html
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-do-configure:
- ${ECHO_CMD} "FreeBSD" > ${WRKSRC}/src/sys/systype
- ${ECHO_CMD} "${LOCALBASE}/include/skalibs" \
- > ${WRKSRC}/conf-compile/import
- ${ECHO_CMD} "${LOCALBASE}/lib/skalibs" \
- >> ${WRKSRC}/conf-compile/import
- ${REINPLACE_CMD} -e 's|superstrip1|#superstrip1|g' \
- ${WRKSRC}/conf-compile/conf-stripbins
- @${REINPLACE_CMD} 's|gcc|${CC}|; s|-O2.*|${CFLAGS}|' \
- ${WRKSRC}/conf-compile/conf-cc \
- ${WRKSRC}/conf-compile/conf-ld
-
-do-build:
- (cd ${WRKSRC} && package/compile)
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/command/* ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/include/* \
- ${STAGEDIR}${PREFIX}/include/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/library/* ${STAGEDIR}${PREFIX}/lib
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/etc/* ${STAGEDIR}${EXAMPLESDIR}
+LICENSE= ISCL
+
+BUILD_DEPENDS= skalibs>=2.2.1.0:${PORTSDIR}/devel/skalibs
+
+USES= gmake
+USE_LDCONFIG= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+=--prefix=${PREFIX} \
+ --with-sysdeps=${LOCALBASE}/lib/skalibs/sysdeps \
+ --with-lib=${LOCALBASE}/lib/skalibs \
+ --with-include=${LOCALBASE}/include \
+ --enable-shared
+
+DOCS= AUTHORS COPYING INSTALL README doc/*.html
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libexecline.so.${PORTVERSION}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
+ cd ${WRKSRC} && ${INSTALL_MAN} ${DOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/lang/execline/distinfo b/lang/execline/distinfo
index e8e94c254f5e..70f326092b5d 100644
--- a/lang/execline/distinfo
+++ b/lang/execline/distinfo
@@ -1,2 +1,2 @@
-SHA256 (execline-1.08.tar.gz) = 6b721bfc2d486e64fa5f0309496a80928ca04d44c647df2aba0c8bbc684ea03b
-SIZE (execline-1.08.tar.gz) = 69685
+SHA256 (execline-2.0.2.0.tar.gz) = 73aa2db6e253f1821361033028d9b77733b799f93e4d7d477e4230534d7fce32
+SIZE (execline-2.0.2.0.tar.gz) = 73327
diff --git a/lang/execline/pkg-descr b/lang/execline/pkg-descr
index 1aff1e188fec..1db5b380b7ed 100644
--- a/lang/execline/pkg-descr
+++ b/lang/execline/pkg-descr
@@ -10,4 +10,4 @@ is far more logical and predictable than the shell's syntax,
and has no security issues.
Author: Laurent G. Bercot <ska-skaware@skarnet.org>
-WWW: http://www.skarnet.org/software/execline/
+WWW: http://www.skarnet.org/software/execline/
diff --git a/lang/execline/pkg-plist b/lang/execline/pkg-plist
index d500b348f999..40ca3aa59021 100644
--- a/lang/execline/pkg-plist
+++ b/lang/execline/pkg-plist
@@ -8,25 +8,28 @@ bin/elgetpositionals
bin/elglob
bin/emptyenv
bin/exec
-bin/execline
bin/execlineb
bin/exit
bin/export
+bin/fdblock
bin/fdclose
bin/fdmove
bin/fdreserve
-bin/for
-bin/forbacktick
+bin/fdswap
+bin/forbacktickx
bin/foreground
+bin/forx
bin/getpid
bin/heredoc
bin/homeof
bin/if
-bin/ifthenelse
+bin/ifelse
bin/ifte
+bin/ifthenelse
bin/import
bin/importas
-bin/loopwhile
+bin/loopwhilex
+bin/multidefine
bin/multisubstitute
bin/pipeline
bin/piperw
@@ -37,15 +40,18 @@ bin/tryexec
bin/umask
bin/unexport
bin/wait
+include/execline/config.h
include/execline/execline.h
-include/execline/exls1.h
-lib/libexecline.a
-lib/libexlp.a
-lib/libexls1.a
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+lib/execline/libexecline.a
+lib/libexecline.so
+lib/libexecline.so.2
+lib/libexecline.so.2.0
+lib/libexecline.so.2.0.2
+lib/libexecline.so.2.0.2.0
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/THANKS
-%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/background.html
%%PORTDOCS%%%%DOCSDIR%%/backtick.html
%%PORTDOCS%%%%DOCSDIR%%/cd.html
@@ -63,29 +69,30 @@ lib/libexls1.a
%%PORTDOCS%%%%DOCSDIR%%/exec.html
%%PORTDOCS%%%%DOCSDIR%%/execline-shell.html
%%PORTDOCS%%%%DOCSDIR%%/execline-startup.html
-%%PORTDOCS%%%%DOCSDIR%%/execline.html
%%PORTDOCS%%%%DOCSDIR%%/execlineb.html
%%PORTDOCS%%%%DOCSDIR%%/exit.html
%%PORTDOCS%%%%DOCSDIR%%/export.html
+%%PORTDOCS%%%%DOCSDIR%%/fdblock.html
%%PORTDOCS%%%%DOCSDIR%%/fdclose.html
%%PORTDOCS%%%%DOCSDIR%%/fdmove.html
%%PORTDOCS%%%%DOCSDIR%%/fdreserve.html
-%%PORTDOCS%%%%DOCSDIR%%/for.html
-%%PORTDOCS%%%%DOCSDIR%%/forbacktick.html
+%%PORTDOCS%%%%DOCSDIR%%/fdswap.html
+%%PORTDOCS%%%%DOCSDIR%%/forbacktickx.html
%%PORTDOCS%%%%DOCSDIR%%/foreground.html
+%%PORTDOCS%%%%DOCSDIR%%/forx.html
%%PORTDOCS%%%%DOCSDIR%%/getpid.html
%%PORTDOCS%%%%DOCSDIR%%/grammar.html
%%PORTDOCS%%%%DOCSDIR%%/heredoc.html
%%PORTDOCS%%%%DOCSDIR%%/homeof.html
%%PORTDOCS%%%%DOCSDIR%%/if.html
+%%PORTDOCS%%%%DOCSDIR%%/ifelse.html
%%PORTDOCS%%%%DOCSDIR%%/ifte.html
%%PORTDOCS%%%%DOCSDIR%%/ifthenelse.html
%%PORTDOCS%%%%DOCSDIR%%/import.html
%%PORTDOCS%%%%DOCSDIR%%/importas.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/install.html
-%%PORTDOCS%%%%DOCSDIR%%/libexecline.html
-%%PORTDOCS%%%%DOCSDIR%%/loopwhile.html
+%%PORTDOCS%%%%DOCSDIR%%/loopwhilex.html
+%%PORTDOCS%%%%DOCSDIR%%/multidefine.html
%%PORTDOCS%%%%DOCSDIR%%/multisubstitute.html
%%PORTDOCS%%%%DOCSDIR%%/pipeline.html
%%PORTDOCS%%%%DOCSDIR%%/piperw.html
@@ -97,5 +104,3 @@ lib/libexls1.a
%%PORTDOCS%%%%DOCSDIR%%/unexport.html
%%PORTDOCS%%%%DOCSDIR%%/upgrade.html
%%PORTDOCS%%%%DOCSDIR%%/wait.html
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execline-shell
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execline-startup