aboutsummaryrefslogtreecommitdiffstats
path: root/lang/expect/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /lang/expect/Makefile
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'lang/expect/Makefile')
-rw-r--r--lang/expect/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index 87a39bc90732..88292de0aa39 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -3,7 +3,7 @@
# Whom: pst
# Version required: 5.28
#
-# $Id: Makefile,v 1.36 1998/10/05 05:02:28 steve Exp $
+# $Id: Makefile,v 1.37 1998/10/10 04:07:04 steve Exp $
#
# Note this file is included from japanese/expect/Makefile
@@ -28,14 +28,16 @@ MAN1= autoexpect.1 cryptdir.1 decryptdir.1 dislocate.1 \
MAN3= libexpect.3
.endif
-post-install:
- ${LN} -sf ${SOLIB} ${PREFIX}/lib/libexpect528.so
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
.if ${PORTOBJFORMAT} == "elf"
SOLIB= libexpect528.so.1
.else
SOLIB= libexpect528.so.1.2
.endif
+
+post-install:
+ ${LN} -sf ${SOLIB} ${PREFIX}/lib/libexpect528.so
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.post.mk>