aboutsummaryrefslogtreecommitdiffstats
path: root/lang/expect
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1998-10-05 13:02:34 +0800
committersteve <steve@FreeBSD.org>1998-10-05 13:02:34 +0800
commitba707a2f1a342f628a2c70928ca90e48195ab177 (patch)
tree9d8e47c0b98f3782e3efcfbb40270426122d3d11 /lang/expect
parent9c103679ca4d3a445f93c55c2233d3f055d00fbe (diff)
downloadfreebsd-ports-gnome-ba707a2f1a342f628a2c70928ca90e48195ab177.tar.gz
freebsd-ports-gnome-ba707a2f1a342f628a2c70928ca90e48195ab177.tar.zst
freebsd-ports-gnome-ba707a2f1a342f628a2c70928ca90e48195ab177.zip
Convert to ELF.
Diffstat (limited to 'lang/expect')
-rw-r--r--lang/expect/Makefile11
-rw-r--r--lang/expect/pkg-plist3
2 files changed, 12 insertions, 2 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index 6678c49aac96..da08e3bb7c33 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -3,7 +3,7 @@
# Whom: pst
# Version required: 5.26
#
-# $Id: Makefile,v 1.34 1998/09/22 18:52:16 asami Exp $
+# $Id: Makefile,v 1.35 1998/09/25 10:05:08 asami Exp $
#
# Note this file is included from japanese/expect/Makefile
@@ -29,6 +29,13 @@ MAN3= libexpect.3
.endif
post-install:
- ${LDCONFIG} -m ${PREFIX}/lib
+ ${LN} -sf ${SOLIB} ${PREFIX}/lib/libexpect526.so
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+SOLIB= libexpect526.so.1
+.else
+SOLIB= libexpect526.so.1.2
+.endif
diff --git a/lang/expect/pkg-plist b/lang/expect/pkg-plist
index 8640a2745a73..3a92ed075d2b 100644
--- a/lang/expect/pkg-plist
+++ b/lang/expect/pkg-plist
@@ -27,5 +27,8 @@ include/expect_tcl.h
lib/expect5.26/pkgIndex.tcl
lib/expect5.26/libexpect526.a
lib/libexpect526.a
+lib/libexpect526.so
lib/libexpect526.so.1.2
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@dirrm lib/expect5.26