aboutsummaryrefslogtreecommitdiffstats
path: root/lang/expect
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-11-16 23:35:37 +0800
committerkrion <krion@FreeBSD.org>2003-11-16 23:35:37 +0800
commitad135d2b8120529161076e9caf0622d04244edda (patch)
tree954dd1733d98641e813ec03219ce641eb028e922 /lang/expect
parent3d43a62059b7e0f29d456a3d9034729c65e69e10 (diff)
downloadfreebsd-ports-gnome-ad135d2b8120529161076e9caf0622d04244edda.tar.gz
freebsd-ports-gnome-ad135d2b8120529161076e9caf0622d04244edda.tar.zst
freebsd-ports-gnome-ad135d2b8120529161076e9caf0622d04244edda.zip
- Use tcl84/tk84 instead of tcl83/tk83
- Bump PORTREVISION PR: 56654 Submitted by: YazzY <yazzy@yazzy.org> Approved by: maintainer timeout > 2 months
Diffstat (limited to 'lang/expect')
-rw-r--r--lang/expect/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index 556d6f658c3e..a2ec6ce5accf 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -6,17 +6,17 @@
PORTNAME= expect
PORTVERSION= 5.38.0
-PORTREVISION= 1
-CATEGORIES= lang tcl83 tk83
+PORTREVISION= 2
+CATEGORIES= lang tcl84 tk84
MASTER_SITES= http://expect.nist.gov/src/
MAINTAINER= jerry@thehutt.org
COMMENT= A sophisticated scripter based on tcl/tk
.if !defined(WITHOUT_X11)
-LIB_DEPENDS?= tk83.1:${PORTSDIR}/x11-toolkits/tk83
+LIB_DEPENDS?= tk83.1:${PORTSDIR}/x11-toolkits/tk84
.else
-LIB_DEPENDS?= tcl83.1:${PORTSDIR}/lang/tcl83
+LIB_DEPENDS?= tcl83.1:${PORTSDIR}/lang/tcl84
.endif
EXPECT_VER= 5.38
@@ -33,14 +33,14 @@ PLIST_SUB+= LIBEXPECT_VER="${LIBEXPECT_VER}"
TK_CONFIG_ARGS=
PLIST_SUB+= XFILES="@comment "
.else
-TK_CONFIG_ARGS= --with-tkconfig=${LOCALBASE}/lib/tk8.3 \
- --with-tkinclude=${LOCALBASE}/include/tk8.3
+TK_CONFIG_ARGS= --with-tkconfig=${LOCALBASE}/lib/tk8.4 \
+ --with-tkinclude=${LOCALBASE}/include/tk8.4
PLIST_SUB+= XFILES=""
.endif
CONFIGURE_ARGS?=--enable-shared \
- --with-tclconfig=${LOCALBASE}/lib/tcl8.3 \
- --with-tclinclude=${LOCALBASE}/include/tcl8.3 \
+ --with-tclconfig=${LOCALBASE}/lib/tcl8.4 \
+ --with-tclinclude=${LOCALBASE}/include/tcl8.4 \
${TK_CONFIG_ARGS}
CONFIGURE_ENV= LDFLAGS="-lutil"