aboutsummaryrefslogtreecommitdiffstats
path: root/lang/expect
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-02-18 14:28:34 +0800
committerasami <asami@FreeBSD.org>1998-02-18 14:28:34 +0800
commit50d844f952692c26c835d3e648d51992b1e68f49 (patch)
tree5e32edf8bdff72ff8b38f88a65134dce3a6bc6ff /lang/expect
parent4a66aaf4279c6051618cb072a74913c3ee415fb0 (diff)
downloadfreebsd-ports-gnome-50d844f952692c26c835d3e648d51992b1e68f49.tar.gz
freebsd-ports-gnome-50d844f952692c26c835d3e648d51992b1e68f49.tar.zst
freebsd-ports-gnome-50d844f952692c26c835d3e648d51992b1e68f49.zip
Make the Makefiles of japanese/expect and lang/expect cooperate better
with each other (and hopefully easier to maintain in the future). Basically, list everything in the regular orders on both Makefiles, and use ?= in lang/expect/Makefile for variables we want to be overridden. PR: 5770
Diffstat (limited to 'lang/expect')
-rw-r--r--lang/expect/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index 86ace2c9b8a5..86a435dcb166 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -3,27 +3,27 @@
# Whom: pst
# Version required: 5.25
#
-# $Id: Makefile,v 1.28 1997/12/29 11:42:10 asami Exp $
+# $Id: Makefile,v 1.29 1998/01/27 01:11:47 fenner Exp $
#
+# Note this file is included from japanese/extract/Makefile
DISTNAME= expect
-PKGNAME= expect-5.25
-CATEGORIES= lang tcl80 tk80
+PKGNAME?= expect-5.25
+CATEGORIES?= lang tcl80 tk80
MASTER_SITES= http://expect.nist.gov/
-MAINTAINER= ports@freebsd.org
+MAINTAINER?= ports@freebsd.org
-LIB_DEPENDS= tk80\\.1:${PORTSDIR}/x11/tk80
+LIB_DEPENDS?= tk80\\.1:${PORTSDIR}/x11/tk80
WRKSRC= ${WRKDIR}/expect-5.25
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared \
+CONFIGURE_ARGS?= --enable-shared \
--with-tclconfig=${PREFIX}/lib/tcl8.0 \
--with-tclinclude=${PREFIX}/include/tcl8.0 \
--with-tkconfig=${PREFIX}/lib/tk8.0 \
--with-tkinclude=${PREFIX}/include/tk8.0
-# needed for japanese/expect
.if !defined(NO_MAN_INSTALL)
MAN1= autoexpect.1 cryptdir.1 decryptdir.1 dislocate.1 \
expect.1 expectk.1 kibitz.1 mkpasswd.1 passmass.1 \
@@ -31,9 +31,6 @@ MAN1= autoexpect.1 cryptdir.1 decryptdir.1 dislocate.1 \
MAN3= libexpect.3
.endif
-test:
- @(cd ${WRKSRC}; make test)
-
post-install:
${LDCONFIG} -m ${PREFIX}/lib