aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ezm3
diff options
context:
space:
mode:
authorjdp <jdp@FreeBSD.org>2004-05-17 01:42:04 +0800
committerjdp <jdp@FreeBSD.org>2004-05-17 01:42:04 +0800
commit6a1a229ce7d2d96051e7363fc21045fcfa72ef62 (patch)
tree3f2658b3b334e5c7d15493a71dba89d75f05c83f /lang/ezm3
parent6f561d2b6ee22fe8dac3918c0a1b7b547288bd52 (diff)
downloadfreebsd-ports-gnome-6a1a229ce7d2d96051e7363fc21045fcfa72ef62.tar.gz
freebsd-ports-gnome-6a1a229ce7d2d96051e7363fc21045fcfa72ef62.tar.zst
freebsd-ports-gnome-6a1a229ce7d2d96051e7363fc21045fcfa72ef62.zip
Fix the ezm3 port to deal with 64-bit time_t on the sparc64 platform.
Two patches were submitted for this. I opted to use the simpler one due to the issues described in the PR follow-up. Bump PORTREVISION. PR: ports/66159 Submitted by: marius
Diffstat (limited to 'lang/ezm3')
-rw-r--r--lang/ezm3/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/lang/ezm3/Makefile b/lang/ezm3/Makefile
index 5554c4010368..c8e050008494 100644
--- a/lang/ezm3/Makefile
+++ b/lang/ezm3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ezm3
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_FREEBSD_ORG}
MASTER_SITE_SUBDIR=development/CVSup/ezm3
@@ -26,6 +26,7 @@ PLIST_SUB+= ARCH=${ARCH} TARGET=${TARGET} WORDSIZE=${WORDSIZE} \
SCRIPTS_ENV+= TARGET=${TARGET}
USE_BZIP2= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
PROGS= bin/m3build \
bin/m3bundle \
@@ -57,6 +58,12 @@ ENDIANESS= be
BOOTSTRAP= ezm3-${PORTVERSION}-${TARGET}-boot.tar.bz2
.endif
+post-patch:
+.if ${ARCH} == "sparc64" && ${OSVERSION} >= 502107
+ @${REINPLACE_CMD} -E -e 's|(^.*time_t.*=.*)int32_t;|\1int64_t;|' \
+ ${WRKSRC}/libs/m3core/src/unix/freebsd-4.sparc64/Utypes.i3
+.endif
+
do-build:
@${ECHO_MSG} "This port does everything in the install step."
@${ECHO_MSG} "The build step is a no-op."