aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ferite/files
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-10-14 22:45:04 +0800
committerijliao <ijliao@FreeBSD.org>2001-10-14 22:45:04 +0800
commit9df8388a1ea914a4b82a99a7ca758d462a67b56c (patch)
tree6fbc68b569efc856ce1446692b9dd0c2dc9c0267 /lang/ferite/files
parentc563c96291bd5cc11bd2e3eb8fad1c50c116ef84 (diff)
downloadfreebsd-ports-gnome-9df8388a1ea914a4b82a99a7ca758d462a67b56c.tar.gz
freebsd-ports-gnome-9df8388a1ea914a4b82a99a7ca758d462a67b56c.tar.zst
freebsd-ports-gnome-9df8388a1ea914a4b82a99a7ca758d462a67b56c.zip
add ferite
An embeddable scripting language PR: 30094 Submitted by: Jeremy Norris <ishmael27@home.com>
Diffstat (limited to 'lang/ferite/files')
-rw-r--r--lang/ferite/files/patch-Makefile.in11
-rw-r--r--lang/ferite/files/patch-configure73
-rw-r--r--lang/ferite/files/patch-docs::Makefile.in11
-rw-r--r--lang/ferite/files/patch-docs::images::Makefile.in11
-rw-r--r--lang/ferite/files/patch-ferite-config.in11
-rw-r--r--lang/ferite/files/patch-libs::Makefile.in11
-rw-r--r--lang/ferite/files/patch-ltmain.sh23
-rw-r--r--lang/ferite/files/patch-scripts::test::test.fe26
-rw-r--r--lang/ferite/files/patch-src::Makefile.in20
9 files changed, 197 insertions, 0 deletions
diff --git a/lang/ferite/files/patch-Makefile.in b/lang/ferite/files/patch-Makefile.in
new file mode 100644
index 000000000000..e32edc0bc4d1
--- /dev/null
+++ b/lang/ferite/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Tue Aug 21 04:21:23 2001
++++ Makefile.in Sat Aug 25 19:40:04 2001
+@@ -105,7 +105,7 @@
+ MAINTAINERCLEANFILES = INSTALL Makefile.in aclocal.m4 config.guess config.h.in config.sub configure install-sh ltconfig ltmain.sh missing mkinstalldirs stamp-h.in
+
+
+-SUBDIRS = libs src builder test include modules docs scripts
++SUBDIRS = libs src builder test include modules $(DOCS) scripts
+
+ bin_SCRIPTS = ferite-config
+
diff --git a/lang/ferite/files/patch-configure b/lang/ferite/files/patch-configure
new file mode 100644
index 000000000000..abfc6eacb39c
--- /dev/null
+++ b/lang/ferite/files/patch-configure
@@ -0,0 +1,73 @@
+--- configure.orig Mon Oct 8 14:11:39 2001
++++ configure Mon Oct 8 17:45:36 2001
+@@ -260,7 +260,6 @@
+ : ${ac_max_here_lines=38}
+
+ ac_unique_file="src/ferite.c"
+-ac_subdirs_all="$ac_subdirs_all libs/ltdl"
+
+ # Initialize some variables set by options.
+ ac_init_help=
+@@ -2455,18 +2454,6 @@
+ SET_MAKE="MAKE=${MAKE-make}"
+ fi
+
+- case $enable_ltdl_convenience in
+- no) { { echo "$as_me:2459: error: this package needs a convenience libltdl" >&5
+-echo "$as_me: error: this package needs a convenience libltdl" >&2;}
+- { (exit 1); exit 1; }; } ;;
+- "") enable_ltdl_convenience=yes
+- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
+- esac
+- LIBLTDL='${top_builddir}/''libltdl'/libltdlc.la
+- INCLTDL='-I${top_srcdir}/''libltdl'
+-
+-subdirs="$subdirs libs/ltdl"
+-
+ # Check whether --enable-shared or --disable-shared was given.
+ if test "${enable_shared+set}" = set; then
+ enableval="$enable_shared"
+@@ -6257,7 +6244,7 @@
+ build_old_libs=$enable_static
+
+ # Whether or not to add -lc for building shared libraries.
+-build_libtool_need_lc=$need_lc
++build_libtool_need_lc=no
+
+ # Whether or not to optimize for fast installation.
+ fast_install=$enable_fast_install
+@@ -6846,13 +6833,13 @@
+ { (exit 1); exit 1; }; }
+ fi
+
+-echo "$as_me:6849: checking for pthread_mutex_lock in -lpthread" >&5
+-echo $ECHO_N "checking for pthread_mutex_lock in -lpthread... $ECHO_C" >&6
++echo "$as_me:6849: checking for pthread_mutex_lock in -pthread" >&5
++echo $ECHO_N "checking for pthread_mutex_lock in -pthread... $ECHO_C" >&6
+ if test "${ac_cv_lib_pthread_pthread_mutex_lock+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 6857 "configure"
+ #include "confdefs.h"
+@@ -6900,7 +6887,7 @@
+ #define HAVE_LIBPTHREAD 1
+ EOF
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else
+
+@@ -6937,7 +6924,7 @@
+ modules="$modules file"
+
+ echo "checking module math ..."
+-math_LIBS=""
++math_LIBS="-lm"
+ math_CFLAGS=""
+
+ modules="$modules math"
diff --git a/lang/ferite/files/patch-docs::Makefile.in b/lang/ferite/files/patch-docs::Makefile.in
new file mode 100644
index 000000000000..9953f8318c00
--- /dev/null
+++ b/lang/ferite/files/patch-docs::Makefile.in
@@ -0,0 +1,11 @@
+--- docs/Makefile.in.orig Tue Aug 21 04:21:48 2001
++++ docs/Makefile.in Sat Aug 25 19:42:51 2001
+@@ -102,7 +102,7 @@
+ docs_DATA = ferite_language_def.pdf
+
+
+-docsdir = $(prefix)/share/ferite/docs
++docsdir = $(prefix)/share/doc/ferite
+
+ EXTRA_DIST = $(docs_DATA)
+
diff --git a/lang/ferite/files/patch-docs::images::Makefile.in b/lang/ferite/files/patch-docs::images::Makefile.in
new file mode 100644
index 000000000000..33ebec06df4f
--- /dev/null
+++ b/lang/ferite/files/patch-docs::images::Makefile.in
@@ -0,0 +1,11 @@
+--- docs/images/Makefile.in.orig Tue Aug 21 04:21:49 2001
++++ docs/images/Makefile.in Sat Aug 25 19:43:23 2001
+@@ -102,7 +102,7 @@
+ images_DATA = ferite_logo_colour_blue.png ferite_logo_black.png ferite_logo_black_600x300.png ferite_logo_colour.png ferite_logo.xcf
+
+
+-imagesdir = $(prefix)/share/ferite/images
++imagesdir = $(prefix)/share/doc/ferite/images
+
+ EXTRA_DIST = $(images_DATA)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/lang/ferite/files/patch-ferite-config.in b/lang/ferite/files/patch-ferite-config.in
new file mode 100644
index 000000000000..93b5323c9d06
--- /dev/null
+++ b/lang/ferite/files/patch-ferite-config.in
@@ -0,0 +1,11 @@
+--- ferite-config.in.orig Wed Jul 25 15:47:03 2001
++++ ferite-config.in Sat Aug 25 19:13:09 2001
+@@ -46,7 +46,7 @@
+ ;;
+ --libs)
+ libdirs=-L@libdir@
+- echo $libdirs -lferite -lm -lpcre
++ echo $libdirs -lferite %%PTHREAD_LIBS%% -lm -lpcre
+ ;;
+ --module-path)
+ echo @libdir@/ferite/modules
diff --git a/lang/ferite/files/patch-libs::Makefile.in b/lang/ferite/files/patch-libs::Makefile.in
new file mode 100644
index 000000000000..1c6b2a3655b3
--- /dev/null
+++ b/lang/ferite/files/patch-libs::Makefile.in
@@ -0,0 +1,11 @@
+--- libs/Makefile.in.orig Tue Aug 21 04:21:24 2001
++++ libs/Makefile.in Sat Aug 25 19:11:20 2001
+@@ -104,7 +104,7 @@
+ # A list of all the files in the current directory which can be regenerated
+ MAINTAINERCLEANFILES =
+
+-SUBDIRS = ltdl
++SUBDIRS =
+
+ EXTRA_DIST =
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/lang/ferite/files/patch-ltmain.sh b/lang/ferite/files/patch-ltmain.sh
new file mode 100644
index 000000000000..7aa81eaf5dcf
--- /dev/null
+++ b/lang/ferite/files/patch-ltmain.sh
@@ -0,0 +1,23 @@
+--- ltmain.sh.orig Tue Aug 14 16:55:55 2001
++++ ltmain.sh Sun Aug 26 09:11:33 2001
+@@ -944,6 +944,7 @@
+ ;;
+
+ -avoid-version)
++ build_old_libs=no
+ avoid_version=yes
+ continue
+ ;;
+@@ -4175,10 +4176,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/lang/ferite/files/patch-scripts::test::test.fe b/lang/ferite/files/patch-scripts::test::test.fe
new file mode 100644
index 000000000000..a8e19aef6fb8
--- /dev/null
+++ b/lang/ferite/files/patch-scripts::test::test.fe
@@ -0,0 +1,26 @@
+--- scripts/test/test.fe.orig Thu Jul 26 01:10:56 2001
++++ scripts/test/test.fe Sun Aug 26 00:06:31 2001
+@@ -17,17 +17,17 @@
+ a_global_int = 10;
+ testfile = new File();
+
+- Console.println( "Printing Out All ext2 Partitions in /etc/fstab" );
++ Console.println( "Printing Out All ufs Partitions in /etc/fstab" );
+ testfile->open( "/etc/fstab", "r" );
+ Console.println( "Here." );
+ while( blam = testfile->readln() && ! testfile->eof() )
+ {
+ if( blam =~ /
+- (\/dev\/[hs]d[a-g][1-9]) # device entry
+- [\ \t]* # whitespace
+- (\/[a-z]*(\/[a-z]*)*) # mount point
+- [\ \t]* # whitespace
+- ext2 # force adherance to ext2
++ (\/dev\/[ad][ad][0-9]s[1-4][a-h]) # device entry
++ [\ \t]* # whitespace
++ (\/[a-z]*(\/[a-z]*)*) # mount point
++ [\ \t]* # whitespace
++ ufs # force adherance to ext2
+ /xoi /* make usre it's not case sensitive */
+ )
+ {
diff --git a/lang/ferite/files/patch-src::Makefile.in b/lang/ferite/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..00dd999a7c97
--- /dev/null
+++ b/lang/ferite/files/patch-src::Makefile.in
@@ -0,0 +1,20 @@
+--- src/Makefile.in.orig Mon Oct 8 14:18:25 2001
++++ src/Makefile.in Mon Oct 8 17:43:52 2001
+@@ -110,7 +110,7 @@
+
+ LDFLAGS = -L/usr/local/lib
+
+-INCLUDES = -I${top_srcdir}/include -I${prefix}/include -I$(includedir) -I${top_srcdir}/include/ferite/ -I$(top_srcdir)/libs/ltdl @pcre_cflags@
++INCLUDES = -I${top_srcdir}/include -I${prefix}/include -I$(includedir) -I${top_srcdir}/include/ferite/ @pcre_cflags@
+
+
+ DEFS = -DMODULE_DIR=\"$(libdir)/ferite/modules\" -DSCRIPT_DIR=\"$(libdir)/ferite/scripts\" @debugdefs@
+@@ -122,7 +122,7 @@
+ libferite_la_SOURCES = ferite_mem_classic.c ferite_mem_jedi.c ferite_variables.c ferite_namespace.c ferite_function.c ferite_compile.c ferite_execute.c ferite_scanner.c ferite_globals.c ferite_parser.c ferite_opcode.c ferite_module.c ferite_error.c ferite_utils.c ferite_stack.c ferite_regex.c ferite_class.c ferite_file.c ferite_hash.c ferite_uarray.c ferite_ops.c ferite_gc. c ferite.c
+
+
+-libferite_la_LIBADD = $(top_builddir)/libs/ltdl/libltdlc.la -lm @pcre_libs@ $(LDFLAGS)
++libferite_la_LIBADD = -lltdl -lm @pcre_libs@ $(LDFLAGS)
+ libferite_la_DEPENDENCIES = $(top_builddir)/config.h
+ libferite_la_LDFLAGS = -version-info 0:99:0 -export-dynamic
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs