aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ficl/Makefile
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2003-12-09 03:00:36 +0800
committerbms <bms@FreeBSD.org>2003-12-09 03:00:36 +0800
commit8a7fa703d6420c51c72840d35a8dd5b410cb807f (patch)
tree2dd7e9165f9b6421deca44128cd24fcb7ef5b9dc /lang/ficl/Makefile
parent47e180ed6c2083b46c73b973b4c7726518558015 (diff)
downloadfreebsd-ports-gnome-8a7fa703d6420c51c72840d35a8dd5b410cb807f.tar.gz
freebsd-ports-gnome-8a7fa703d6420c51c72840d35a8dd5b410cb807f.tar.zst
freebsd-ports-gnome-8a7fa703d6420c51c72840d35a8dd5b410cb807f.zip
New port: Ficl is a programming language interpreter designed to be
embedded into other systems as a command, macro, and development prototyping language. FreeBSD uses ficl in its loader. So far we haven't done much more in this area, perhaps importing a port will encourage further fruitful exploitation of this valuable tool.
Diffstat (limited to 'lang/ficl/Makefile')
-rw-r--r--lang/ficl/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/lang/ficl/Makefile b/lang/ficl/Makefile
new file mode 100644
index 000000000000..f6d229f4e94f
--- /dev/null
+++ b/lang/ficl/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: ficl
+# Date created: 23 August 2002
+# Whom: Bruce M Simpson
+#
+# $FreeBSD$
+#
+
+PORTNAME= ficl
+PORTVERSION= 4.0.31
+CATEGORIES= lang devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= bms@spc.org
+COMMENT= Forth Inspired Command Language
+
+NO_WRKSUBDIR= defined
+NOMAN= defined
+
+ONLY_FOR_ARCHS= i386
+
+USE_GMAKE= yes
+
+ALL_TARGET= everything
+
+DOCS= releases.html parsesteps.html oop.html locals.html links.html \
+ license.html index.html api.html ficl.html favicon.ico dpans.html \
+ debugger.html upgrading.html
+
+DOCS_ARTICLES= sigplan9906.doc oo_in_c.html jwsforml.pdf ficlddj.pdf
+DOCS_GRAPHICS= sourceforge.jpg ficl_top.jpg ficl_oop.jpg ficl.4.96.jpg \
+ ficl.4.64.jpg ficl.4.128.jpg 4ring.gif
+DOCS_SOURCE= upgrading.ht releases.ht parsesteps.ht oop.ht locals.ht \
+ links.ht license.ht index.ht generate.py ficl.ht dpans.ht \
+ debugger.ht api.ht
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ficl ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/libficl.so.4 ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libficl.a ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/source ${DOCSDIR}/articles ${DOCSDIR}/graphics
+.for doc in ${DOCS}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${doc} ${DOCSDIR}
+.endfor
+.for doc in ${DOCS_ARTICLES}
+ ${INSTALL_MAN} ${WRKSRC}/doc/articles/${doc} ${DOCSDIR}/articles
+.endfor
+.for doc in ${DOCS_GRAPHICS}
+ ${INSTALL_MAN} ${WRKSRC}/doc/graphics/${doc} ${DOCSDIR}/graphics
+.endfor
+.for doc in ${DOCS_SOURCE}
+ ${INSTALL_MAN} ${WRKSRC}/doc/source/${doc} ${DOCSDIR}/source
+.endfor
+.endif
+
+.include <bsd.port.mk>