aboutsummaryrefslogtreecommitdiffstats
path: root/lang/fpc-tcl
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-07-24 19:21:27 +0800
committeracm <acm@FreeBSD.org>2006-07-24 19:21:27 +0800
commitbe8c2fc2f0a9dbc5795cca72bab530cd95ac8cf9 (patch)
treea3a2f4268e8fe61cde513b3aae848bcf90394d28 /lang/fpc-tcl
parentf17c49926cffd90046cb36851ca50d5d2a825410 (diff)
downloadfreebsd-ports-gnome-be8c2fc2f0a9dbc5795cca72bab530cd95ac8cf9.tar.gz
freebsd-ports-gnome-be8c2fc2f0a9dbc5795cca72bab530cd95ac8cf9.tar.zst
freebsd-ports-gnome-be8c2fc2f0a9dbc5795cca72bab530cd95ac8cf9.zip
- The big change on ports of freepascal, now all ports are compiled
- Adding entry for lang/fpc-utils Approved by: garga (mentor)
Diffstat (limited to 'lang/fpc-tcl')
-rw-r--r--lang/fpc-tcl/Makefile27
-rw-r--r--lang/fpc-tcl/pkg-plist12
2 files changed, 36 insertions, 3 deletions
diff --git a/lang/fpc-tcl/Makefile b/lang/fpc-tcl/Makefile
index f7413dec34d0..c33b3c6c8803 100644
--- a/lang/fpc-tcl/Makefile
+++ b/lang/fpc-tcl/Makefile
@@ -8,12 +8,33 @@
CATEGORIES= lang
PKGNAMESUFFIX= -tcl
-MAINTAINER= acardenas@bsd.org.pe
+MAINTAINER= acm@FreeBSD.org
COMMENT= Free Pascal interface to the tcl/tk interpreter
-RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
- wish8.4:${PORTSDIR}/x11-toolkits/tk84
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
+ fpcmake:${PORTSDIR}/lang/fpc-utils \
+ ${UNITSDIR}/fcl/Package.fpc:${PORTSDIR}/devel/fpc-fcl \
+ ${UNITSDIR}/gdbint/Package.fpc:${PORTSDIR}/devel/fpc-gdbint \
+ ${UNITSDIR}/ibase/Package.fpc:${PORTSDIR}/databases/fpc-ibase \
+ ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
+ ${UNITSDIR}/md5/Package.fpc:${PORTSDIR}/security/fpc-md5 \
+ ${UNITSDIR}/mysql/Package.fpc:${PORTSDIR}/databases/fpc-mysql \
+ ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
+ ${UNITSDIR}/odbc/Package.fpc:${PORTSDIR}/databases/fpc-odbc \
+ ${UNITSDIR}/oracle/Package.fpc:${PORTSDIR}/databases/fpc-oracle \
+ ${UNITSDIR}/pasjpeg/Package.fpc:${PORTSDIR}/graphics/fpc-pasjpeg \
+ ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
+ ${UNITSDIR}/pthreads/Package.fpc:${PORTSDIR}/devel/fpc-pthreads \
+ ${UNITSDIR}/postgres/Package.fpc:${PORTSDIR}/databases/fpc-postgres \
+ ${UNITSDIR}/regexpr/Package.fpc:${PORTSDIR}/devel/fpc-regexpr \
+ ${UNITSDIR}/sqlite/Package.fpc:${PORTSDIR}/databases/fpc-sqlite
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+
+UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${PORTNAME}/packages/extra/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+HAVE_EXAMPLES= true
.include "${MASTERDIR}/Makefile"
diff --git a/lang/fpc-tcl/pkg-plist b/lang/fpc-tcl/pkg-plist
new file mode 100644
index 000000000000..554df91651a9
--- /dev/null
+++ b/lang/fpc-tcl/pkg-plist
@@ -0,0 +1,12 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/tcl/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/tcl/tcl80.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/tcl/tcl80.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/tcl/libptcl80.a
+%%PORTDOCS%%share/examples/fpc-%%PORTVERSION%%/tcl/tcl_demo.pp
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/tcl
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc
+%%PORTDOCS%%@dirrm share/examples/fpc-%%PORTVERSION%%/tcl
+%%PORTDOCS%%@dirrmtry share/examples/fpc-%%PORTVERSION%%