aboutsummaryrefslogtreecommitdiffstats
path: root/lang/fpc-units/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-06-22 00:21:45 +0800
committergarga <garga@FreeBSD.org>2006-06-22 00:21:45 +0800
commit95eff47746707e29b73ed8ed78d38b39a6324d2b (patch)
tree8505ffa21296dfccb40b79646c54bb0096463208 /lang/fpc-units/Makefile
parentd6799d317494be972ac8d91f0e2a3dd48af00bed (diff)
downloadfreebsd-ports-gnome-95eff47746707e29b73ed8ed78d38b39a6324d2b.tar.gz
freebsd-ports-gnome-95eff47746707e29b73ed8ed78d38b39a6324d2b.tar.zst
freebsd-ports-gnome-95eff47746707e29b73ed8ed78d38b39a6324d2b.zip
Add fpc-units 2.0.2, a meta port to install Free Pascal units.
PR: ports/98721 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'lang/fpc-units/Makefile')
-rw-r--r--lang/fpc-units/Makefile84
1 files changed, 84 insertions, 0 deletions
diff --git a/lang/fpc-units/Makefile b/lang/fpc-units/Makefile
new file mode 100644
index 000000000000..969bc9e1f588
--- /dev/null
+++ b/lang/fpc-units/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: fpc-units
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= units
+PORTVERSION= 2.0.2
+CATEGORIES= lang
+MASTER_SITES= # none
+PKGNAMEPREFIX= fpc-
+DISTFILES= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= A meta port to install Free Pascal units
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= yes
+
+BUILDNAME= i386-freebsd
+
+OPTIONS= BFD "Interface to GNU Binary Format description" on \
+ FCL "Free Pascal Component Library" on \
+ FORMS "Interface to X-Forms" on \
+ FPGTK "Interface to create programs with gtk" on \
+ FV "Free Pascal unit for Delphi support" on \
+ GDBM "Interface to the GNU database system" on \
+ GGI "Interface to libggi library" on \
+ GTK "Interface to gtk libraries" on \
+ GTK2 "Interface to gtk2 libraries" on \
+ IMLIB "Interface to imlib library" on \
+ LIBGD "Interface to gd library" on \
+ LIBPNG "Interface to png library" on \
+ NCURSES "Interface to ncurses library" on \
+ OPENGL "Interface to opengl library" on \
+ SVGALIB "Interface to svgalib library" on \
+ SYSLOG "Interface to system logger" on \
+ TCL "Interface to tcl/tk interpreter" on \
+ UNZIP "Routines for unzipping zip files" on \
+ UTMP "Interface to gather information from the utmp file" on \
+ X11 "Interface to X windows server" on \
+ ZLIB "Interface to the zlib compression library" on
+
+.include <bsd.port.pre.mk>
+
+UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
+ALL_OPTIONS= BFD FCL FORMS FPGTK FV GDBM GGI GTK GTK2 \
+ IMLIB LIBGD LIBPNG NCURSES OPENGL SVGALIB \
+ SYSLOG TCL UNZIP UTMP X11 ZLIB
+
+BFD_UNIT= devel/fpc-bfd
+FCL_UNIT= devel/fpc-fcl
+FORMS_UNIT= x11-toolkits/fpc-forms
+FPGTK_UNIT= graphics/fpc-fpgtk
+FV_UNIT= devel/fpc-fv
+GDBM_UNIT= databases/fpc-gdbm
+GGI_UNIT= graphics/fpc-ggi
+GTK_UNIT= graphics/fpc-gtk
+GTK2_UNIT= graphics/fpc-gtk2
+IMLIB_UNIT= graphics/fpc-imlib
+LIBGD_UNIT= graphics/fpc-libgd
+LIBPNG_UNIT= graphics/fpc-libpng
+NCURSES_UNIT= graphics/fpc-ncurses
+OPENGL_UNIT= graphics/fpc-opengl
+SVGALIB_UNIT= graphics/fpc-svgalib
+SYSLOG_UNIT= sysutils/fpc-syslog
+TCL_UNIT= lang/fpc-tcl
+UNZIP_UNIT= archivers/fpc-unzip
+UTMP_UNIT= sysutils/fpc-utmp
+X11_UNIT= x11/fpc-x11
+ZLIB_UNIT= devel/fpc-zlib
+
+.for OPT in ${ALL_OPTIONS}
+. if defined(WITH_${OPT}) && !defined(WITHOUT_${OPT})
+RUN_DEPENDS+= ${UNITSDIR}/${OPT:L}/Package.fpc:${PORTSDIR}/${${OPT}_UNIT}
+. endif
+.endfor
+
+do-install: build
+ @${DO_NADA}
+
+.include <bsd.port.post.mk>