aboutsummaryrefslogtreecommitdiffstats
path: root/lang/fpc/Makefile.units
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-07-29 10:48:26 +0800
committeracm <acm@FreeBSD.org>2006-07-29 10:48:26 +0800
commiteb13871150cb441dcbae4a3646db39d34443e064 (patch)
tree75f3f934affda184682d4a1a2fe3f42f5d057c86 /lang/fpc/Makefile.units
parente4541a7b496e3cf023784cb68d390cb60a31e8c0 (diff)
downloadfreebsd-ports-gnome-eb13871150cb441dcbae4a3646db39d34443e064.tar.gz
freebsd-ports-gnome-eb13871150cb441dcbae4a3646db39d34443e064.tar.zst
freebsd-ports-gnome-eb13871150cb441dcbae4a3646db39d34443e064.zip
- Added post-extract on Makefiles.units. It remove the svn directories from
some fpc ports. - Added PORTREVISION for each port - Fixed pkg-plist on fpc-gtk2 and fpc-gtk ports - Fixed the gtk, glib and gdk libraries linking for fpc-gtk - Removed obsolete patches from fpc-gtk. Now it's using ${REINPLACE_CMD} - Removed post-extract from fpc-fcl. I just added it to makefiles.units file Approved by: garga (mentor)
Diffstat (limited to 'lang/fpc/Makefile.units')
-rw-r--r--lang/fpc/Makefile.units4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/fpc/Makefile.units b/lang/fpc/Makefile.units
index 9254f4a8602d..d683f80ef3f6 100644
--- a/lang/fpc/Makefile.units
+++ b/lang/fpc/Makefile.units
@@ -15,6 +15,10 @@ DISTFILES+= ${DISTNAME:S/$/.bin/}${EXTRACT_SUFX}:bin
MAKE_ENV+= FPCMAKE=${WRKDIR}/${PORTNAME:S/$/-bin/}/bin/fpcmake
.endif
+post-extract:
+ @cd ${WRKDIR}/${WRKUNITDIR} && \
+ ${FIND} ${WRKSRC} -type d -name .svn | ${XARGS} ${RM} -rf
+
do-build:
@cd ${WRKDIR}/${WRKUNITDIR} && ${GMAKE} all ${MAKE_ENV}