aboutsummaryrefslogtreecommitdiffstats
path: root/lang/fpc2
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-05-02 03:31:49 +0800
committersem <sem@FreeBSD.org>2006-05-02 03:31:49 +0800
commit2ecf4a5dd518e540878a2dcaf16578b2eb44333f (patch)
treeabc767e66771f9cea3a03adfae565a56e025fff1 /lang/fpc2
parent40108bd5fbf6972feb7dff9bbe991657c4923fab (diff)
downloadfreebsd-ports-gnome-2ecf4a5dd518e540878a2dcaf16578b2eb44333f.tar.gz
freebsd-ports-gnome-2ecf4a5dd518e540878a2dcaf16578b2eb44333f.tar.zst
freebsd-ports-gnome-2ecf4a5dd518e540878a2dcaf16578b2eb44333f.zip
- Update to 2.0.2.
- Remove OPTIONS for units. They are installed all now. - Pass maintainership to submitter. PR: ports/96505 Submitted by: Ales Katona <almindor@gmail.com>
Diffstat (limited to 'lang/fpc2')
-rw-r--r--lang/fpc2/Makefile136
-rw-r--r--lang/fpc2/distinfo6
-rw-r--r--lang/fpc2/pkg-descr3
-rw-r--r--lang/fpc2/pkg-plist11
4 files changed, 24 insertions, 132 deletions
diff --git a/lang/fpc2/Makefile b/lang/fpc2/Makefile
index 018a24b42aad..dbc8b90d35f9 100644
--- a/lang/fpc2/Makefile
+++ b/lang/fpc2/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: Free Pascal Compiler
# Date created: 25 Jun 2005
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
#
# $FreeBSD$
#
PORTNAME= fpc
-PORTVERSION= 2.0.0
+PORTVERSION= 2.0.2
CATEGORIES= lang
MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/i386-freebsd-${PORTVERSION}/ \
ftp://planetmirror.com/pub/fpc/dist/i386-freebsd-${PORTVERSION}/ \
@@ -19,54 +19,13 @@ MASTER_SITE_SUBDIR= freepascal
DISTNAME= ${PORTNAME}-${PORTVERSION}.i386-freebsd
EXTRACT_SUFX= .tar
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= almindor@gmail.com
COMMENT= Free Pascal compiler with Turbo, Delphi and other extensions
BUILDNAME= i386-freebsd
-# Define some libraries for fpc using OPTIONS
-OPTIONS= BFD "Install bfd support" off \
- FCL "Install fcl support" off \
- FORMS "Install forms support" off \
- FPGTK "Install fpgtk support" off \
- FV "Install fv support" off \
- GCONF "Install gconf support" off \
- GDBINT "Install gdbint support" off \
- GDBM "Install GDBM support" off \
- GGI "Install ggi support" off \
- GNOME "Install gnome support" off \
- GTK "Install gtk support" off \
- GTK2 "Install gtk2 support" off \
- IBASE "Install interbase support" off \
- IMLIB "Install imlib support" off \
- ASYNC "Install libacync support" off \
- GD "Install libgd support" off \
- PNG "Install libpng support" off \
- MD5 "Install md5 support" off \
- MYSQL "Install mysql support" off \
- NCURSES "Install ncurses support" off \
- NETDB "Install netdb support" off \
- ODBC "Install odbc support" off \
- OPENGL "Install opengl support" off \
- ORACLE "Install oracle support" off \
- PASJPEG "Install pascal libjpeg support" off \
- PASZLIB "Install pascal zlib support" off \
- POSTGRES "Install postgresql support" off \
- PTHREADS "Install pthreads support" off \
- REGEXP "Install regexp support" off \
- SQLITE "Install sqlite support" off \
- SVGALIB "Install svgalib support" off \
- SYSLOG "Install syslog support" off \
- TCL "Install tcl support" off \
- UTMP "Install utmp support" off \
- UNZIP "Install unzip support" off \
- X11 "Install x11 support" off \
- ZLIB "Install zlib support" off \
- ZVT "Install zvt support" off
-
.include <bsd.port.pre.mk>
-USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
PKGDEINSTALL= ${PKGINSTALL}
@@ -103,130 +62,50 @@ MAN5= fpc.cfg.5 fpcmake.5 ptop.cfg.5
# only need misc/compat4x if using the pre-built ppc386
.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
.endif
# Build units list
-.if defined(WITH_BFD)
UNITS+= bfd
-.endif
-.if defined(WITH_FCL)
UNITS+= fcl
PLIST_SUB+= FCL=""
-.else
-PLIST_SUB+= FCL="@comment "
-.endif
-.if defined(WITH_FORMS)
UNITS+= forms
PLIST_SUB+= FORMS=""
-.else
-PLIST_SUB+= FORMS="@comment "
-.endif
-.if defined(WITH_FPGTK)
UNITS+= fpgtk
-.endif
-.if defined(WITH_FV)
UNITS+= fv
-.endif
-.if defined(WITH_GCONF)
UNITS+= gconf
-.endif
-.if defined(WITH_GDBINT)
UNITS+= gdbint
-.endif
-.if defined(WITH_GDBM)
UNITS+= gdbm
-.endif
-.if defined(WITH_GGI)
UNITS+= ggi
-.endif
-.if defined(WITH_GNOME)
UNITS+= gnome
-.endif
-.if defined(WITH_GTK)
UNITS+= gtk
-.endif
-.if defined(WITH_GTK2)
UNITS+= gtk2
-.endif
-.if defined(WITH_IBASE)
UNITS+= ibase
-.endif
-.if defined(WITH_IMLIB)
UNITS+= imlib
-.endif
-.if defined(WITH_ASYNC)
UNITS+= libasync
-.endif
-.if defined(WITH_GD)
UNITS+= libgd
-.endif
-.if defined(WITH_PNG)
UNITS+= libpng
-.endif
-.if defined(WITH_MD5)
UNITS+= md5
-.endif
-.if defined(WITH_MYSQL)
UNITS+= mysql
-.endif
-.if defined(WITH_NCURSES)
UNITS+= ncurses
-.endif
-.if defined(WITH_NETDB)
UNITS+= netdb
-.endif
-.if defined(WITH_ODBC)
UNITS+= odbc
-.endif
-.if defined(WITH_OPENGL)
UNITS+= opengl
-.endif
-.if defined(WITH_ORACLE)
UNITS+= oracle
-.endif
-.if defined(WITH_PASJPEG)
UNITS+= pasjpeg
-.endif
-.if defined(WITH_PASZLIB)
UNITS+= paszlib
-.endif
-.if defined(WITH_POSTGRES)
UNITS+= postgres
-.endif
-.if defined(WITH_PTHREADS)
UNITS+= pthreads
-.endif
-.if defined(WITH_REGEXP)
UNITS+= regexpr
-.endif
-.if defined(WITH_SQLITE)
UNITS+= sqlite
-.endif
-.if defined(WITH_SVGALIB)
UNITS+= svgalib
-.endif
-.if defined(WITH_SYSLOG)
UNITS+= syslog
-.endif
-.if defined(WITH_TCL)
UNITS+= tcl
-.endif
-.if defined(WITH_UNZIP)
UNITS+= unzip
-.endif
-.if defined(WITH_UTMP)
UNITS+= utmp
-.endif
-.if defined(WITH_X11)
UNITS+= x11
-.endif
-.if defined(WITH_ZLIB)
UNITS+= zlib
-.endif
-.if defined(WITH_ZVT)
UNITS+= zvt
-.endif
do-extract:
# unpack distribution
@@ -258,7 +137,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/boot/bin/* ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/boot/share/doc/fpc-${PORTVERSION}/fpc/* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/boot/share/doc/fpc-${PORTVERSION}/* ${DOCSDIR}
.endif
# Installing fpc libs
${CP} -r ${WRKSRC}/boot/lib/* ${PREFIX}/lib
@@ -271,7 +150,8 @@ post-install:
@${CAT} ${TMPPLIST}.modules ${TMPPLIST} > ${TMPPLIST}.result
@${MV} ${TMPPLIST}.result ${TMPPLIST}
.endif
- @${LN} -s ${PREFIX}/lib/fpc/${PORTVERSION}/ppc386 ${PREFIX}/bin
- ${SH} ${PREFIX}/lib/fpc/${PORTVERSION}/samplecfg ${PREFIX}/lib/fpc/${PORTVERSION} ${PREFIX}/etc
+ if [ -e "${PREFIX}/bin/ppc386" ]; then ${RM} -f "${PREFIX}/bin/ppc386"; fi
+ ${LN} -s "${PREFIX}/lib/fpc/${PORTVERSION}/ppc386" "${PREFIX}/bin"
+ ${SH} "${PREFIX}/lib/fpc/${PORTVERSION}/samplecfg" "${PREFIX}/lib/fpc/${PORTVERSION}" "${PREFIX}/etc"
.include <bsd.port.post.mk>
diff --git a/lang/fpc2/distinfo b/lang/fpc2/distinfo
index 5809abe5cb77..80f3f200b2ed 100644
--- a/lang/fpc2/distinfo
+++ b/lang/fpc2/distinfo
@@ -1,3 +1,3 @@
-MD5 (fpc-2.0.0.i386-freebsd.tar) = 957264ee7fa93a4987c143dc691fbc71
-SHA256 (fpc-2.0.0.i386-freebsd.tar) = 0ba72248ed6c17dde7b78a3edea9e46cd3a6f69197b86249840d095f1f703536
-SIZE (fpc-2.0.0.i386-freebsd.tar) = 19118080
+MD5 (fpc-2.0.2.i386-freebsd.tar) = e1f834f445b0f2313f41ed417a28fb1c
+SHA256 (fpc-2.0.2.i386-freebsd.tar) = 906f002dfdbdfc3380f5a66b93d68debdbb68bba65b9db0590a93f548fb9f528
+SIZE (fpc-2.0.2.i386-freebsd.tar) = 22517760
diff --git a/lang/fpc2/pkg-descr b/lang/fpc2/pkg-descr
index 8b76cc5a8bee..d4820cba0798 100644
--- a/lang/fpc2/pkg-descr
+++ b/lang/fpc2/pkg-descr
@@ -1,5 +1,6 @@
Originally named FPK-Pascal, the Free Pascal compiler is a 32 bit
Turbo Pascal compatible Pascal compiler for DOS, Linux, Win32, OS/2,
-(based on an older version) the AmigaOS, FreeBSD/ELF, and BeOS.
+(based on an older version) the AmigaOS, FreeBSD/ELF, BeOS, Darwin(OSX)
+and others.
WWW: http://www.freepascal.org/
diff --git a/lang/fpc2/pkg-plist b/lang/fpc2/pkg-plist
index 7d9484e1991e..e9ca216af53e 100644
--- a/lang/fpc2/pkg-plist
+++ b/lang/fpc2/pkg-plist
@@ -18,9 +18,11 @@ bin/delp
bin/fpc
bin/fpcmake
bin/fpcmkcfg
+bin/fpcres
bin/fpcsubst
bin/fpdoc
bin/fprcp
+bin/fppkg
bin/h2pas
bin/h2paspp
bin/makeskel
@@ -46,6 +48,9 @@ lib/fpc/%%PORTVERSION%%/msg/errorpl.msg
lib/fpc/%%PORTVERSION%%/msg/errorpli.msg
lib/fpc/%%PORTVERSION%%/msg/errorr.msg
lib/fpc/%%PORTVERSION%%/msg/errorrw.msg
+lib/fpc/%%PORTVERSION%%/msg/errorptd.msg
+lib/fpc/%%PORTVERSION%%/msg/errorptw.msg
+lib/fpc/%%PORTVERSION%%/msg/errorues.msg
lib/fpc/%%PORTVERSION%%/ppc386
lib/fpc/%%PORTVERSION%%/samplecfg
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/lexyacc/Package.fpc
@@ -75,6 +80,8 @@ lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/cthreads.o
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/cthreads.ppu
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/ctypes.o
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/ctypes.ppu
+lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/cwstring.o
+lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/cwstring.ppu
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/dateutils.o
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/dateutils.ppu
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/dl.o
@@ -85,6 +92,8 @@ lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/dynlibs.o
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/dynlibs.ppu
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/errors.o
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/errors.ppu
+lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/fpmkunit.o
+lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/fpmkunit.ppu
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/getopts.o
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/getopts.ppu
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/gprt0.o
@@ -108,11 +117,13 @@ lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpcpu.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpcrt.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpcthreads.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpctypes.a
+lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpcwstring.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpdateutils.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpdl.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpdos.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpdynlibs.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libperrors.a
+lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpfpmkunit.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpgetopts.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpgraph.a
lib/fpc/%%PORTVERSION%%/units/i386-freebsd/rtl/libpheaptrc.a