aboutsummaryrefslogtreecommitdiffstats
path: root/lang/fsharp/Makefile
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2013-03-21 06:07:40 +0800
committerpgj <pgj@FreeBSD.org>2013-03-21 06:07:40 +0800
commit3f92a14ce93606408c5ddaa080fe5a3ef4a34e2d (patch)
tree23c13280650c3e15f8fde395c2d443274613d83d /lang/fsharp/Makefile
parent6dd2ab701ed80e801652101e47dff8b754562e45 (diff)
downloadfreebsd-ports-gnome-3f92a14ce93606408c5ddaa080fe5a3ef4a34e2d.tar.gz
freebsd-ports-gnome-3f92a14ce93606408c5ddaa080fe5a3ef4a34e2d.tar.zst
freebsd-ports-gnome-3f92a14ce93606408c5ddaa080fe5a3ef4a34e2d.zip
- Update to 3.0.25
- Change license to AL2, not restricted any more - Transfer maintainership to mono - Trim header PR: ports/176018 Submitted by: Jack Pappas <jack.pappas@tidepowerd.com>
Diffstat (limited to 'lang/fsharp/Makefile')
-rw-r--r--lang/fsharp/Makefile71
1 files changed, 13 insertions, 58 deletions
diff --git a/lang/fsharp/Makefile b/lang/fsharp/Makefile
index d39cd091f89b..9f8538a1a138 100644
--- a/lang/fsharp/Makefile
+++ b/lang/fsharp/Makefile
@@ -1,70 +1,25 @@
-# New ports collection makefile for: fsharp
-# Date created: 2006 10 10
-# Whom: Phillip Neumann <pneumann@gmail.com>
-#
+# Created by: Phillip Neumann <pneumann@gmail.com>
# $FreeBSD$
-#
PORTNAME= fsharp
-PORTVERSION= 1.9.6.16
-PORTREVISION= 4
+PORTVERSION= 3.0.25
CATEGORIES= lang
-MASTER_SITES= http://download.microsoft.com/download/F/7/4/F74A3170-261C-4E8F-B1A8-2E352C61A89B/
-DISTNAME= fsharp
+MASTER_SITES= https://nodeload.github.com/fsharp/fsharp/tar.gz/ \
+ CRITICAL
+DISTFILES= ${PORTVERSION}
-MAINTAINER= pgj@FreeBSD.org
+MAINTAINER= mono@FreeBSD.org
COMMENT= Functional and object-oriented language for the .NET platform
+LICENSE= AL2
-BUILD_DEPENDS= mono>=2:${PORTSDIR}/lang/mono\
- ${LOCALBASE}/lib/libgdiplus.a:${PORTSDIR}/x11-toolkits/libgdiplus
-RUN_DEPENDS= mono>=2:${PORTSDIR}/lang/mono\
- ${LOCALBASE}/lib/libgdiplus.a:${PORTSDIR}/x11-toolkits/libgdiplus
+BUILD_DEPENDS= mono>=3.0:${PORTSDIR}/lang/mono
+RUN_DEPENDS= mono>=3.0:${PORTSDIR}/lang/mono
-PORTDIR= lib/${PORTNAME}-${PORTVERSION}
-PORTDOCS= LICENSE-fsharp.txt README-fsharp.html doc manual
-PORTDATA= lib source
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf
+USE_PKGCONFIG= build
-PLIST_SUB= SUBDIR=${PORTDIR}
-.if !defined(NOPORTDOCS)
-PLIST_SUB+= RMLIC="@comment "
-.else
-PLIST_SUB+= RMLIC=""
-.endif
-
-WRKSRC= ${WRKDIR}/FSharp-${PORTVERSION}
-USE_ZIP= yes
-RESTRICTED= Microsoft Research Shared Source License Agreement
-
-AOT= Core Compiler PowerPack
-WRAPPERS= fsc fsi fslex fsyacc
-
-post-extract:
-.for wrapper in ${WRAPPERS}
- @(${ECHO} '#!${SH}' > ${WRKDIR}/${wrapper})
- @(${ECHO} '${LOCALBASE}/bin/mono ${PREFIX}/${PORTDIR}/bin/${wrapper}.exe $$*' >> ${WRKDIR}/${wrapper})
-.endfor
-
-do-build:
-
-do-install:
-.for asm in ${AOT}
- @ ${GACUTIL_INSTALL} ${WRKSRC}/bin/FSharp.${asm}.dll
-.endfor
- @ ${MKDIR} ${PREFIX}/${PORTDIR} ${PREFIX}/${PORTDIR}/bin ${DOCSDIR}
- @ (cd ${WRKSRC} && ${COPYTREE_SHARE} "bin" ${PREFIX}/${PORTDIR}/)
- @ ${INSTALL_DATA} ${WRKSRC}/LICENSE-fsharp.txt ${DOCSDIR}/
-.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${DOCSDIR}/doc ${DOCSDIR}/manual
- @ (cd ${WRKSRC} && ${COPYTREE_SHARE} "doc manual" ${DOCSDIR}/)
- @ ${INSTALL_DATA} ${WRKSRC}/README-fsharp.html ${DOCSDIR}/
-.endif
-.if !defined(NOPORTDATA)
- @ ${MKDIR} ${DATADIR} ${DATADIR}/lib ${DATADIR}/source
- @ (cd ${WRKSRC} && ${COPYTREE_SHARE} "lib source" ${DATADIR}/)
-.endif
-.for wrapper in ${WRAPPERS}
- @ ${INSTALL_SCRIPT} ${WRKDIR}/${wrapper} ${PREFIX}/bin/
-.endfor
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>