aboutsummaryrefslogtreecommitdiffstats
path: root/lang/fsharp/Makefile
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2016-10-19 00:05:20 +0800
committerdbn <dbn@FreeBSD.org>2016-10-19 00:05:20 +0800
commit7bf0483f105a9b5078155c7b27767919e808f86d (patch)
tree41ab245fc3591a1cc491019924bd9500002550d1 /lang/fsharp/Makefile
parent371a713bbbbfa0dd2fada07b5ec8c9cf1186d49b (diff)
downloadfreebsd-ports-gnome-7bf0483f105a9b5078155c7b27767919e808f86d.tar.gz
freebsd-ports-gnome-7bf0483f105a9b5078155c7b27767919e808f86d.tar.zst
freebsd-ports-gnome-7bf0483f105a9b5078155c7b27767919e808f86d.zip
lang/fsharp: fix build on FreeBSD < 11.
- change substitution since make(1) on FreeBSD 9 does not like variables within a substitution. - repeat tar substitution command since tar(1) on FreeBSD 9/10 does not obay the 'g' substitution command. Reported by: pkg-fallout PR: 213584
Diffstat (limited to 'lang/fsharp/Makefile')
-rw-r--r--lang/fsharp/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/fsharp/Makefile b/lang/fsharp/Makefile
index 088baef33b82..e0c5d43f6275 100644
--- a/lang/fsharp/Makefile
+++ b/lang/fsharp/Makefile
@@ -36,7 +36,7 @@ NUGET_PACKAGEDIR= ${WRKSRC}/packages
.for depend in ${NUGET_DEPENDS}
id= ${depend:C/-.*$//}
-version= ${depend:S/${id}-//}
+version= ${depend:C/^[^-]*-//}
group= nuget_${id:S/.//g}
nupkg= ${id:tl}.${version}.nupkg
DISTFILES_${group}:= ${nupkg}:${group}
@@ -52,7 +52,7 @@ post-extract:
.for nupkg in ${NUGET_NUPKGS}
@${MKDIR} ${NUGET_PACKAGEDIR}/${nupkg:C/^.*://:S/-/./}
@tar -xf ${DISTDIR}/${nupkg:C/:.*$//} -C ${NUGET_PACKAGEDIR}/${nupkg:C/^.*://:S/-/./} \
- -s/%2B/\+/g \
+ -s/%2B/\+/g -s/%2B/\+/g -s/%2B/\+/g \
--exclude '\[Content_Types\].xml' \
--exclude package/ \
--exclude _rels/