aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gauche/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-01-19 17:49:24 +0800
committerpav <pav@FreeBSD.org>2004-01-19 17:49:24 +0800
commite3621e143e384150df4ee7aefffe2fb95e487943 (patch)
treea0ae62165dc8fa6e355186e743f9dabc9676c4de /lang/gauche/Makefile
parent2df38c46a3b576a31d73123575130450a43437e6 (diff)
downloadfreebsd-ports-gnome-e3621e143e384150df4ee7aefffe2fb95e487943.tar.gz
freebsd-ports-gnome-e3621e143e384150df4ee7aefffe2fb95e487943.tar.zst
freebsd-ports-gnome-e3621e143e384150df4ee7aefffe2fb95e487943.zip
- Correct instalation of info files
- Add dependency on iconv PR: ports/59168, ports/61557 Submitted by: NIIMI Satoshi <sa2c@sa2c.net>, Kimura Fuyuki <fuyuki@nigredo.org> Approved by: maintainer
Diffstat (limited to 'lang/gauche/Makefile')
-rw-r--r--lang/gauche/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index f886f0142d08..432faf1893c7 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gauche
PORTVERSION= 0.7.3 # Keep databases/gauche-gdbm in sync with this
+PORTREVISION= 1
CATEGORIES= lang scheme
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +17,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= erik@smluc.org
COMMENT= Scheme script interpreter with multibyte character handling
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+
# Choices are: "pthreads" and "no", but it seems that FreeBSD does not
# yet fully support threads with Boehm GC.
GAUCHE_THREADS?= no
@@ -32,7 +35,8 @@ MAN1= gosh.1 \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-threads=${GAUCHE_THREADS} \
--enable-multibyte=${GAUCHE_ENCODING} \
- --with-slib=${PREFIX}/share/slib
+ --with-slib=${LOCALBASE}/share/slib \
+ --with-iconv=${LOCALBASE}
PLIST_SUB= VERSION="${PORTVERSION}" \
TARGET="${CONFIGURE_TARGET}" \
INFOSECTION="${INFOSECTION}"