aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc-aux
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-11-28 20:43:03 +0800
committermarino <marino@FreeBSD.org>2014-11-28 20:43:03 +0800
commit86bf3a5a345e1c36bbc9ef8715d2f67b7fe3c0a4 (patch)
treeba80a95d166ab8f1cd5cef012ccbb4716f712af1 /lang/gcc-aux
parent09bf617c32d43f77d6cb579280d0f53869950973 (diff)
downloadfreebsd-ports-gnome-86bf3a5a345e1c36bbc9ef8715d2f67b7fe3c0a4.tar.gz
freebsd-ports-gnome-86bf3a5a345e1c36bbc9ef8715d2f67b7fe3c0a4.tar.zst
freebsd-ports-gnome-86bf3a5a345e1c36bbc9ef8715d2f67b7fe3c0a4.zip
lang/gcc-aux: Fix symbolic trace on FreeBSD
Recent gcc creates debug information in dwarf4 format, something that the base version of addr2line on FreeBSD cannot understand. When the compiler requires binutils from ports to build, then ensure the symbolic tracing code also uses addr2line from the same binutils (which is already available due to RUN_DEPENDS requirements). Since DragonFly 3.6 and lower are no longer officially supported, this change only affects FreeBSD, but it affects all supported releases. The conditional code for DragonFly 3.6 has been removed while here. Reported by: Natacha Porte PR: 195465
Diffstat (limited to 'lang/gcc-aux')
-rw-r--r--lang/gcc-aux/Makefile8
-rw-r--r--lang/gcc-aux/Makefile.version2
2 files changed, 6 insertions, 4 deletions
diff --git a/lang/gcc-aux/Makefile b/lang/gcc-aux/Makefile
index 2e1b1d90550d..353a1a88386d 100644
--- a/lang/gcc-aux/Makefile
+++ b/lang/gcc-aux/Makefile
@@ -56,9 +56,6 @@ BOOTSTRAP_COMPILER= ada-bootstrap.${GARCH}.freebsd.100B.tar.bz2
. endif
.endif
.if ${OPSYS} == DragonFly
-. if ${OSREL:S/.//} < 37
-MODERN_BINUTILS= yes
-. endif
BOOTSTRAP_COMPILER= ada-bootstrap.${GARCH}.dragonfly.36A.tar.bz2
.endif
@@ -218,6 +215,11 @@ post-extract:
${WRKSRC}/gcc/config/dragonfly.h \
${WRKSRC}/gcc/config/i386/freebsd64.h \
${WRKSRC}/gcc/config/i386/freebsd.h
+.if defined(MODERN_BINUTILS)
+ # Use dwarf4-compatible addr2line (affects FreeBSD only)
+ ${REINPLACE_CMD} -e 's|/usr/bin/addr2line|${PREFIX}/bin/addr2line|g' \
+ ${WRKSRC}/gcc/ada/traceback_symbolic.c
+.endif
do-configure:
${MKDIR} ${BUILDDIR}
diff --git a/lang/gcc-aux/Makefile.version b/lang/gcc-aux/Makefile.version
index a351f39c9a35..3708bbeadff5 100644
--- a/lang/gcc-aux/Makefile.version
+++ b/lang/gcc-aux/Makefile.version
@@ -4,7 +4,7 @@ GCC_BRANCH= 4.9
GCC_POINT= 2
GCC_VERSION= ${GCC_BRANCH}.${GCC_POINT}
SNAPSHOT= 20141023
-MAIN_PR= 0
+MAIN_PR= 1
UTIL_PR= 0
ARMV5_PR= 0
ARMV7_PR= 0