aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc-aux
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-03-04 05:55:29 +0800
committermarino <marino@FreeBSD.org>2014-03-04 05:55:29 +0800
commit57a9e064026fe6de3588ba3e594aab7d7eb95355 (patch)
tree6ceb2d4d005bee09e780ab15a4a10ecb9b6939cd /lang/gcc-aux
parenta071d4ad68ae0a8ec633671d42c948f53c3186b6 (diff)
downloadfreebsd-ports-gnome-57a9e064026fe6de3588ba3e594aab7d7eb95355.tar.gz
freebsd-ports-gnome-57a9e064026fe6de3588ba3e594aab7d7eb95355.tar.zst
freebsd-ports-gnome-57a9e064026fe6de3588ba3e594aab7d7eb95355.zip
lang/gcc-aux: Fix skip-bootstrap functionality
I don't know when the skip-bootstrap logic stopped working, but I'm reasonably sure it did once. Apparently PREFIX isn't defined at the time of the "if exists" evaluation. Using LOCALBASE instead will allow the compiler to build using the compiler on the system rather than the older bootstrap compiler. The bug was discovered while trying to move gcc-aux to a gcc49 base.
Diffstat (limited to 'lang/gcc-aux')
-rw-r--r--lang/gcc-aux/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/gcc-aux/Makefile b/lang/gcc-aux/Makefile
index 6b3dd8b1e020..d15795641af4 100644
--- a/lang/gcc-aux/Makefile
+++ b/lang/gcc-aux/Makefile
@@ -79,11 +79,11 @@ AWKMANPAGE= '{if ($$0 ~ /^man\/man[1-9]\/.+[1-9]$$/) print $$0 ".gz"; else prin
# If we find gnatmake and friends in a standard location, then we'll use this
# compiler instead of downloading the bootstrap.
-.if exists (${PREFIX}/${PORTNAME}/bin/ada)
-.if exists (${PREFIX}/${PORTNAME}/bin/gnatbind)
-.if exists (${PREFIX}/${PORTNAME}/bin/gnatlink)
-.if exists (${PREFIX}/${PORTNAME}/bin/gnatmake)
-FULL_GNATGCC=${PREFIX}/${PORTNAME}/bin/ada
+.if exists (${LOCALBASE}/${PORTNAME}/bin/ada)
+.if exists (${LOCALBASE}/${PORTNAME}/bin/gnatbind)
+.if exists (${LOCALBASE}/${PORTNAME}/bin/gnatlink)
+.if exists (${LOCALBASE}/${PORTNAME}/bin/gnatmake)
+FULL_GNATGCC=${LOCALBASE}/${PORTNAME}/bin/ada
FULL_PATH=/sbin:/bin:/usr/sbin:/usr/bin:${PREFIX}/${PORTNAME}/bin:${PREFIX}/bin
.endif
.endif