aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc-ooo
diff options
context:
space:
mode:
authorjdp <jdp@FreeBSD.org>1998-01-24 01:49:47 +0800
committerjdp <jdp@FreeBSD.org>1998-01-24 01:49:47 +0800
commit586c65559add3777fdd27ef709ab4dd728d591d6 (patch)
tree3a94bc8f51bb61ecef8f917db14fcb277d013fa3 /lang/gcc-ooo
parent461315ae0e5f61496e4fa2bb5b2dec987b558e5b (diff)
downloadfreebsd-ports-gnome-586c65559add3777fdd27ef709ab4dd728d591d6.tar.gz
freebsd-ports-gnome-586c65559add3777fdd27ef709ab4dd728d591d6.tar.zst
freebsd-ports-gnome-586c65559add3777fdd27ef709ab4dd728d591d6.zip
Make "-fsjlj-exceptions" (use setjmp/longjmp for exceptions) the
default for FreeBSD. The standard exception implementation reliably dumps core under FreeBSD. Users can put "-fno-sjlj-exceptions" on the command line if they really want to override the new default. Configure with "--with-gnu-as" and "--with-gnu-ld". Define "__FreeBSD__" as 3.
Diffstat (limited to 'lang/gcc-ooo')
-rw-r--r--lang/gcc-ooo/Makefile4
-rw-r--r--lang/gcc-ooo/files/patch-ad17
2 files changed, 19 insertions, 2 deletions
diff --git a/lang/gcc-ooo/Makefile b/lang/gcc-ooo/Makefile
index 335f43bc237b..8d432dde1bb0 100644
--- a/lang/gcc-ooo/Makefile
+++ b/lang/gcc-ooo/Makefile
@@ -3,7 +3,7 @@
# Date created: 9 Jan 1998
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.2 1998/01/13 05:18:16 asami Exp $
+# $Id: Makefile,v 1.3 1998/01/14 07:24:54 obrien Exp $
#
DISTNAME= egcs-1.0.1
@@ -16,7 +16,7 @@ MAINTAINER= jdp@polstra.com
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= i386-unknown-freebsd
+CONFIGURE_ARGS= --with-gnu-as --with-gnu-ld i386-unknown-freebsd
MAN1= cccp.1 g++.1 g77.1 gcc.1
FME=${PREFIX}
diff --git a/lang/gcc-ooo/files/patch-ad b/lang/gcc-ooo/files/patch-ad
new file mode 100644
index 000000000000..207c128cff6a
--- /dev/null
+++ b/lang/gcc-ooo/files/patch-ad
@@ -0,0 +1,17 @@
+--- gcc/config/i386/freebsd.h.orig Fri Oct 17 23:52:58 1997
++++ gcc/config/i386/freebsd.h Thu Jan 22 21:50:29 1998
+@@ -35,10 +35,13 @@
+ #include "i386/perform.h"
+
+ #undef CPP_PREDEFINES
+-#define CPP_PREDEFINES "-Dunix -Di386 -D__FreeBSD__ -D__386BSD__ -Asystem(unix) -Asystem(FreeBSD) -Acpu(i386) -Amachine(i386)"
++#define CPP_PREDEFINES "-Dunix -Di386 -D__FreeBSD__=3 -D__386BSD__ -Asystem(unix) -Asystem(FreeBSD) -Acpu(i386) -Amachine(i386)"
+
+ /* Like the default, except no -lg. */
+ #define LIB_SPEC "%{!p:%{!pg:-lc}}%{p:-lc_p}%{pg:-lc_p}"
++
++#undef CC1PLUS_SPEC
++#define CC1PLUS_SPEC "-fsjlj-exceptions"
+
+ #undef SIZE_TYPE
+ #define SIZE_TYPE "unsigned int"