aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc28
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-30 18:25:34 +0800
committerpav <pav@FreeBSD.org>2007-01-30 18:25:34 +0800
commit68e4663f01d748743e0029f83931c02fba58eb4e (patch)
treed24dbe32e4bdb87d0f3ba1c46717e6e34576e724 /lang/gcc28
parentc6c1440c2b66077bedba90612a4827a8051ec9c1 (diff)
downloadfreebsd-ports-gnome-68e4663f01d748743e0029f83931c02fba58eb4e.tar.gz
freebsd-ports-gnome-68e4663f01d748743e0029f83931c02fba58eb4e.tar.zst
freebsd-ports-gnome-68e4663f01d748743e0029f83931c02fba58eb4e.zip
- Remove support for a.out format and PORTOBJFORMAT variable from individual
ports With hat: portmgr
Diffstat (limited to 'lang/gcc28')
-rw-r--r--lang/gcc28/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/lang/gcc28/Makefile b/lang/gcc28/Makefile
index 6320057650be..57f63c5f9c97 100644
--- a/lang/gcc28/Makefile
+++ b/lang/gcc28/Makefile
@@ -26,14 +26,10 @@ DEPRECATED= This port is no longer in use by anything in the ports collection.
.include <bsd.port.pre.mk>
.if ${ARCH} == "alpha"
-BROKEN= "Does not compile on alpha"
+BROKEN= Does not compile on alpha
.endif
-.if ${PORTOBJFORMAT} == "elf"
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-.else
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsdaout${OSREL}
-.endif
CONFIGURE_ENV+= OSVERSION=${OSVERSION}
PLIST_SUB= GNUHOST=${CONFIGURE_TARGET}
.if ${OSVERSION} < 600011
@@ -48,7 +44,7 @@ MAN1= cccp28.1 g++28.1 gcc28.1
INFO= cpp gcc
pre-everything::
- @${ECHO_MSG} "GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} ${PORTOBJFORMAT}"
+ @${ECHO_MSG} "GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL}"
pre-patch:
@${MV} ${WRKSRC}/config/i386/freebsd.h ${WRKSRC}/config/i386/freebsd-aout.h