aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc28
diff options
context:
space:
mode:
authordas <das@FreeBSD.org>2005-02-12 21:19:47 +0800
committerdas <das@FreeBSD.org>2005-02-12 21:19:47 +0800
commitd0a8169f66cd61514add7ee911c6b6db0e51c1b9 (patch)
tree2f20a76d035a3b6d76643819e4d11cd7456ce538 /lang/gcc28
parentffbef27bb1180c2cd5cf7122154e05f714d21605 (diff)
downloadfreebsd-ports-gnome-d0a8169f66cd61514add7ee911c6b6db0e51c1b9.tar.gz
freebsd-ports-gnome-d0a8169f66cd61514add7ee911c6b6db0e51c1b9.tar.zst
freebsd-ports-gnome-d0a8169f66cd61514add7ee911c6b6db0e51c1b9.zip
Fix build. Ports that formerly attempted to work around problems
created by matherr() no longer need to do so.
Diffstat (limited to 'lang/gcc28')
-rw-r--r--lang/gcc28/Makefile5
-rw-r--r--lang/gcc28/files/patch-0347
-rw-r--r--lang/gcc28/files/patch-1231
-rw-r--r--lang/gcc28/pkg-plist1
4 files changed, 52 insertions, 32 deletions
diff --git a/lang/gcc28/Makefile b/lang/gcc28/Makefile
index eee04c845a34..c837e40a74b2 100644
--- a/lang/gcc28/Makefile
+++ b/lang/gcc28/Makefile
@@ -34,8 +34,11 @@ CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.else
CONFIGURE_TARGET= ${ARCH}-portbld-freebsdaout${OSREL}
.endif
-
+CONFIGURE_ENV+= OSVERSION=${OSVERSION}
PLIST_SUB= GNUHOST=${CONFIGURE_TARGET}
+.if ${OSVERSION} < 600011
+PLIST_FILES+= lib/gcc-lib/${CONFIGURE_TARGET}/2.8.1/include/math.h
+.endif
CONFIGURE_ARGS= --with-gxx-include-dir=${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/2.8.1/include/g++
CONFIGURE_ARGS+= --program-suffix=28
GNU_CONFIGURE= yes
diff --git a/lang/gcc28/files/patch-03 b/lang/gcc28/files/patch-03
index 391e3a9c3d5d..5b2f582a9b2d 100644
--- a/lang/gcc28/files/patch-03
+++ b/lang/gcc28/files/patch-03
@@ -1,5 +1,5 @@
---- configure.orig Sat Feb 28 18:02:02 1998
-+++ configure Mon Feb 8 11:51:44 1999
+--- configure.orig Sat Feb 28 21:02:02 1998
++++ configure Sat Feb 12 02:28:01 2005
@@ -677,9 +677,9 @@
if test -z "$ac_aux_dir"; then
{ echo "configure: error: can not find install-sh or install.sh in $srcdir $srcdir/.. $srcdir/../.." 1>&2; exit 1; }
@@ -13,15 +13,16 @@
# Do some error checking and defaulting for the host and target type.
-@@ -2797,6 +2797,20 @@
+@@ -2797,6 +2797,21 @@
a29k-*-*) # Default a29k environment.
use_collect2=yes
;;
+ alpha*-*-freebsd*)
+ tm_file=alpha/freebsd.h
-+ # On FreeBSD, the headers are already ok, except for math.h. (??right??)
-+ fixincludes=fixinc.math
-+ fixincludes=fixinc.math
++ if [ "${OSVERSION}" -lt 600011 ] ; \
++ then fixincludes=fixinc.math; \
++ else fixincludes=Makefile.in; \
++ fi
+ tmake_file=t-libc-ok
+ ;;
+ alpha-*-openbsd*)
@@ -34,7 +35,7 @@
alpha*-*-linux-gnuecoff*)
tm_file="${tm_file} alpha/linux.h"
xm_file="${xm_file} alpha/xm-linux.h"
-@@ -3158,6 +3172,14 @@
+@@ -3158,6 +3173,14 @@
use_collect2=yes
fixincludes=Makefile.in
;;
@@ -49,16 +50,20 @@
i370-*-mvs*)
;;
i[34567]86-ibm-aix*) # IBM PS/2 running AIX
-@@ -3256,20 +3278,20 @@
+@@ -3256,20 +3279,24 @@
# Next line turned off because both 386BSD and BSD/386 use GNU ld.
# use_collect2=yes
;;
- i[34567]86-*-freebsdelf*)
- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
+- # On FreeBSD, the headers are already ok, except for math.h.
+- fixincludes=fixinc.math
+ i[34567]86-*-freebsdaout*)
+ tm_file=i386/freebsd-aout.h
- # On FreeBSD, the headers are already ok, except for math.h.
- fixincludes=fixinc.math
++ if [ "${OSVERSION}" -lt 600011 ] ; \
++ then fixincludes=fixinc.math; \
++ else fixincludes=Makefile.in; \
++ fi
tmake_file=i386/t-freebsd
- gas=yes
- gnu_ld=yes
@@ -66,9 +71,13 @@
;;
i[34567]86-*-freebsd*)
- tm_file=i386/freebsd.h
+- # On FreeBSD, the headers are already ok, except for math.h.
+- fixincludes=fixinc.math
+ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
- # On FreeBSD, the headers are already ok, except for math.h.
- fixincludes=fixinc.math
++ if [ "${OSVERSION}" -lt 600011 ] ; \
++ then fixincludes=fixinc.math; \
++ else fixincludes=Makefile.in; \
++ fi
tmake_file=i386/t-freebsd
+ gas=yes
+ gnu_ld=yes
@@ -76,7 +85,7 @@
;;
i[34567]86-*-netbsd*)
tm_file=i386/netbsd.h
-@@ -3277,6 +3299,13 @@
+@@ -3277,6 +3304,13 @@
fixincludes=fixinc.math
tmake_file=t-netbsd
;;
@@ -90,7 +99,7 @@
i[34567]86-*-coff*)
tm_file=i386/i386-coff.h
tmake_file=i386/t-i386bare
-@@ -3964,6 +3993,13 @@
+@@ -3964,6 +3998,13 @@
fixincludes=fixinc.math
tmake_file=t-netbsd
;;
@@ -104,7 +113,7 @@
m68k-*-sysv3*) # Motorola m68k's running system V.3
xm_file=m68k/xm-m68kv.h
xmake_file=m68k/x-m68kv
-@@ -4273,6 +4309,20 @@
+@@ -4273,6 +4314,20 @@
prefix=$native_prefix
fi
;;
@@ -125,7 +134,7 @@
mips-sony-bsd* | mips-sony-newsos*) # Sony NEWS 3600 or risc/news.
tm_file=mips/news4.h
if [ x$stabs = xyes ]; then
-@@ -4612,6 +4662,13 @@
+@@ -4612,6 +4667,13 @@
fixincludes=fixinc.math
tmake_file=t-netbsd
;;
@@ -139,7 +148,7 @@
pdp11-*-bsd)
tm_file="${tm_file} pdp11/2bsd.h"
;;
-@@ -4625,10 +4682,23 @@
+@@ -4625,10 +4687,23 @@
romp-*-aos*)
use_collect2=yes
;;
@@ -163,7 +172,7 @@
powerpc-*-sysv* | powerpc-*-elf*)
tm_file=rs6000/sysv4.h
xm_file=rs6000/xm-sysv4.h
-@@ -4841,6 +4911,13 @@
+@@ -4841,6 +4916,13 @@
fixincludes=fixinc.math
tmake_file=t-netbsd
;;
@@ -177,7 +186,7 @@
sparc-*-bsd*)
tm_file=sparc/bsd.h
;;
-@@ -5009,6 +5086,14 @@
+@@ -5009,6 +5091,14 @@
# On NetBSD, the headers are already okay, except for math.h.
fixincludes=fixinc.math
tmake_file=t-netbsd
diff --git a/lang/gcc28/files/patch-12 b/lang/gcc28/files/patch-12
index 9bcd13b461e0..7b16b1ea0a5b 100644
--- a/lang/gcc28/files/patch-12
+++ b/lang/gcc28/files/patch-12
@@ -1,29 +1,34 @@
---- configure.in.orig Sat Feb 28 12:58:12 1998
-+++ configure.in Tue Feb 9 02:24:34 1999
-@@ -303,6 +303,13 @@
+--- configure.in.orig Sat Feb 28 15:58:12 1998
++++ configure.in Sat Feb 12 02:26:56 2005
+@@ -303,6 +303,14 @@
a29k-*-*) # Default a29k environment.
use_collect2=yes
;;
+ alpha*-*-freebsd*)
+ tm_file=alpha/freebsd.h
-+ # On FreeBSD, the headers are already ok, except for math.h. (??right??)
-+ fixincludes=fixinc.math
-+ fixincludes=fixinc.math
++ if [[ "${OSVERSION}" -lt 600011 ]] ; \
++ then fixincludes=fixinc.math; \
++ else fixincludes=Makefile.in; \
++ fi
+ tmake_file=t-libc-ok
+ ;;
alpha*-*-linux-gnuecoff*)
tm_file="${tm_file} alpha/linux.h"
xm_file="${xm_file} alpha/xm-linux.h"
-@@ -762,20 +769,20 @@
+@@ -762,20 +770,24 @@
# Next line turned off because both 386BSD and BSD/386 use GNU ld.
# use_collect2=yes
;;
- i[[34567]]86-*-freebsdelf*)
- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
+- # On FreeBSD, the headers are already ok, except for math.h.
+- fixincludes=fixinc.math
+ i[[34567]]86-*-freebsdaout*)
+ tm_file=i386/freebsd.h
- # On FreeBSD, the headers are already ok, except for math.h.
- fixincludes=fixinc.math
++ if [[ "${OSVERSION}" -lt 600011 ]] ; \
++ then fixincludes=fixinc.math; \
++ else fixincludes=Makefile.in; \
++ fi
tmake_file=i386/t-freebsd
- gas=yes
- gnu_ld=yes
@@ -31,9 +36,13 @@
;;
i[[34567]]86-*-freebsd*)
- tm_file=i386/freebsd.h
+- # On FreeBSD, the headers are already ok, except for math.h.
+- fixincludes=fixinc.math
+ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
- # On FreeBSD, the headers are already ok, except for math.h.
- fixincludes=fixinc.math
++ if [[ "${OSVERSION}" -lt 600011 ]] ; \
++ then fixincludes=fixinc.math; \
++ else fixincludes=Makefile.in; \
++ fi
tmake_file=i386/t-freebsd
+ gas=yes
+ gnu_ld=yes
diff --git a/lang/gcc28/pkg-plist b/lang/gcc28/pkg-plist
index 5babd6041a0b..734f99e2cd57 100644
--- a/lang/gcc28/pkg-plist
+++ b/lang/gcc28/pkg-plist
@@ -43,7 +43,6 @@ info/gcc.info-9
@exec install-info %D/info/cpp.info %D/info/dir
@exec install-info %D/info/gcc.info %D/info/dir
lib/gcc-lib/%%GNUHOST%%/2.8.1/include/float.h
-lib/gcc-lib/%%GNUHOST%%/2.8.1/include/math.h
lib/gcc-lib/%%GNUHOST%%/2.8.1/include/syslimits.h
lib/gcc-lib/%%GNUHOST%%/2.8.1/include/typeinfo
lib/gcc-lib/%%GNUHOST%%/2.8.1/include/exception