aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc28
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-10-08 09:19:19 +0800
committerasami <asami@FreeBSD.org>1998-10-08 09:19:19 +0800
commit0f8e69c06703f6d837618637f907c5ca574d7096 (patch)
tree86f78e4a6757914cedaa706092145061926236a1 /lang/gcc28
parentdd2c0c7ea83e219d2817906e2ef94535a3faba0b (diff)
downloadfreebsd-ports-gnome-0f8e69c06703f6d837618637f907c5ca574d7096.tar.gz
freebsd-ports-gnome-0f8e69c06703f6d837618637f907c5ca574d7096.tar.zst
freebsd-ports-gnome-0f8e69c06703f6d837618637f907c5ca574d7096.zip
GNUHOST was defined twice. Also, take out the ELF cruft, a simple
BROKEN_ELF will do. :)
Diffstat (limited to 'lang/gcc28')
-rw-r--r--lang/gcc28/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/lang/gcc28/Makefile b/lang/gcc28/Makefile
index 58929c7374e2..0293b4b9aab1 100644
--- a/lang/gcc28/Makefile
+++ b/lang/gcc28/Makefile
@@ -4,7 +4,7 @@
# Date created: 17 Jan 1998
# Whom: David O'Brien <obrien@NUXI.com>
#
-# $Id: Makefile,v 1.14 1998/08/18 03:45:02 obrien Exp $
+# $Id: Makefile,v 1.15 1998/09/27 04:25:56 obrien Exp $
#
DISTNAME= gcc-2.8.1
@@ -13,6 +13,7 @@ MASTER_SITES= ${MASTER_SITE_GNU}
MAINTAINER= obrien@FreeBSD.org
+BROKEN_ELF= "/usr/lib/aout/crt0.o: file not recognized: File format not recognized"
PLIST_SUB= GNUHOST=${GNUHOST}
GNUHOST= i386-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --with-gxx-include-dir=${PREFIX}/lib/gcc-lib/${GNUHOST}/2.8.1/include/g++
@@ -52,10 +53,3 @@ post-install:
@${MV} ${PREFIX}/man/man1/gcc.1 ${PREFIX}/man/man1/gcc28.1
.include <bsd.port.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-BROKEN= "/usr/lib/aout/crt0.o: file not recognized: File format not recognized"
-GNUHOST= i386-unknown-freebsdelf
-.else
-GNUHOST= i386-unknown-freebsd
-.endif