aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc295
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-12-04 14:38:33 +0800
committertrevor <trevor@FreeBSD.org>2003-12-04 14:38:33 +0800
commitd237236e110e535871ab81821f7a7a4daaa77578 (patch)
tree35a203d8a8395e55f14796bee246e08ec936e237 /lang/gcc295
parent8a4e7bf24a7f20886924eb4e88e38fa6349c3d46 (diff)
downloadfreebsd-ports-gnome-d237236e110e535871ab81821f7a7a4daaa77578.tar.gz
freebsd-ports-gnome-d237236e110e535871ab81821f7a7a4daaa77578.tar.zst
freebsd-ports-gnome-d237236e110e535871ab81821f7a7a4daaa77578.zip
The __WORD_BIT constant in GCC's stl_bvector.h caused a namespace
conflict which kept the mailsync port from compiling. Resolve it.
Diffstat (limited to 'lang/gcc295')
-rw-r--r--lang/gcc295/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/gcc295/Makefile b/lang/gcc295/Makefile
index ac71f565fec2..878eccc21eec 100644
--- a/lang/gcc295/Makefile
+++ b/lang/gcc295/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 2.95.3
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= releases/${PKGNAME}
@@ -58,6 +59,11 @@ MAN1= cccp.1 g++295.1 gcc295.1
pre-patch:
@${MV} ${WRKSRC}/gcc/config/i386/freebsd.h ${WRKSRC}/gcc/config/i386/freebsd-aout.h
@${MV} ${WRKSRC}/gcc/config/i386/freebsd-elf.h ${WRKSRC}/gcc/config/i386/freebsd.h
+ @${MV} ${WRKSRC}/libstdc++/stl/stl_bvector.h \
+ ${WRKSRC}/libstdc++/stl/stl_bvector.h.orig
+ @${SED} -e "s,_WORD_BIT,_WORD_BIT_GCC295,g" \
+ < ${WRKSRC}/libstdc++/stl/stl_bvector.h.orig \
+ > ${WRKSRC}/libstdc++/stl/stl_bvector.h
pre-configure:
@(MAJ=`/sbin/sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \