aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc31
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2005-03-21 01:53:04 +0800
committeradamw <adamw@FreeBSD.org>2005-03-21 01:53:04 +0800
commit3693c01c5e61733362c8758991db200e8eccb759 (patch)
tree62ce9a9ea5bba92fd529dac75968da1842e91e2e /lang/gcc31
parent29f670f8ae52ff6c97295192471dcdd5134864cd (diff)
downloadfreebsd-ports-gnome-3693c01c5e61733362c8758991db200e8eccb759.tar.gz
freebsd-ports-gnome-3693c01c5e61733362c8758991db200e8eccb759.tar.zst
freebsd-ports-gnome-3693c01c5e61733362c8758991db200e8eccb759.zip
It was discovered that running "make clean" from a port with a dependency
on gcc31 or gcc32 (either with a BUILD_DEPENDS or via USE_GCC) with that version of gcc already installed causes infinite recursion problems. The issue stems from gcc31 and gcc32 using USE_GCC internally. Internally, it was used to override any other definition and say that you can use any gcc version to build gcc31/gcc32. But that USE_GCC redefinition was causing recursion errors, so handle the problem instead by just simply undefining USE_GCC inside the gcc port Makefile itself. This should make things happy again.
Diffstat (limited to 'lang/gcc31')
-rw-r--r--lang/gcc31/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/gcc31/Makefile b/lang/gcc31/Makefile
index 868edb3bcdac..8d651ce6b46b 100644
--- a/lang/gcc31/Makefile
+++ b/lang/gcc31/Makefile
@@ -42,8 +42,11 @@ CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
.error You have `USE_GCC' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
-# do not require Gcc 3.1 to compile -- or we have an infinate loop on RELENG_4.
-USE_GCC= 2.7+
+# Do not let USE_GCC be set here. We can't hardcode that gcc31 should require
+# gcc31 in order to build. Setting USE_GCC at all here causes recursion errors
+# when it clobbers the USE_GCC defined by other ports.
+.undef USE_GCC
+
NOMANCOMPRESS= yes # to hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>