aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc33
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2004-02-02 04:54:24 +0800
committergerald <gerald@FreeBSD.org>2004-02-02 04:54:24 +0800
commitd84695f38823637daa00456edc5bad81a6535e9b (patch)
treedca2dc3324752ac89fd2c747df4957dc7a65f8ba /lang/gcc33
parentbff8442c7ca57c561351f57ca2d25abfe3e34760 (diff)
downloadfreebsd-ports-gnome-d84695f38823637daa00456edc5bad81a6535e9b.tar.gz
freebsd-ports-gnome-d84695f38823637daa00456edc5bad81a6535e9b.tar.zst
freebsd-ports-gnome-d84695f38823637daa00456edc5bad81a6535e9b.zip
Consider another instance of the man pages not being generated if Perl 5.6
is not installed and move/adjust the previous hack. Reported by: bento Lee Harr <missive@hotmail.com> AMAKAWA Shuhei <sa264@cam.ac.uk>
Diffstat (limited to 'lang/gcc33')
-rw-r--r--lang/gcc33/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/gcc33/Makefile b/lang/gcc33/Makefile
index 9455e8204f5b..1cc1ed9fee46 100644
--- a/lang/gcc33/Makefile
+++ b/lang/gcc33/Makefile
@@ -148,7 +148,12 @@ post-install:
fi
.endfor
${MV} -f ${PREFIX}/bin/g7733 ${PREFIX}/bin/g77-33
- ${MV} -f ${PREFIX}/man/man1/g7733.1 ${PREFIX}/man/man1/g77-33.1
+ -${MV} -f ${PREFIX}/man/man1/g7733.1 ${PREFIX}/man/man1/g77-33.1
+ # man pages can only be generated if Perl >= 5.6 is installed, so
+ # fake them on 4.x systems.
+.for mp in ${_MANPAGES}
+ ( ${TEST} -e ${mp} || ${TOUCH} ${TOUCH_FLAGS} ${mp} )
+.endfor
# These libraries are moved from PREFIX/lib to avoid conflicts with
# the stock compiler.
.for f in libstdc++ libsupc++ libg2c libfrtbegin libobjc ${EXTRA_SHLIB}
@@ -158,11 +163,6 @@ post-install:
-${MV} -f ${PREFIX}/lib/libgcj.* ${TARGLIB}
${RM} -f ${PREFIX}/lib/libiberty.a
${RM} -f ${TARGLIB}/*.la
-# I am sick and tired of the anonyance that man pages can only be generated if
-# perl 5.6 is installed. This is becoming a royal PITA on non-5-CURRENT systems
-.for mp in ${_MANPAGES}
- ( ${TEST} -e ${mp} || ${TOUCH} ${TOUCH_FLAGS} ${mp} )
-.endfor
# Handle target libraries and GCJ include files.
${RM} -f ${WRKDIR}/PLIST.lib
.for d in ${TARGLIB:S/^${PREFIX}\///} include/gcj include/gnu include/java include/javax