aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc42/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2007-02-05 06:30:17 +0800
committergerald <gerald@FreeBSD.org>2007-02-05 06:30:17 +0800
commit4912c6838c68ebc5e6dd9fdc4e86aabc1edff566 (patch)
treeeb27dae98188b132256f21bd6253a01caf74ece5 /lang/gcc42/Makefile
parent217f01e09e135d906a68ccfcda26a5252423b16f (diff)
downloadfreebsd-ports-gnome-4912c6838c68ebc5e6dd9fdc4e86aabc1edff566.tar.gz
freebsd-ports-gnome-4912c6838c68ebc5e6dd9fdc4e86aabc1edff566.tar.zst
freebsd-ports-gnome-4912c6838c68ebc5e6dd9fdc4e86aabc1edff566.zip
Update to the 20070131 snapshot of GCC 4.2.0.
Move ia64 to NOT_FOR_ARCHS from BROKEN, like we did with lang/gcc43. Remove the cklatest target and files/patch-gengtype-yacc.y.
Diffstat (limited to 'lang/gcc42/Makefile')
-rw-r--r--lang/gcc42/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 9af6a600b152..b11287e3e787 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.2.0
-PORTREVISION= 20070124
+PORTREVISION= 20070131
CATEGORIES= lang java
VERSIONSTRING= 4.2-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC}
@@ -32,7 +32,7 @@ CONFLICTS?= gcc-withfortran-4.2.*
SUFFIX= 42
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
-NOT_FOR_ARCHS= alpha
+NOT_FOR_ARCHS= alpha ia64
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -48,10 +48,6 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
-BROKEN= Fails to build due to "illegal instruction" error
-.endif
-
.if ${OSVERSION} < 502102
CONFIGURE_ARGS+= --disable-libgomp
.endif
@@ -168,9 +164,4 @@ post-install:
${ECHO_CMD} "@unexec ${RMDIR} %D/libexec/gcc 2>&1 || true" >> ${WRKDIR}/PLIST.lib
cd ${WRKDIR} ; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
-cklatest:
-.for SITE in ftp://gcc.gnu.org/pub/gcc/snapshots/
- @-ncftpls -l ${SITE} | ${GREP} "LATEST.*${PORTVERSION:C/.[0-9]+$//}"
-.endfor
-
.include <bsd.port.post.mk>