aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc42
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2010-01-02 13:12:53 +0800
committergerald <gerald@FreeBSD.org>2010-01-02 13:12:53 +0800
commitb51d8c2d1661150b5cdcf4dd6e4e706409b1237c (patch)
tree3c954554e727d2d125008b930974c463bdd4b4b8 /lang/gcc42
parent0b509c332db651d34beba14e287d1e09092de9cd (diff)
downloadfreebsd-ports-gnome-b51d8c2d1661150b5cdcf4dd6e4e706409b1237c.tar.gz
freebsd-ports-gnome-b51d8c2d1661150b5cdcf4dd6e4e706409b1237c.tar.zst
freebsd-ports-gnome-b51d8c2d1661150b5cdcf4dd6e4e706409b1237c.zip
Remove some extra aspects brought in by the previous changeset, and
remove the WITH_JAVA_AWT knob. Discusssed with: glarkin
Diffstat (limited to 'lang/gcc42')
-rw-r--r--lang/gcc42/Makefile18
1 files changed, 1 insertions, 17 deletions
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 3cb0559152b3..84280b7a836e 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -16,7 +16,7 @@ DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX}
-MAINTAINER?= gerald@FreeBSD.org
+MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.2
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
@@ -32,7 +32,6 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
MAKE_JOBS_SAFE= yes
-WANT_GNOME= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
@@ -103,13 +102,6 @@ PLIST_SUB+= JAVA=""
post-patch::
@cd ${SRCDIR} && ${CHMOD} 755 ./contrib/download_ecj && ./contrib/download_ecj
-.if defined(WITH_JAVA_AWT)
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
-USE_GNOME= gtk20 libartlgpl2
-CONFIGURE_ARGS+= --enable-java-awt=gtk,xlib \
- --enable-gtk-cairo
-.endif
-
.else
CONFIGURE_ARGS+=--disable-libgcj
PLIST_SUB+= JAVA="@comment "
@@ -118,14 +110,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-pre-extract:
- @# Building libgcj with lang/gcc295 installed is causing a failure
- @# about "hidden symbol `__eprintf'" in libgcc.a(_eprintf.o).
- @if type gcc295 >/dev/null ; then \
- echo "This port will not build in the presence of lang/gcc295."; \
- exit 1; \
- fi
-
post-patch::
@${REINPLACE_CMD} -e 's|\(const char version_string.*\)";|\1 [FreeBSD]";|' \
${SRCDIR}/gcc/version.c