aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc44/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-05-27 17:14:32 +0800
committergerald <gerald@FreeBSD.org>2009-05-27 17:14:32 +0800
commitd0c78d2b51c020419c191581c1884611763f6098 (patch)
tree5350a4523870241572e2f7150348aeef43410958 /lang/gcc44/Makefile
parent536620cabad0ba418ddf6aa074adbd1efce9be7e (diff)
downloadfreebsd-ports-gnome-d0c78d2b51c020419c191581c1884611763f6098.tar.gz
freebsd-ports-gnome-d0c78d2b51c020419c191581c1884611763f6098.tar.zst
freebsd-ports-gnome-d0c78d2b51c020419c191581c1884611763f6098.zip
Update to the 20090526 snapshot of GCC 4.4.1.
Move the snapshot date from PORTREVISION to being a part of PORTVERSION to allow for PORTREVISION bumps. Simplify pre-everything and adjust PLIST_SUB accordingly. Move VERSIONSTRING down to pacify portlint after all those years and extract it from PORTVERSION, too.
Diffstat (limited to 'lang/gcc44/Makefile')
-rw-r--r--lang/gcc44/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 548e2b3732fd..6dc869c71200 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -7,10 +7,8 @@
#
PORTNAME= gcc
-PORTVERSION= 4.4.1
-PORTREVISION= 20090519
+PORTVERSION= 4.4.1.20090526
CATEGORIES= lang java
-VERSIONSTRING= 4.4-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
@@ -29,6 +27,7 @@ DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
+VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
@@ -71,7 +70,8 @@ CONFIGURE_ARGS+= --disable-nls \
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
-PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
+PLIST_SUB= GCC_VER=${PORTVERSION:C/(.+)\.[0-9]+/\1/} \
+ GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
g++${SUFFIX}.1 \
@@ -132,7 +132,7 @@ PLIST_SUB+= JAVA="@comment "
.endif
pre-everything::
- @${ECHO_MSG} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
+ @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
.if ! defined(WITHOUT_JAVA)
@DSIZ=700000; DSIZBYTE=734003200; \
if [ `ulimit -d` -lt $$DSIZ ]; then \