aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc46/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-11-20 08:03:20 +0800
committergerald <gerald@FreeBSD.org>2009-11-20 08:03:20 +0800
commitb33f7a191e36ece7c0cf69838d5a55d17e884493 (patch)
treecd534631a9ee9191bcbdda3869b27a75fd642cc3 /lang/gcc46/Makefile
parentf4d927a198be679522726152e26f0933a0771717 (diff)
downloadfreebsd-ports-gnome-b33f7a191e36ece7c0cf69838d5a55d17e884493.tar.gz
freebsd-ports-gnome-b33f7a191e36ece7c0cf69838d5a55d17e884493.tar.zst
freebsd-ports-gnome-b33f7a191e36ece7c0cf69838d5a55d17e884493.zip
No longer download Objective-C related files which we don't actually use.
Minor style changes. Adjust the ports description to the new style I am using for the various gcc ports and remove an obsolete note on memory consumption when building libgcj (the Java library).
Diffstat (limited to 'lang/gcc46/Makefile')
-rw-r--r--lang/gcc46/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 05ac9e889adb..ba557f6bcbc9 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
- gcc-objc-${VERSIONSTRING}${EXTRACT_SUFX}
+ gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
@@ -37,8 +36,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
-MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
+MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
@@ -61,7 +60,7 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+= --disable-nls \
+CONFIGURE_ARGS+=--disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--with-gmp=${LOCALBASE} \