aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc46
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-11-26 22:13:15 +0800
committergerald <gerald@FreeBSD.org>2013-11-26 22:13:15 +0800
commit823a1ff1d377fcaa16f8db20e42c02ac0012919f (patch)
tree79b7d19f958eb47c2ee6025925274956a7218310 /lang/gcc46
parent4899d51396489b06464322728522cb91a68516b8 (diff)
downloadfreebsd-ports-gnome-823a1ff1d377fcaa16f8db20e42c02ac0012919f.tar.gz
freebsd-ports-gnome-823a1ff1d377fcaa16f8db20e42c02ac0012919f.tar.zst
freebsd-ports-gnome-823a1ff1d377fcaa16f8db20e42c02ac0012919f.zip
Change PORTNAME for lang/gcc46 from gcc to gcc46 to match the actual
name of this port and avoid a package name collision with other GCC ports. This also allows us to remove LATEST_LINK. And it finally allows for a simple and proper CONFLICTS between lang/gcc and lang/gcc46.
Diffstat (limited to 'lang/gcc46')
-rw-r--r--lang/gcc46/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index e503b0ecb13c..6f92217948f0 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -1,13 +1,14 @@
# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
# $FreeBSD$
-PORTNAME= gcc
+PORTNAME= gcc46
PORTVERSION= 4.6.4
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= releases/gcc-${DISTVERSION}
+DISTNAME= gcc-${DISTVERSION}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.6
@@ -22,14 +23,13 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
-CONFLICTS= gcc-4.6.[123]*
+CONFLICTS= gcc-4.6.*
# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
# of executables and directories once installed.
DISTVERSION= ${PORTVERSION}
GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
-LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 ia64 powerpc sparc64
USES= gmake iconv perl5
USE_BINUTILS= yes