aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc47/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-05-30 17:32:25 +0800
committergerald <gerald@FreeBSD.org>2009-05-30 17:32:25 +0800
commitfc6c74fe7f0f914ee385ccc006152eeeb5692141 (patch)
treec74d320b61c6fa8d75f19710ed471c77e120bf9f /lang/gcc47/Makefile
parentcd3b918476eb4d7ac5b8b13ca74dc0b4e4a79a56 (diff)
downloadfreebsd-ports-gnome-fc6c74fe7f0f914ee385ccc006152eeeb5692141.tar.gz
freebsd-ports-gnome-fc6c74fe7f0f914ee385ccc006152eeeb5692141.tar.zst
freebsd-ports-gnome-fc6c74fe7f0f914ee385ccc006152eeeb5692141.zip
Update to the 20090528 snapshot of GCC 4.5.0.
Move the snapshot date from PORTREVISION to being a part of PORTVERSION to allow for PORTREVISION bumps. Simplify pre-everything and adjust PLIST_SUB accordingly. Move VERSIONSTRING down to pacify portlint after all those years and extract it from PORTVERSION, too.
Diffstat (limited to 'lang/gcc47/Makefile')
-rw-r--r--lang/gcc47/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index c3ceaf7d4b96..49c9dac3431d 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -7,10 +7,8 @@
#
PORTNAME= gcc
-PORTVERSION= 4.5.0
-PORTREVISION= 20090521
+PORTVERSION= 4.5.0.20090528
CATEGORIES= lang java
-VERSIONSTRING= 4.5-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
DISTFILES= gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
@@ -29,6 +27,7 @@ DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
+VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= alpha ia64 powerpc
@@ -71,7 +70,8 @@ CONFIGURE_ARGS+= --disable-nls \
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
-PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
+PLIST_SUB= GCC_VER=${PORTVERSION:C/(.+)\.[0-9]+/\1/} \
+ GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
g++${SUFFIX}.1 \
@@ -132,7 +132,7 @@ PLIST_SUB+= JAVA="@comment "
.endif
pre-everything::
- @${ECHO_MSG} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
+ @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
.if ! defined(WITHOUT_JAVA)
@DSIZ=700000; DSIZBYTE=734003200; \
if [ `ulimit -d` -lt $$DSIZ ]; then \