aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc47
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2007-04-10 02:34:53 +0800
committergerald <gerald@FreeBSD.org>2007-04-10 02:34:53 +0800
commit909295901455a5342ee91cc65f835144c1e2ca3b (patch)
treeff892dc14c6f68f8592ae7ba2e3adf4404cd09f2 /lang/gcc47
parent2e66d09e3fe042e78d6f9fc285726513c9e3c5c5 (diff)
downloadfreebsd-ports-gnome-909295901455a5342ee91cc65f835144c1e2ca3b.tar.gz
freebsd-ports-gnome-909295901455a5342ee91cc65f835144c1e2ca3b.tar.zst
freebsd-ports-gnome-909295901455a5342ee91cc65f835144c1e2ca3b.zip
Check for, and warn about the datasize limit, before trying to build
with Java support. PR: 111126 Suggested by: kris, cperciva
Diffstat (limited to 'lang/gcc47')
-rw-r--r--lang/gcc47/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 6c7f511cc2f2..dd905e8a54bd 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -135,6 +135,15 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
+.if ! defined(WITHOUT_JAVA)
+ @DSIZ=700000; DSIZBYTE=734003200; \
+ if [ `ulimit -d` -lt $$DSIZ ]; then \
+ echo "You need to increase the datasize limit to at least $$DSIZ \
+ (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
+ build with Java support." | ${FMT} -s; \
+ exit 1; \
+ fi
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|\(const char version_string.*\)";|\1 [FreeBSD]";|' \