aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc48/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-11-02 03:12:06 +0800
committergerald <gerald@FreeBSD.org>2012-11-02 03:12:06 +0800
commit0bdcb6f7b3081468d3aa203deaff3dfeb055ac52 (patch)
treeb604c63ce632704c448a4312af1b4f0d9b872768 /lang/gcc48/Makefile
parent007fcc9b4b3f491861150b5032a6cf0e2174d2ef (diff)
downloadfreebsd-ports-gnome-0bdcb6f7b3081468d3aa203deaff3dfeb055ac52.tar.gz
freebsd-ports-gnome-0bdcb6f7b3081468d3aa203deaff3dfeb055ac52.tar.zst
freebsd-ports-gnome-0bdcb6f7b3081468d3aa203deaff3dfeb055ac52.zip
Forward port inclusion and use of the Eclipse Java compiler. [1]
Update to the 20121014 snapshot of GCC 4.8.0. Submitted by: jkim [1] Feature safe: yes
Diffstat (limited to 'lang/gcc48/Makefile')
-rw-r--r--lang/gcc48/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 2de4432dfdf4..f47a6d15e50e 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 4.8.0.20120930
+PORTVERSION= 4.8.0.20121014
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
-DISTNAME= gcc-${VERSIONSTRING}
+DISTFILES= gcc-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.8
@@ -97,6 +97,11 @@ INFO+= gcc${SUFFIX}/libquadmath \
.endif
.if ${PORT_OPTIONS:MJAVA}
+ECJ_JAR= ecj-4.5.jar
+MASTER_SITES+= ${MASTER_SITE_SOURCEWARE:S|$|:ecj|}
+MASTER_SITE_SUBDIR+= java/:ecj
+DISTFILES+= ${ECJ_JAR}:ecj
+EXTRACT_ONLY= ${DISTFILES:S|${ECJ_JAR}:ecj||}
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
EXTRA_PATCHES+= ${FILESDIR}/java-patch-hier
LANGUAGES:= ${LANGUAGES},java
@@ -128,6 +133,10 @@ MAN3= ffi${SUFFIX}.3 \
INFO+= gcc${SUFFIX}/cp-tools \
gcc${SUFFIX}/gcj
PLIST_SUB+= JAVA=""
+
+# Prep the source tree for the GCJ build.
+post-patch::
+ @${CP} ${DISTDIR}/${ECJ_JAR} ${SRCDIR}/ecj.jar
.else
CONFIGURE_ARGS+=--disable-libgcj
PLIST_SUB+= JAVA="@comment "