aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc48/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2006-06-18 14:39:28 +0800
committergerald <gerald@FreeBSD.org>2006-06-18 14:39:28 +0800
commit69611a9fbc25590996b9427f5c9d366787721613 (patch)
tree9c50021b5311113757b303535191a48b54a88e84 /lang/gcc48/Makefile
parentdce86d72f460fc26f629cfc3bcca09f1202c66aa (diff)
downloadfreebsd-ports-gnome-69611a9fbc25590996b9427f5c9d366787721613.tar.gz
freebsd-ports-gnome-69611a9fbc25590996b9427f5c9d366787721613.tar.zst
freebsd-ports-gnome-69611a9fbc25590996b9427f5c9d366787721613.zip
Update to the 20060617 snapshot of GCC 4.2.0.
Employ the new USE_LDCONFIG feature, which allows us to get rid of the various, much more manual and error-prone hacks we needed so far. Reviewed by: flz (for lang/gcc40)
Diffstat (limited to 'lang/gcc48/Makefile')
-rw-r--r--lang/gcc48/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index c5511ac38475..2ccfbf995ae7 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.2.0
-PORTREVISION= 20060610
+PORTREVISION= 20060617
CATEGORIES= lang java
VERSIONSTRING= 4.2-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC}
@@ -71,11 +71,7 @@ CONFIGURE_ARGS+= --enable-java-awt=xlib,gtk
.endif
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= ${TARGLIB}
-SUB_LIST= TARGLIB="${TARGLIB}"
-SUB_FILES= gcc.sh
-RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
+USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -146,8 +142,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
- -@${MKDIR} ${PREFIX}/etc/rc.d
- ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
+ -@${MKDIR} ${PREFIX}/libdata/ldconfig
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \