aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc48/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2018-07-22 17:57:25 +0800
committergerald <gerald@FreeBSD.org>2018-07-22 17:57:25 +0800
commite912f32470f54e1173ddd514909eb2f579c64246 (patch)
tree26a367b46650ad7043e3ea1144b0c170e1cdbfb4 /lang/gcc48/Makefile
parent2739aa778ea5ba7e607abbb7c1b8c3f4be997fe1 (diff)
downloadfreebsd-ports-gnome-e912f32470f54e1173ddd514909eb2f579c64246.tar.gz
freebsd-ports-gnome-e912f32470f54e1173ddd514909eb2f579c64246.tar.zst
freebsd-ports-gnome-e912f32470f54e1173ddd514909eb2f579c64246.zip
Simplify the setting of CFLAGS where /g is not necessary when substituting
a Makefile variable (since this takes place for every word in the variable, not just once).
Diffstat (limited to 'lang/gcc48/Makefile')
-rw-r--r--lang/gcc48/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index fdb696fe99e1..2b2ea70ba984 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -61,7 +61,7 @@ CONFIGURE_ENV+= UNAME_m="powerpc64"
.if ${ARCH} == armv6
# Override sys.mk including -O in CFLAGS which breaks libgomp building.
-CFLAGS:= ${CFLAGS:S/-O/-O2/g}
+CFLAGS:= ${CFLAGS:S/-O/-O2/}
. if ${COMPILER_TYPE} == clang
. if empty(PORT_OPTIONS:MBOOTSTRAP)
MAKE_ARGS+=CXXFLAGS=-fbracket-depth=512