aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc48
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-12-01 19:36:59 +0800
committergerald <gerald@FreeBSD.org>2009-12-01 19:36:59 +0800
commit8ca6f369fe9114cdae3b2e742ff0fdec59ae9012 (patch)
tree1322504ff2c8f5313ef380fac7c78c85368da133 /lang/gcc48
parentdc15f262d1d65e1156c45ba2a7c59eaca5cbcf57 (diff)
downloadfreebsd-ports-gnome-8ca6f369fe9114cdae3b2e742ff0fdec59ae9012.tar.gz
freebsd-ports-gnome-8ca6f369fe9114cdae3b2e742ff0fdec59ae9012.tar.zst
freebsd-ports-gnome-8ca6f369fe9114cdae3b2e742ff0fdec59ae9012.zip
Use current GNU binutils from ports (devel/binutils) instead of the
system tools. The latter are half a decade old and fail to properly support modern CPUs and their standard features such as SSE or AVX in the case of AMD64/Intel64 which means that they even break when using a simple -march=native. On the way, sort CONFIGURE_ARGS. PR: 140995, 136607
Diffstat (limited to 'lang/gcc48')
-rw-r--r--lang/gcc48/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 85b49227f3c7..115e5cfd1576 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.0.20091126
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -21,6 +22,8 @@ COMMENT= GNU Compiler Collection 4.5
LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
mpfr.3:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.if defined(MAINTAINER_MODE)
DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
@@ -61,13 +64,14 @@ LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--disable-nls \
- --with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
- --with-gmp=${LOCALBASE} \
- --program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/
+ --program-suffix=${SUFFIX} \
+ --with-as=${LOCALBASE}/bin/as \
+ --with-gmp=${LOCALBASE} \
+ --with-gxx-include-dir=${TARGLIB}/include/c++/ \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}