aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc49/Makefile
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2014-12-31 03:19:43 +0800
committerdim <dim@FreeBSD.org>2014-12-31 03:19:43 +0800
commitf7a62eae9f2b1b4743ef86ef92eeefab94ac852b (patch)
tree0af12dad368a4835d12e33fca8152a87e478d0a2 /lang/gcc49/Makefile
parent47339e40c353eb9252f2dd15234d44a49a5ece62 (diff)
downloadfreebsd-ports-gnome-f7a62eae9f2b1b4743ef86ef92eeefab94ac852b.tar.gz
freebsd-ports-gnome-f7a62eae9f2b1b4743ef86ef92eeefab94ac852b.tar.zst
freebsd-ports-gnome-f7a62eae9f2b1b4743ef86ef92eeefab94ac852b.zip
When building the gcc ports using a full bootstrap, tell the configure
script to assume the BUILD_CONFIG is set to bootstrap-debug, instead of letting it auto-detect. With clang 3.5.0 this auto-detection can fail, due to a discrepancy [1] [2] in its debug information, when objects are produced with and without -g. When the auto-detection fails, gcc will compare objects with full debug information during the stage comparisons, and this sometimes causes those stage comparisons to fail unexpectedly. [1] http://lists.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20141222/250134.html [2] http://llvm.org/PR22046 Approved by: gerald (maintainer)
Diffstat (limited to 'lang/gcc49/Makefile')
-rw-r--r--lang/gcc49/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/gcc49/Makefile b/lang/gcc49/Makefile
index c6c163797c71..d5d2c6e1a0ef 100644
--- a/lang/gcc49/Makefile
+++ b/lang/gcc49/Makefile
@@ -69,6 +69,7 @@ GNU_CONFIGURE= yes
.if empty(PORT_OPTIONS:MBOOTSTRAP)
CONFIGURE_ARGS+=--disable-bootstrap
.else
+CONFIGURE_ARGS+=--with-build-config=bootstrap-debug
ALL_TARGET= bootstrap-lean
.endif
CONFIGURE_ARGS+=--disable-nls \