aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc49
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-06-26 17:00:57 +0800
committergerald <gerald@FreeBSD.org>2015-06-26 17:00:57 +0800
commitbbdbfe1a34b67f82c835563a06965b44f8236423 (patch)
treea01c4c1c0771039807f376d1e1d4d4e279741fe7 /lang/gcc49
parent3059f7aee291ac7ee0367677560e095e36a148ac (diff)
downloadfreebsd-ports-gnome-bbdbfe1a34b67f82c835563a06965b44f8236423.tar.gz
freebsd-ports-gnome-bbdbfe1a34b67f82c835563a06965b44f8236423.tar.zst
freebsd-ports-gnome-bbdbfe1a34b67f82c835563a06965b44f8236423.zip
Update to the 20150624 snapshot of GCC 4.9.3.
files/patch-pr63740-arm is no longer necessary, this has been addressed upstream now (thanks to andreast@).
Diffstat (limited to 'lang/gcc49')
-rw-r--r--lang/gcc49/Makefile2
-rw-r--r--lang/gcc49/distinfo4
-rw-r--r--lang/gcc49/files/patch-pr63740-arm14
3 files changed, 3 insertions, 17 deletions
diff --git a/lang/gcc49/Makefile b/lang/gcc49/Makefile
index 40afbf6e5dcb..1438d318885c 100644
--- a/lang/gcc49/Makefile
+++ b/lang/gcc49/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 4.9.3.s20150617
+PORTVERSION= 4.9.3.s20150624
CATEGORIES= lang java
MASTER_SITES= GCC/snapshots/${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}
diff --git a/lang/gcc49/distinfo b/lang/gcc49/distinfo
index dcf9c783ddcf..06313fafda61 100644
--- a/lang/gcc49/distinfo
+++ b/lang/gcc49/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-4.9-20150617.tar.bz2) = 10c4ac376f40674184891530e4cb323daf65fe182faf9241b370bc43856b7cfd
-SIZE (gcc-4.9-20150617.tar.bz2) = 85874465
+SHA256 (gcc-4.9-20150624.tar.bz2) = fb37f9ac1a49f1c454f63ae45c5e004ab714ba005e940fa6ca54aaa1b6611761
+SIZE (gcc-4.9-20150624.tar.bz2) = 85876805
diff --git a/lang/gcc49/files/patch-pr63740-arm b/lang/gcc49/files/patch-pr63740-arm
deleted file mode 100644
index 06c275eaf5b3..000000000000
--- a/lang/gcc49/files/patch-pr63740-arm
+++ /dev/null
@@ -1,14 +0,0 @@
---- gcc/lra-lives.c 2014/06/16 09:25:26 211700
-+++ gcc/lra-lives.c 2014/06/16 09:58:34 211701
-@@ -558,7 +558,11 @@
- /* It might be 'inheritance pseudo <- reload pseudo'. */
- || (src_regno >= lra_constraint_new_regno_start
- && ((int) REGNO (SET_DEST (set))
-- >= lra_constraint_new_regno_start))))
-+ >= lra_constraint_new_regno_start)
-+ /* Remember to skip special cases where src/dest regnos are
-+ the same, e.g. insn SET pattern has matching constraints
-+ like =r,0. */
-+ && src_regno != (int) REGNO (SET_DEST (set)))))
- {
- int hard_regno = -1, regno = -1;