aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc5/files
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-10-11 22:35:28 +0800
committergerald <gerald@FreeBSD.org>2017-10-11 22:35:28 +0800
commit87baf3c94a4c9c54bb3580574761a293f2a4b5f1 (patch)
tree2096e82a0c8c78b05aed549b490409a5eadba439 /lang/gcc5/files
parent75c66e320aaad6bfe802b063baf6451e221267bd (diff)
downloadfreebsd-ports-gnome-87baf3c94a4c9c54bb3580574761a293f2a4b5f1.tar.gz
freebsd-ports-gnome-87baf3c94a4c9c54bb3580574761a293f2a4b5f1.tar.zst
freebsd-ports-gnome-87baf3c94a4c9c54bb3580574761a293f2a4b5f1.zip
Update to the GCC 5.5 release. This brings more than 250 final bug
fixes compared to GCC 5.4 and is the last release planned on the GCC 5 branch which is now closed. files/patch-aarch64-support, files/patch-disable-armvhf-config.gcc, files/patch-libgcc-config-arm-unwind-arm, and files/patch-x86-64-fix-m16 all have been merged upstream in between GCC 5.4 and 5.5 and can thus be removed; the same is the case for most of files/patch-libc++. Finally, the tarball is now compressed using xz instead of bzip2. PR: 216266
Diffstat (limited to 'lang/gcc5/files')
-rw-r--r--lang/gcc5/files/patch-aarch64-support191
-rw-r--r--lang/gcc5/files/patch-disable-armvhf-config.gcc18
-rw-r--r--lang/gcc5/files/patch-libc++33
-rw-r--r--lang/gcc5/files/patch-libgcc-config-arm-unwind-arm51
-rw-r--r--lang/gcc5/files/patch-x86-64-fix-m1625
5 files changed, 0 insertions, 318 deletions
diff --git a/lang/gcc5/files/patch-aarch64-support b/lang/gcc5/files/patch-aarch64-support
deleted file mode 100644
index 976848aca11b..000000000000
--- a/lang/gcc5/files/patch-aarch64-support
+++ /dev/null
@@ -1,191 +0,0 @@
---- UTC
-Index: configure
-===================================================================
---- configure (revision 240731)
-+++ configure (working copy)
-@@ -3455,6 +3455,9 @@
- *-*-vxworks*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
-+ aarch64*-*-freebsd*)
-+ noconfigdirs="$noconfigdirs ${libgcj}"
-+ ;;
- alpha*-*-*vms*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
-Index: configure.ac
-===================================================================
---- configure.ac (revision 240731)
-+++ configure.ac (working copy)
-@@ -802,6 +802,9 @@
- *-*-vxworks*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
-+ aarch64*-*-freebsd*)
-+ noconfigdirs="$noconfigdirs ${libgcj}"
-+ ;;
- alpha*-*-*vms*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
-Index: gcc/config/aarch64/aarch64-freebsd.h
-===================================================================
---- gcc/config/aarch64/aarch64-freebsd.h (nonexistent)
-+++ gcc/config/aarch64/aarch64-freebsd.h (working copy)
-@@ -0,0 +1,99 @@
-+/* Definitions for AArch64 running FreeBSD
-+ Copyright (C) 2016 Free Software Foundation, Inc.
-+
-+ This file is part of GCC.
-+
-+ GCC is free software; you can redistribute it and/or modify it
-+ under the terms of the GNU General Public License as published by
-+ the Free Software Foundation; either version 3, or (at your option)
-+ any later version.
-+
-+ GCC is distributed in the hope that it will be useful, but
-+ WITHOUT ANY WARRANTY; without even the implied warranty of
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ General Public License for more details.
-+
-+ You should have received a copy of the GNU General Public License
-+ along with GCC; see the file COPYING3. If not see
-+ <http://www.gnu.org/licenses/>. */
-+
-+#ifndef GCC_AARCH64_FREEBSD_H
-+#define GCC_AARCH64_FREEBSD_H
-+
-+#undef SUBTARGET_CPP_SPEC
-+#define SUBTARGET_CPP_SPEC FBSD_CPP_SPEC
-+
-+#if TARGET_BIG_ENDIAN_DEFAULT
-+#define TARGET_LINKER_EMULATION "aarch64fbsdb"
-+#else
-+#define TARGET_LINKER_EMULATION "aarch64fbsd"
-+#endif
-+
-+#undef SUBTARGET_EXTRA_LINK_SPEC
-+#define SUBTARGET_EXTRA_LINK_SPEC " -m" TARGET_LINKER_EMULATION
-+
-+#undef FBSD_TARGET_LINK_SPEC
-+#define FBSD_TARGET_LINK_SPEC " \
-+ %{p:%nconsider using `-pg' instead of `-p' with gprof (1) } \
-+ %{v:-V} \
-+ %{assert*} %{R*} %{rpath*} %{defsym*} \
-+ %{shared:-Bshareable %{h*} %{soname*}} \
-+ %{symbolic:-Bsymbolic} \
-+ %{static:-Bstatic} \
-+ %{!static: \
-+ %{rdynamic:-export-dynamic} \
-+ %{!shared:-dynamic-linker " FBSD_DYNAMIC_LINKER " }} \
-+ -X" SUBTARGET_EXTRA_LINK_SPEC " \
-+ %{mbig-endian:-EB} %{mlittle-endian:-EL}"
-+
-+#if TARGET_FIX_ERR_A53_835769_DEFAULT
-+#define CA53_ERR_835769_SPEC \
-+ " %{!mno-fix-cortex-a53-835769:--fix-cortex-a53-835769}"
-+#else
-+#define CA53_ERR_835769_SPEC \
-+ " %{mfix-cortex-a53-835769:--fix-cortex-a53-835769}"
-+#endif
-+
-+#ifdef TARGET_FIX_ERR_A53_843419_DEFAULT
-+#define CA53_ERR_843419_SPEC \
-+ " %{!mno-fix-cortex-a53-843419:--fix-cortex-a53-843419}"
-+#else
-+#define CA53_ERR_843419_SPEC \
-+ " %{mfix-cortex-a53-843419:--fix-cortex-a53-843419}"
-+#endif
-+
-+#undef LINK_SPEC
-+#define LINK_SPEC FBSD_TARGET_LINK_SPEC \
-+ CA53_ERR_835769_SPEC \
-+ CA53_ERR_843419_SPEC
-+
-+#define GNU_USER_TARGET_MATHFILE_SPEC \
-+ "%{Ofast|ffast-math|funsafe-math-optimizations:crtfastmath.o%s}"
-+
-+#undef ENDFILE_SPEC
-+#define ENDFILE_SPEC \
-+ GNU_USER_TARGET_MATHFILE_SPEC " " \
-+ FBSD_ENDFILE_SPEC
-+
-+#undef TARGET_OS_CPP_BUILTINS
-+#define TARGET_OS_CPP_BUILTINS() \
-+ do \
-+ { \
-+ FBSD_TARGET_OS_CPP_BUILTINS (); \
-+ } \
-+ while (false)
-+
-+#define TARGET_ASM_FILE_END file_end_indicate_exec_stack
-+
-+/* Uninitialized common symbols in non-PIE executables, even with
-+ strong definitions in dependent shared libraries, will resolve
-+ to COPY relocated symbol in the executable. See PR65780. */
-+#undef TARGET_BINDS_LOCAL_P
-+#define TARGET_BINDS_LOCAL_P default_binds_local_p_2
-+
-+/* Use the AAPCS type for wchar_t, override the one from
-+ config/freebsd.h. */
-+#undef WCHAR_TYPE
-+#define WCHAR_TYPE "unsigned int"
-+
-+#endif /* GCC_AARCH64_FREEBSD_H */
-Index: gcc/config/aarch64/t-aarch64-freebsd
-===================================================================
---- gcc/config/aarch64/t-aarch64-freebsd (nonexistent)
-+++ gcc/config/aarch64/t-aarch64-freebsd (working copy)
-@@ -0,0 +1,21 @@
-+# Machine description for AArch64 architecture.
-+# Copyright (C) 2016 Free Software Foundation, Inc.
-+#
-+# This file is part of GCC.
-+#
-+# GCC is free software; you can redistribute it and/or modify it
-+# under the terms of the GNU General Public License as published by
-+# the Free Software Foundation; either version 3, or (at your option)
-+# any later version.
-+#
-+# GCC is distributed in the hope that it will be useful, but
-+# WITHOUT ANY WARRANTY; without even the implied warranty of
-+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+# General Public License for more details.
-+#
-+# You should have received a copy of the GNU General Public License
-+# along with GCC; see the file COPYING3. If not see
-+# <http://www.gnu.org/licenses/>.
-+
-+LIB1ASMSRC = aarch64/lib1funcs.asm
-+LIB1ASMFUNCS = _aarch64_sync_cache_range
-Index: gcc/config.gcc
-===================================================================
---- gcc/config.gcc (revision 240731)
-+++ gcc/config.gcc (working copy)
-@@ -914,6 +914,11 @@
- done
- TM_MULTILIB_CONFIG=`echo $TM_MULTILIB_CONFIG | sed 's/^,//'`
- ;;
-+aarch64*-*-freebsd*)
-+ tm_file="${tm_file} dbxelf.h elfos.h ${fbsd_tm_file}"
-+ tm_file="${tm_file} aarch64/aarch64-elf.h aarch64/aarch64-freebsd.h"
-+ tmake_file="${tmake_file} aarch64/t-aarch64 aarch64/t-aarch64-freebsd"
-+ ;;
- aarch64*-*-linux*)
- tm_file="${tm_file} dbxelf.h elfos.h gnu-user.h linux.h glibc-stdint.h"
- tm_file="${tm_file} aarch64/aarch64-elf.h aarch64/aarch64-linux.h"
-Index: libgcc/config.host
-===================================================================
---- libgcc/config.host (revision 240731)
-+++ libgcc/config.host (working copy)
-@@ -328,6 +328,11 @@
- tmake_file="${tmake_file} ${cpu_type}/t-aarch64"
- tmake_file="${tmake_file} ${cpu_type}/t-softfp t-softfp t-crtfm"
- ;;
-+aarch64*-*-freebsd*)
-+ extra_parts="$extra_parts crtfastmath.o"
-+ tmake_file="${tmake_file} ${cpu_type}/t-aarch64"
-+ tmake_file="${tmake_file} ${cpu_type}/t-softfp t-softfp t-crtfm"
-+ ;;
- aarch64*-*-linux*)
- extra_parts="$extra_parts crtfastmath.o"
- md_unwind_header=aarch64/linux-unwind.h
diff --git a/lang/gcc5/files/patch-disable-armvhf-config.gcc b/lang/gcc5/files/patch-disable-armvhf-config.gcc
deleted file mode 100644
index 7d9e4bb70524..000000000000
--- a/lang/gcc5/files/patch-disable-armvhf-config.gcc
+++ /dev/null
@@ -1,18 +0,0 @@
---- UTC
---- gcc/config.gcc.orig 2017-04-03 17:14:32.217141000 +0200
-+++ gcc/config.gcc 2017-04-03 17:15:05.626375000 +0200
-@@ -1026,11 +1026,9 @@
- case $target in
- armv6*-*-freebsd*)
- tm_defines="${tm_defines} TARGET_FREEBSD_ARMv6=1"
-- ;;
-- esac
-- case $target in
-- arm*hf-*-freebsd*)
-- tm_defines="${tm_defines} TARGET_FREEBSD_ARM_HARD_FLOAT=1"
-+ if test $fbsd_major -ge 11; then
-+ tm_defines="${tm_defines} TARGET_FREEBSD_ARM_HARD_FLOAT=1"
-+ fi
- ;;
- esac
- with_tls=${with_tls:-gnu}
diff --git a/lang/gcc5/files/patch-libc++ b/lang/gcc5/files/patch-libc++
index 9550b11f7c29..787bf30c7d49 100644
--- a/lang/gcc5/files/patch-libc++
+++ b/lang/gcc5/files/patch-libc++
@@ -1,36 +1,3 @@
---- gcc/auto-profile.c.orig 2015-01-18 02:25:42 UTC
-+++ gcc/auto-profile.c
-@@ -19,11 +19,9 @@ along with GCC; see the file COPYING3.
- <http://www.gnu.org/licenses/>. */
-
- #include "config.h"
--#include "system.h"
--
--#include <string.h>
- #include <map>
- #include <set>
-+#include "system.h"
-
- #include "coretypes.h"
- #include "hash-set.h"
---- gcc/graphite-isl-ast-to-gimple.c.orig 2017-01-19 21:02:12 UTC
-+++ gcc/graphite-isl-ast-to-gimple.c
-@@ -38,6 +38,7 @@ extern "C" {
- #endif
- #endif
-
-+#include <map>
- #include "system.h"
- #include "coretypes.h"
- #include "hash-set.h"
-@@ -75,7 +76,6 @@ extern "C" {
- #include "tree-scalar-evolution.h"
- #include "gimple-ssa.h"
- #include "tree-into-ssa.h"
--#include <map>
-
- #ifdef HAVE_isl
- #include "graphite-poly.h"
--- gcc/system.h.orig 2015-01-05 12:33:28 UTC
+++ gcc/system.h
@@ -217,6 +217,7 @@ extern int errno;
diff --git a/lang/gcc5/files/patch-libgcc-config-arm-unwind-arm b/lang/gcc5/files/patch-libgcc-config-arm-unwind-arm
deleted file mode 100644
index d332d2bf867a..000000000000
--- a/lang/gcc5/files/patch-libgcc-config-arm-unwind-arm
+++ /dev/null
@@ -1,51 +0,0 @@
---- UTC
---- libgcc/config/arm/unwind-arm.h.orig 2017-05-20 23:16:46.089160000 +0200
-+++ libgcc/config/arm/unwind-arm.h 2017-05-20 23:17:17.447204000 +0200
-@@ -72,12 +72,19 @@
- {
- return _URC_FAILURE;
- }
-+#ifndef __FreeBSD__
- /* Return the address of the instruction, not the actual IP value. */
- #define _Unwind_GetIP(context) \
- (_Unwind_GetGR (context, 15) & ~(_Unwind_Word)1)
-
- #define _Unwind_SetIP(context, val) \
- _Unwind_SetGR (context, 15, val | (_Unwind_GetGR (context, 15) & 1))
-+#else
-+ #undef _Unwind_GetIPInfo
-+ _Unwind_Ptr _Unwind_GetIP (struct _Unwind_Context *);
-+ _Unwind_Ptr _Unwind_GetIPInfo (struct _Unwind_Context *, int *);
-+ void _Unwind_SetIP (struct _Unwind_Context *, _Unwind_Ptr);
-+#endif
-
- #ifdef __cplusplus
- } /* extern "C" */
---- libgcc/config/arm/unwind-arm.c.orig 2017-05-20 23:16:46.089435000 +0200
-+++ libgcc/config/arm/unwind-arm.c 2017-05-20 23:17:17.447479000 +0200
-@@ -509,3 +509,25 @@
- {
- return __gnu_unwind_pr_common (state, ucbp, context, 2);
- }
-+
-+#ifdef __FreeBSD__
-+/* FreeBSD expects these to be functions */
-+inline _Unwind_Ptr
-+_Unwind_GetIP (struct _Unwind_Context *context)
-+{
-+ return _Unwind_GetGR (context, 15) & ~(_Unwind_Word)1;
-+}
-+
-+inline _Unwind_Ptr
-+_Unwind_GetIPInfo (struct _Unwind_Context *context, int *ip_before_insn)
-+{
-+ *ip_before_insn = 0;
-+ return _Unwind_GetIP (context);
-+}
-+
-+inline void
-+_Unwind_SetIP (struct _Unwind_Context *context, _Unwind_Ptr val)
-+{
-+ _Unwind_SetGR (context, 15, val | (_Unwind_GetGR (context, 15) & 1));
-+}
-+#endif
diff --git a/lang/gcc5/files/patch-x86-64-fix-m16 b/lang/gcc5/files/patch-x86-64-fix-m16
deleted file mode 100644
index 515c0952a29d..000000000000
--- a/lang/gcc5/files/patch-x86-64-fix-m16
+++ /dev/null
@@ -1,25 +0,0 @@
-At the moment the -m16 option only passes the "--32" parameter to the
-assembler on glibc OSes, while on other OSes the assembler is called
-without any specific flag. This is wrong and causes the assembler to
-fail. Fix it by adding support for the -m16 option to x86-64.h.
-
-2016-07-06 Roger Pau Monné <roger.pau@citrix.com>
-
- * x86-64.h: append --32 to the assembler options when -m16 is used
- even on non-glibc OSes.
-
-This should be backported to all stable branches up to 4.9 (when -m16 was
-introduced).
-
---- UTC
---- gcc/config/i386/x86-64.h
-+++ gcc/config/i386/x86-64.h
-@@ -49,7 +49,7 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
- #define WCHAR_TYPE_SIZE 32
-
- #undef ASM_SPEC
--#define ASM_SPEC "%{m32:--32} %{m64:--64} %{mx32:--x32}"
-+#define ASM_SPEC "%{m16|m32:--32} %{m64:--64} %{mx32:--x32}"
-
- #undef ASM_OUTPUT_ALIGNED_BSS
- #define ASM_OUTPUT_ALIGNED_BSS(FILE, DECL, NAME, SIZE, ALIGN) \