aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc5
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2016-06-06 22:01:42 +0800
committergerald <gerald@FreeBSD.org>2016-06-06 22:01:42 +0800
commit120c366cea226f0a8207265000b59bf7c9908414 (patch)
tree727fcdc15f635375794bd92ec709c129dac1c49e /lang/gcc5
parent0f87840759b094ed02f8716e4f5f07f9572a3b6d (diff)
downloadfreebsd-ports-gnome-120c366cea226f0a8207265000b59bf7c9908414.tar.gz
freebsd-ports-gnome-120c366cea226f0a8207265000b59bf7c9908414.tar.zst
freebsd-ports-gnome-120c366cea226f0a8207265000b59bf7c9908414.zip
Update to the GCC 5.4 release.
files/patch-build-without-bootstrap and files/patch-gcc-freebsd-powerpc64 (ELFv2 support for FreeBSD PowerPC64) are now upstream, so drop them. Due to timeing of the release freeze files/patch-armv6-hf-support has not been integrated in this upstream release yet.
Diffstat (limited to 'lang/gcc5')
-rw-r--r--lang/gcc5/Makefile2
-rw-r--r--lang/gcc5/distinfo5
-rw-r--r--lang/gcc5/files/patch-build-without-bootstrap25
-rw-r--r--lang/gcc5/files/patch-gcc-freebsd-powerpc6479
4 files changed, 4 insertions, 107 deletions
diff --git a/lang/gcc5/Makefile b/lang/gcc5/Makefile
index 9990f0ec8b62..960527691a84 100644
--- a/lang/gcc5/Makefile
+++ b/lang/gcc5/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 5.3.0
+PORTVERSION= 5.4.0
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}
diff --git a/lang/gcc5/distinfo b/lang/gcc5/distinfo
index 0465b7a07b89..55b33915874a 100644
--- a/lang/gcc5/distinfo
+++ b/lang/gcc5/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gcc-5.3.0.tar.bz2) = b84f5592e9218b73dbae612b5253035a7b34a9a1f7688d2e1bfaaf7267d5c4db
-SIZE (gcc-5.3.0.tar.bz2) = 95441837
+TIMESTAMP = 1464965789
+SHA256 (gcc-5.4.0.tar.bz2) = 608df76dec2d34de6558249d8af4cbee21eceddbcb580d666f7a5a583ca3303a
+SIZE (gcc-5.4.0.tar.bz2) = 95661481
diff --git a/lang/gcc5/files/patch-build-without-bootstrap b/lang/gcc5/files/patch-build-without-bootstrap
deleted file mode 100644
index 6bd7d528c9c3..000000000000
--- a/lang/gcc5/files/patch-build-without-bootstrap
+++ /dev/null
@@ -1,25 +0,0 @@
---- UTC
-Index: Makefile.def
-===================================================================
---- Makefile.def (revision 230942)
-+++ Makefile.def (working copy)
-@@ -534,6 +534,7 @@
- // on libgcc and newlib/libgloss.
- lang_env_dependencies = { module=libjava; cxx=true; };
- lang_env_dependencies = { module=libitm; cxx=true; };
-+lang_env_dependencies = { module=libffi; cxx=true; };
- lang_env_dependencies = { module=libcilkrts; cxx=true; };
- lang_env_dependencies = { module=liboffloadmic; cxx=true; };
- lang_env_dependencies = { module=newlib; no_c=true; };
-Index: Makefile.in
-===================================================================
---- Makefile.in (revision 230942)
-+++ Makefile.in (working copy)
-@@ -51034,6 +51034,7 @@
-
-
- configure-target-libffi: maybe-all-target-newlib maybe-all-target-libgloss
-+configure-target-libffi: maybe-all-target-libstdc++-v3
-
- configure-target-libjava: maybe-all-target-newlib maybe-all-target-libgloss
- configure-target-libjava: maybe-all-target-libstdc++-v3
diff --git a/lang/gcc5/files/patch-gcc-freebsd-powerpc64 b/lang/gcc5/files/patch-gcc-freebsd-powerpc64
deleted file mode 100644
index efa2f1155ae3..000000000000
--- a/lang/gcc5/files/patch-gcc-freebsd-powerpc64
+++ /dev/null
@@ -1,79 +0,0 @@
---- gcc/config/rs6000/freebsd64.h.orig 2015-12-23 21:56:41.030016000 +0100
-+++ gcc/config/rs6000/freebsd64.h 2015-12-23 21:56:28.343015000 +0100
-@@ -65,6 +65,13 @@
- #define INVALID_64BIT "-m%s not supported in this configuration"
- #define INVALID_32BIT INVALID_64BIT
-
-+/* Use LINUX64 instead of FREEBSD64 for compat with e.g. sysv4le.h */
-+#ifdef LINUX64_DEFAULT_ABI_ELFv2
-+#define ELFv2_ABI_CHECK (rs6000_elf_abi != 1)
-+#else
-+#define ELFv2_ABI_CHECK (rs6000_elf_abi == 2)
-+#endif
-+
- #undef SUBSUBTARGET_OVERRIDE_OPTIONS
- #define SUBSUBTARGET_OVERRIDE_OPTIONS \
- do \
-@@ -84,6 +91,12 @@
- rs6000_isa_flags &= ~OPTION_MASK_RELOCATABLE; \
- error (INVALID_64BIT, "relocatable"); \
- } \
-+ if (ELFv2_ABI_CHECK) \
-+ { \
-+ rs6000_current_abi = ABI_ELFv2; \
-+ if (dot_symbols) \
-+ error ("-mcall-aixdesc incompatible with -mabi=elfv2"); \
-+ } \
- if (rs6000_isa_flags & OPTION_MASK_EABI) \
- { \
- rs6000_isa_flags &= ~OPTION_MASK_EABI; \
-@@ -154,22 +167,7 @@
- { "link_os_freebsd_spec32", LINK_OS_FREEBSD_SPEC32 }, \
- { "link_os_freebsd_spec64", LINK_OS_FREEBSD_SPEC64 },
-
--#define FREEBSD_DYNAMIC_LINKER32 "/libexec/ld-elf32.so.1"
--#define FREEBSD_DYNAMIC_LINKER64 "/libexec/ld-elf.so.1"
--
--#define LINK_OS_FREEBSD_SPEC_DEF32 "\
-- %{p:%nconsider using `-pg' instead of `-p' with gprof(1)} \
-- %{v:-V} \
-- %{assert*} %{R*} %{rpath*} %{defsym*} \
-- %{shared:-Bshareable %{h*} %{soname*}} \
-- %{!shared: \
-- %{!static: \
-- %{rdynamic: -export-dynamic} \
-- %{!dynamic-linker:-dynamic-linker " FREEBSD_DYNAMIC_LINKER32 "}} \
-- %{static:-Bstatic}} \
-- %{symbolic:-Bsymbolic}"
--
--#define LINK_OS_FREEBSD_SPEC_DEF64 "\
-+#define LINK_OS_FREEBSD_SPEC_DEF "\
- %{p:%nconsider using `-pg' instead of `-p' with gprof(1)} \
- %{v:-V} \
- %{assert*} %{R*} %{rpath*} %{defsym*} \
-@@ -177,13 +175,13 @@
- %{!shared: \
- %{!static: \
- %{rdynamic: -export-dynamic} \
-- %{!dynamic-linker:-dynamic-linker " FREEBSD_DYNAMIC_LINKER64 "}} \
-+ %{!dynamic-linker:-dynamic-linker " FBSD_DYNAMIC_LINKER "}} \
- %{static:-Bstatic}} \
- %{symbolic:-Bsymbolic}"
-
--#define LINK_OS_FREEBSD_SPEC32 "-melf32ppc_fbsd " LINK_OS_FREEBSD_SPEC_DEF32
-+#define LINK_OS_FREEBSD_SPEC32 "-melf32ppc_fbsd " LINK_OS_FREEBSD_SPEC_DEF
-
--#define LINK_OS_FREEBSD_SPEC64 "-melf64ppc_fbsd " LINK_OS_FREEBSD_SPEC_DEF64
-+#define LINK_OS_FREEBSD_SPEC64 "-melf64ppc_fbsd " LINK_OS_FREEBSD_SPEC_DEF
-
- #undef MULTILIB_DEFAULTS
- #define MULTILIB_DEFAULTS { "m64" }
-@@ -304,7 +302,7 @@
-
- /* rs6000.h gets this wrong for FreeBSD. We use the GCC defaults instead. */
- #undef WCHAR_TYPE
--#define WCHAR_TYPE (TARGET_64BIT ? "int" : "long int")
-+
- #undef WCHAR_TYPE_SIZE
- #define WCHAR_TYPE_SIZE 32
-