aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc6-devel
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-06-04 12:57:44 +0800
committergerald <gerald@FreeBSD.org>2017-06-04 12:57:44 +0800
commit5c3430c194f61676899adab8bf573e96bdcd3cac (patch)
tree367131ca89861a9e8fe366e41b281c2ec0b0c344 /lang/gcc6-devel
parent3aa5ff2878ab5f1a05b67fc4b023b8d9375f5c06 (diff)
downloadfreebsd-ports-gnome-5c3430c194f61676899adab8bf573e96bdcd3cac.tar.gz
freebsd-ports-gnome-5c3430c194f61676899adab8bf573e96bdcd3cac.tar.zst
freebsd-ports-gnome-5c3430c194f61676899adab8bf573e96bdcd3cac.zip
Replace the general USE_GCC=yes when building for powerpc64 by the
specific USE_GCC=5 to be future proof when GCC 6 becomes the default (since USE_GCC=yes would then pull in lang/gcc6 which we obviously cannot require to build gcc6 itself nor gcc6-devel). This also helps users who play with GCC_DEFAULT in Mk/bsd.default-versions.mk. Reported by: jhibbits Discussed with: andreast
Diffstat (limited to 'lang/gcc6-devel')
-rw-r--r--lang/gcc6-devel/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/gcc6-devel/Makefile b/lang/gcc6-devel/Makefile
index 1f036bf8330d..b40e6393037d 100644
--- a/lang/gcc6-devel/Makefile
+++ b/lang/gcc6-devel/Makefile
@@ -72,7 +72,7 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.if ${ARCH} == powerpc64
CONFIGURE_ENV+= UNAME_m="powerpc64"
-USE_GCC= yes
+USE_GCC= 5 # Cannot require ourselves, needs to be at least 4.9.
.endif
.if ${ARCH} == "armv6" || ${ARCH} == "aarch64"