aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc7
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-09-18 01:51:24 +0800
committergerald <gerald@FreeBSD.org>2017-09-18 01:51:24 +0800
commit2fc2b3347a8fbdae4992e9c06226065fb5b711dd (patch)
tree51b3dbd69b4a59e78f3e2110b65d805bfcd972a2 /lang/gcc7
parent9ec3f59bcb5938d2db08761cc7cbde26d91e2dc4 (diff)
downloadfreebsd-ports-gnome-2fc2b3347a8fbdae4992e9c06226065fb5b711dd.tar.gz
freebsd-ports-gnome-2fc2b3347a8fbdae4992e9c06226065fb5b711dd.tar.zst
freebsd-ports-gnome-2fc2b3347a8fbdae4992e9c06226065fb5b711dd.zip
Do not quote constant strings compared with ${ARCH}. [1] Remove
some commented (and thus disabled) logic around this on the way. This brings the active lang/gcc* release-based ports in sync with their respective lang/gcc*-devel twins. PR: 221905 [1] Submitted by: linimon [1]
Diffstat (limited to 'lang/gcc7')
-rw-r--r--lang/gcc7/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/gcc7/Makefile b/lang/gcc7/Makefile
index bd4ff420abd3..0db3713551f7 100644
--- a/lang/gcc7/Makefile
+++ b/lang/gcc7/Makefile
@@ -51,7 +51,7 @@ CONFIGURE_ARGS+= --disable-multilib
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.endif
@@ -60,7 +60,7 @@ CONFIGURE_ENV+= UNAME_m="powerpc64"
USE_GCC= yes
.endif
-.if ${ARCH} == "armv6"
+.if ${ARCH} == armv6
. if ${COMPILER_TYPE} == clang
. if empty(PORT_OPTIONS:MBOOTSTRAP)
MAKE_ARGS+=CXXFLAGS+=-fbracket-depth=512
@@ -106,10 +106,8 @@ INFO= gcc${SUFFIX}/cpp \
gcc${SUFFIX}/gfortran \
gcc${SUFFIX}/libgomp
# Release tarballs (as opposed to snapshots) always carry this.
-#.if ${ARCH} == "amd64" || ${ARCH} == "i386"
INFO+= gcc${SUFFIX}/libquadmath \
gcc${SUFFIX}/libitm
-#.endif
SUB_FILES= pkg-message
SUB_LIST+= TARGLIB=${TARGLIB}