aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2016-08-14 15:28:13 +0800
committergerald <gerald@FreeBSD.org>2016-08-14 15:28:13 +0800
commit8bff0527d333463eb98cb8774d3888618a027fa7 (patch)
treefca98f8c42b4d0874362f27eb61c923ba64496be /lang/gcc
parent7c4ae51a3ccbb93691fda20dcec4f2e4372889f7 (diff)
downloadfreebsd-ports-gnome-8bff0527d333463eb98cb8774d3888618a027fa7.tar.gz
freebsd-ports-gnome-8bff0527d333463eb98cb8774d3888618a027fa7.tar.zst
freebsd-ports-gnome-8bff0527d333463eb98cb8774d3888618a027fa7.zip
GCC uses an AWK script to generate source code that helps process
command-line options. According to POSIX, string comparisons (and hence sorting) are to be performed based on the locale's collating order. Alas GNU AWK only does so in POSIX mode, whereas starting with FreeBSD 11 we do so by default, running into a bug (or false assumption) with that script used by GCC. Setting MAKE_ARGS such that AWK is always invoked in the C locale works around this bug. PR: 210122, 211742 Submitted by: jkim
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile5
-rw-r--r--lang/gcc/distinfo1
2 files changed, 5 insertions, 1 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index c86c9aab3c94..f922d3d62181 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -99,7 +99,10 @@ CONFIGURE_ARGS+=--disable-nls \
${ICONV_CONFIGURE_ARG} \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
-MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
+# On FreeBSD 11 and above AWK uses the locale's collating order which
+# runs into a bug in GCC (PR 211742).
+MAKE_ARGS+= MAKEINFOFLAGS="--no-split" \
+ AWK="${SETENV} LC_ALL=C ${AWK:Q}"
USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VERSION=${GCC_VERSION} \
GNU_HOST=${CONFIGURE_TARGET} \
diff --git a/lang/gcc/distinfo b/lang/gcc/distinfo
index b618f6667a4f..1b3d6dc0646e 100644
--- a/lang/gcc/distinfo
+++ b/lang/gcc/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1471124229
SHA256 (gcc-4.8.5.tar.bz2) = 22fb1e7e0f68a63cee631d85b20461d1ea6bda162f03096350e38c8d427ecf23
SIZE (gcc-4.8.5.tar.bz2) = 86165587